python-pex_1.1.4-1_all.deb


Advertisement

Description

python-pex - library for generating Python executable zip files

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pex
Package version: 1.1.4
Package release: 1
Package architecture: all
Package type: deb
Installed size: 294 B
Download size: 62.93 KB
Official Mirror: archive.ubuntu.com
pex is a library for generating .pex (Python EXecutable) files which are executable Python environments in the spirit of virtualenvs. pex is an expansion upon the ideas outlined in PEP 441 and makes the deployment of Python applications as simple as cp. pex files may even include multiple platform-specific Python distributions, meaning that a single pex file can be portable across Linux and OS X. pex files can be built using the pex tool. Build systems such as Pants and Buck also support building .pex files directly. This is the Python 2 library version.

Alternatives

    Download

    Source package: python-pex

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pex deb package:
      # sudo apt-get install python-pex

    Files

    • /usr/lib/python2.7/dist-packages/pex/__init__.py
    • /usr/lib/python2.7/dist-packages/pex/archiver.py
    • /usr/lib/python2.7/dist-packages/pex/base.py
    • /usr/lib/python2.7/dist-packages/pex/common.py
    • /usr/lib/python2.7/dist-packages/pex/compatibility.py
    • /usr/lib/python2.7/dist-packages/pex/compiler.py
    • /usr/lib/python2.7/dist-packages/pex/crawler.py
    • /usr/lib/python2.7/dist-packages/pex/environment.py
    • /usr/lib/python2.7/dist-packages/pex/fetcher.py
    • /usr/lib/python2.7/dist-packages/pex/finders.py
    • /usr/lib/python2.7/dist-packages/pex/http.py
    • /usr/lib/python2.7/dist-packages/pex/installer.py
    • /usr/lib/python2.7/dist-packages/pex/interpreter.py
    • /usr/lib/python2.7/dist-packages/pex/iterator.py
    • /usr/lib/python2.7/dist-packages/pex/link.py
    • /usr/lib/python2.7/dist-packages/pex/orderedset.py
    • /usr/lib/python2.7/dist-packages/pex/package.py
    • /usr/lib/python2.7/dist-packages/pex/pep425.py
    • /usr/lib/python2.7/dist-packages/pex/pex.py
    • /usr/lib/python2.7/dist-packages/pex/pex_bootstrapper.py
    • /usr/lib/python2.7/dist-packages/pex/pex_builder.py
    • /usr/lib/python2.7/dist-packages/pex/pex_info.py
    • /usr/lib/python2.7/dist-packages/pex/platforms.py
    • /usr/lib/python2.7/dist-packages/pex/requirements.py
    • /usr/lib/python2.7/dist-packages/pex/resolvable.py
    • /usr/lib/python2.7/dist-packages/pex/resolver.py
    • /usr/lib/python2.7/dist-packages/pex/resolver_options.py
    • /usr/lib/python2.7/dist-packages/pex/sorter.py
    • /usr/lib/python2.7/dist-packages/pex/testing.py
    • /usr/lib/python2.7/dist-packages/pex/tracer.py
    • /usr/lib/python2.7/dist-packages/pex/translator.py
    • /usr/lib/python2.7/dist-packages/pex/util.py
    • /usr/lib/python2.7/dist-packages/pex/variables.py
    • /usr/lib/python2.7/dist-packages/pex/version.py
    • /usr/lib/python2.7/dist-packages/pex-1.1.4.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/pex-1.1.4.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/pex-1.1.4.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/pex-1.1.4.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/pex-1.1.4.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/pex-1.1.4.egg-info/zip-safe
    • /usr/lib/python2.7/dist-packages/pex/bin/__init__.py
    • /usr/lib/python2.7/dist-packages/pex/bin/pex.py
    • /usr/lib/python2.7/dist-packages/pex/commands/__init__.py
    • /usr/lib/python2.7/dist-packages/pex/commands/bdist_pex.py
    • /usr/share/doc/python-pex/changelog.Debian.gz
    • /usr/share/doc/python-pex/copyright

    Changelog

    2016-03-22 - Barry Warsaw <barry@debian.org> python-pex (1.1.4-1) unstable; urgency=medium * New upstream release. * d/patches/bump-setuptools-max-version.patch: Update setuptools versions.

    2016-02-22 - Barry Warsaw <barry@debian.org> python-pex (1.1.2-1) unstable; urgency=medium * New upstream release. * d/control: - Bump Standards-Version to 3.9.7 with no other changes needed. - Update Vcs-Git header to https URL as per style guide. * d/tests/{control,execute.sh}: Revert Ubuntu accommodations. * d/patches: Updated by git-dpm. * d/rules: in override_dh_auto_clean, there's no need to remove the build/ directory explicitly, but we do need to remove the pex.1 file.

    2015-10-15 - Barry Warsaw <barry@debian.org> python-pex (1.1.0-2) unstable; urgency=medium * d/control: Canonicalize the Vcs-* headers as per team standard. * d/patches/bump-wheel-requirement-version.patch: Added. * d/README.pex: Removed; upstream now includes the docs directory. * d/python-pex-docs -> python-pex-doc.docs; fix the path. * d/rules: - Added override_dh_installdocs to build the Sphinx documentation. - Added override_dh_auto_clean to remove the doc build directory. * d/tests: - Rewrite the execution test so that it's compatible between both Ubuntu and Debian, negating the need for an Ubuntu delta. The extra required package is now conditionally installed depending on the dpkg-vendor. Also, by setting http_proxy and https_proxy to the discard port, we ensure that pex cannot install from PyPI (it must use system packages to resolve dependencies in the test). - d/t/execute.sh: Added. - d/t/control: Call execute.sh instead of using a Test-Command, and add the needs-root Restriction (for the conditional `apt-get install` in the script).

    2015-10-12 - Barry Warsaw <barry@debian.org> python-pex (1.1.0-1) unstable; urgency=medium * New upstream release. * d/control: Added python3-pkg-resources to pex Depends.

    2015-10-06 - Barry Warsaw <barry@debian.org> python-pex (1.0.3-2) unstable; urgency=medium * d/control: - Rename python-pex-cli binary package to pex. This now replaces/breaks earlier versions of python-pex-cli. (Closes: #801246) - Reintroduce python-pex-cli binary package as a virtual package. * d/rules: - Updated for binary package rename. * d/python-pex-cli.manpages -> d/pex.manpages. * d/tests/control: - Use Test-Command instead of a separate script. - Bump pex verbosity in the execution test. - Add "Restrictions: allow-stderr" for verbose execution test. - Add import tests for Python 2 and 3. * d/tests/smoketest: Remove.

    2015-08-13 - Barry Warsaw <barry@debian.org> python-pex (1.0.3-1) unstable; urgency=medium * New upstream release. * d/patches/bump-setuptools-max-version.patch: Bump the maximum allowed setuptools version to coincide with what's in Debian, which allows the manpages to be built. (Closes: #792521) * d/rules: Remove the overrides for upstream issue #51, which has been fixed released.

    2015-07-17 - Barry Warsaw <barry@debian.org> python-pex (1.0.1-1) unstable; urgency=medium * New upstream release.

    2015-06-02 - Barry Warsaw <barry@debian.org> python-pex (1.0.0-1) unstable; urgency=medium * New upstream release. * d/control, d/tests: Add a simple DEP-8 smoketest. * d/copyright: Reorganize to make lintian happy.

    2015-03-25 - Barry Warsaw <barry@debian.org> python-pex (0.8.6-2) unstable; urgency=medium * d/patches/handle-pkg_resources-devendorization.patch: Work around the Debian devendorization of pkg_resources, which wreaks havoc with the manipulations of sys that pex employs. (Closes: #781130) * d/patches/modern-install-requires.patch: Allow for setuptools 12.2, fixing the manpage build. (LP: #1435598)

    2015-02-19 - Barry Warsaw <barry@debian.org> python-pex (0.8.6-1) unstable; urgency=medium * Initial release. (Closes: #778708)

    Advertisement
    Advertisement