python-padme_1.1.1-2_all.deb


Advertisement

Description

python-padme - mostly transparent proxy class for Python 2

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-padme
Package version 1.1.1
Package release 2
Package architecture all
Package type deb
Installed size 99 B
Download size 16.69 KB
Official Mirror archive.ubuntu.com
Padme, named after the Star Wars (tm) character, is a library for creating
proxy objects out of any other Python object.
The resulting object is as close to mimicking the original as possible. Some
things are impossible to fake in CPython so those are highlighted below. All
other operations are silently forwarded to the original.
This package contains the Python 2.x version of the library

Alternatives

Package Version Architecture Repository
python-padme_1.1.1-2_all.deb 1.1.1 all Ubuntu Universe
python-padme - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-padme_1.1.1-2_all.deb
Source Package python-padme

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-padme deb package:
    # sudo apt-get install python-padme

Files

Path
/usr/lib/python2.7/dist-packages/padme/__init__.py
/usr/lib/python2.7/dist-packages/padme/tests.py
/usr/lib/python2.7/dist-packages/padme-1.1.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/padme-1.1.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/padme-1.1.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/padme-1.1.1.egg-info/zip-safe
/usr/share/doc/python-padme/changelog.Debian.gz
/usr/share/doc/python-padme/copyright

Changelog

2015-09-02 - Zygmunt Krynicki <zygmunt.krynicki@canonical.com>
python-padme (1.1.1-2) unstable; urgency=medium
* Improve compatibility with the most recent version of python-mock. This
fixes a build issue that occurs when padme tries to patch-away bugs in
mock that were fixed in the meantime. 
* Remove the autopkgtest header from debian/control (this is now standard)
* Bump Standards-Version to 3.9.6 (no change required)
2014-09-09 - Zygmunt Krynicki <zygmunt.krynicki@canonical.com>
python-padme (1.1.1-1) unstable; urgency=medium
* Initial release. (Closes: #780126)

See Also

Package Description
python-pager_3.3-1_all.deb terminal/console pager module in pure Python - Python 2.7
python-paisley_0.3.1-1_all.deb CouchDB client written in Python to be used within a Twisted application
python-pampy_1.8.2-1_all.deb Python module for simple PAM authentications (Python 2)
python-pandas-doc_0.17.1-3ubuntu2_all.deb documentation and examples for pandas
python-pandas-lib_0.17.1-3ubuntu2_amd64.deb low-level implementations and bindings for pandas
python-pandas_0.17.1-3ubuntu2_all.deb data structures for "relational" or "labeled" data
python-pandocfilters_1.2.2-1_all.deb python bindings for Pandoc's filters
python-parallel_0.2-7build1_all.deb pyparallel - module encapsulating access for the parallel port
python-park_1.0.0-1_all.deb persistent key-value API for Python with ordered traversal of keys
python-parse_1.6.6-0ubuntu1_all.deb Parse provides the reverse function for format()
python-parsley_1.2-1_all.deb pattern-matching language based on OMeta and Python
python-parted_3.10.7-2build1_amd64.deb Python interface for libparted
python-passfd_0.2-2_amd64.deb Python functions to pass file descriptors across UNIX domain
python-pastewebkit_1.0-7build1_all.deb port/reimplementation of Webware WebKit in WSGI and Paste
python-path_8.1.2+dfsg-1_all.deb module wrapper for os.path for Python 2
Advertisement
Advertisement