python-pacparser_1.3.6-1.1build1_amd64.deb


Advertisement

Description

python-pacparser - Python module to parse proxy auto-config files

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-pacparser
Package version: 1.3.6
Package release: 1.1build1
Package architecture: amd64
Package type: deb
Installed size: 1.30 KB
Download size: 318.47 KB
Official Mirror: archive.ubuntu.com
a library to parse proxy auto-config (PAC) files. Proxy auto-config files are a vastly used proxy configuration method these days. Web browsers can use a PAC file to determine which proxy server to use or whether to go direct for a given URL. PAC files are written in JavaScript and can be programmed to return different proxy methods (e.g. "PROXY proxy1:port; DIRECT") depending upon URL, source IP address, protocol, time of the day etc. PAC files introduce a lot of possibilities. Needless to say, PAC files are now a widely accepted method for proxy configuration management and companies all over are using them in corporate environments. Almost all popular web browsers support PAC files. The idea behind pacparser is to make it easy to add this PAC file parsing capability to any program (C and Python supported right now). This package contains the Python bindings for the shared library

Alternatives

    Download

    Source package: pacparser

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-pacparser deb package:
      # sudo apt-get install python-pacparser

    Files

    • /usr/lib/python2.7/dist-packages/pacparser-1.egg-info
    • /usr/lib/python2.7/dist-packages/pacparser/__init__.py
    • /usr/lib/python2.7/dist-packages/pacparser/_pacparser.x86_64-linux-gnu.so
    • /usr/share/doc/python-pacparser/changelog.Debian.gz
    • /usr/share/doc/python-pacparser/copyright
    • /usr/share/doc/python-pacparser/examples/fetchurl.py
    • /usr/share/doc/python-pacparser/examples/pactest.py
    • /usr/share/doc/python-pacparser/examples/wpad.dat

    Changelog

    2016-01-18 - Matthias Klose <doko@ubuntu.com> pacparser (1.3.6-1.1build1) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2016-01-11 - Scott Kitterman <scott@kitterman.com> pacparser (1.3.6-1.1) unstable; urgency=medium * Non-maintainer upload. (Closes: #809466) * Loop over supported python3 versions in build/install rules to add support for multiple python3 versions * Add removal of python build directory to clean rule * Slightly change python3-pacparser descriptions to distinguish from python- pacparser * Add libpacparser1 to libpacparser-dev depends for proper shared library package operation

    2015-09-04 - Manu Garg <manugarg@gmail.com> pacparser (1.3.6-1) unstable; urgency=medium * Sync to upstream version 1.3.6. * Fix debian/copyright. * List of upstream changes: https://goo.gl/eJrQRB

    2015-08-30 - Manu Garg <manugarg@gmail.com> pacparser (1.3.5-1) unstable; urgency=low * Sync to upstream version 1.3.5. * Apply a patch on top of that for debian hardening and document fixes. * Complete list of changes in upstream: https://github.com/pacparser/pacparser/releases

    2015-08-20 - Andrey Rahmatullin <wrar@debian.org> pacparser (1.3.0-2.1) unstable; urgency=medium * Non-maintainer upload. * Port from python-support to dh_python (Closes: #786034)

    2012-02-13 - Andrew Pollock <apollock@debian.org> pacparser (1.3.0-2) unstable; urgency=low * debian/control: Bumped Standards-Version (no changes)

    2011-09-10 - Manu Garg <manugarg@gmail.com> pacparser (1.3.0-1) unstable; urgency=low * Imported Upstream version 1.3.0

    2011-05-04 - Manu Garg <manugarg@gmail.com> pacparser (1.2.9-1) unstable; urgency=low * Imported Upstream version 1.2.9 * Fix the typo in last debian/changelog entry. * Add a config file for git-buildpackage to make it build in ../build-area directory so that original source remains clean.

    2011-03-16 - Manu Garg <manugarg@gmail.com> pacparser (1.2.7-1) unstable; urgency=low * Imported Upstream version 1.2.7 * Use source format 3.0 (quilt) * Add patch to skip the dns related post-build test, as network is assumed to be not available in the debian build environment.

    2011-01-07 - Andrew Pollock <apollock@debian.org> pacparser (1.2.6-3) unstable; urgency=low * debian/control: transfer maintenance to Manu Garg, with myself as an uploader

    Advertisement
    Advertisement