python-osmapi_0.6.2-1_all.deb


Advertisement

Description

python-osmapi - Python interface to OpenStreetMap API

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-osmapi
Package version 0.6.2
Package release 1
Package architecture all
Package type deb
Installed size 124 B
Download size 21.62 KB
Official Mirror archive.ubuntu.com
This package contains a Python module implementing the OpenStreetMap
API (version 0.6). The module allows access the OSM database, and
provides full featured manipulation of data using Python. Please note
that scripted imports and automated edits should only be carried out by
those with experience and understanding of the way the OpenStreetMap
community create maps, and only with careful planning and consultation.
This is the Python 2 version of the library.

Alternatives

Package Version Architecture Repository
python-osmapi_0.6.2-1_all.deb 0.6.2 all Ubuntu Universe
python-osmapi - - -

Requires

Name Value
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-osmapi_0.6.2-1_all.deb
Source Package python-osmapi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-osmapi deb package:
    # sudo apt-get install python-osmapi

Files

Path
/usr/lib/python2.7/dist-packages/osmapi-0.6.2.egg-info
/usr/lib/python2.7/dist-packages/osmapi/OsmApi.py
/usr/lib/python2.7/dist-packages/osmapi/__init__.py
/usr/share/doc/python-osmapi/CONTRIBUTING.md
/usr/share/doc/python-osmapi/README.md
/usr/share/doc/python-osmapi/changelog.Debian.gz
/usr/share/doc/python-osmapi/copyright

Changelog

2016-01-06 - Bas Couwenberg <sebastic@debian.org>
python-osmapi (0.6.2-1) unstable; urgency=medium
* New upstream release.
* Update Homepage URL to use HTTPS.
2015-05-30 - Bas Couwenberg <sebastic@debian.org>
python-osmapi (0.6.0-1) unstable; urgency=medium
* New upstream release.
* Install CONTRIBUTING.md in documentation.
2015-04-27 - Bas Couwenberg <sebastic@debian.org>
python-osmapi (0.5.0-1) unstable; urgency=medium
* Move from experimental to unstable.
2015-02-16 - Bas Couwenberg <sebastic@debian.org>
python-osmapi (0.5.0-1~exp2) experimental; urgency=medium
* Add ODbL-1.0 license for OSM test data.
* Update my email to @debian.org address.
2015-01-03 - Bas Couwenberg <sebastic@xs4all.nl>
python-osmapi (0.5.0-1~exp1) experimental; urgency=medium
* Initial upload (closes: #774508)

See Also

Package Description
python-otherstuf_1.1.0-0ubuntu1_all.deb Attribute accessible collections inspired by stuf
python-ow_3.1p1-2ubuntu1_amd64.deb Dallas 1-wire support: Python bindings
python-ownet_3.1p1-2ubuntu1_all.deb Python module for accessing 1-wire networks
python-owslib_0.10.3-1_all.deb Client library for Open Geospatial (OGC) web services (Python 2)
python-packaging_16.6-1_all.deb core utilities for python packages
python-pacparser_1.3.6-1.1build1_amd64.deb Python module to parse proxy auto-config files
python-padme_1.1.1-2_all.deb mostly transparent proxy class for Python 2
python-pager_3.3-1_all.deb terminal/console pager module in pure Python - Python 2.7
python-paisley_0.3.1-1_all.deb CouchDB client written in Python to be used within a Twisted application
python-pampy_1.8.2-1_all.deb Python module for simple PAM authentications (Python 2)
python-pandas-doc_0.17.1-3ubuntu2_all.deb documentation and examples for pandas
python-pandas-lib_0.17.1-3ubuntu2_amd64.deb low-level implementations and bindings for pandas
python-pandas_0.17.1-3ubuntu2_all.deb data structures for "relational" or "labeled" data
python-pandocfilters_1.2.2-1_all.deb python bindings for Pandoc's filters
python-parallel_0.2-7build1_all.deb pyparallel - module encapsulating access for the parallel port
Advertisement
Advertisement