python-notify_0.1.1-4_amd64.deb


Advertisement

Description

python-notify - Python bindings for libnotify

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-notify
Package version: 0.1.1
Package release: 4
Package architecture: amd64
Package type: deb
Installed size: 107 B
Download size: 15.21 KB
Official Mirror: archive.ubuntu.com
libnotify sends desktop notifications to a notification daemon, as defined in the Desktop Notifications spec. These notifications can be used to inform the user about an event or display some form of information without getting in the user's way. python-notify provides just the Python bindings for libnotify.

Alternatives

Provides

  • python2.7-notify

    Download

    Source package: notify-python

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-notify deb package:
      # sudo apt-get install python-notify

    Files

    • /usr/lib/pkgconfig/notify-python.pc
    • /usr/lib/python2.7/dist-packages/gtk-2.0/pynotify/__init__.py
    • /usr/lib/python2.7/dist-packages/gtk-2.0/pynotify/_pynotify.so
    • /usr/share/doc/python-notify/AUTHORS
    • /usr/share/doc/python-notify/NEWS.gz
    • /usr/share/doc/python-notify/changelog.Debian.gz
    • /usr/share/doc/python-notify/copyright
    • /usr/share/doc/python-notify/examples/applet-critical.png
    • /usr/share/doc/python-notify/examples/test-basic.py
    • /usr/share/doc/python-notify/examples/test-default-action.py
    • /usr/share/doc/python-notify/examples/test-image.py
    • /usr/share/doc/python-notify/examples/test-markup.py
    • /usr/share/doc/python-notify/examples/test-multi-actions.py
    • /usr/share/doc/python-notify/examples/test-replace-widget.py
    • /usr/share/doc/python-notify/examples/test-replace.py
    • /usr/share/doc/python-notify/examples/test-server-info.py
    • /usr/share/doc/python-notify/examples/test-urgency.py
    • /usr/share/doc/python-notify/examples/test-xy-stress.py
    • /usr/share/doc/python-notify/examples/test-xy.py
    • /usr/share/pygtk/2.0/defs/pynotify.defs

    Changelog

    2014-10-20 - Wookey <wookey@localhost> notify-python (0.1.1-4) unstable; urgency=medium * Use dh-autoreconf to keep uptodate for new architectures (Closes: 765237)

    2011-08-02 - Scott Kitterman <scott@kitterman.com> notify-python (0.1.1-3) unstable; urgency=low * Team upload [ Sandro Tosi ] * debian/control - uniforming both Vcs-Svn and Vcs-Browser fields * debian/control - switch Vcs-Browser field to viewsvn [ Carlos Galisteo ] * debian/control - Added Homepage field. [ Sebastien Bacher ] * new_libnotify.patch: updated for the new libnotify api changes; closes: #630292 (thanks to Jérémy Bobbio for finding the patch) [ Barry Warasaw ] * Switch to dh_python2 closes: #635452 [ Scott Kitterman ] * Don't ship .la file (Change from Ubuntu)

    2007-12-06 - Loic Minier <lool@dooz.org> notify-python (0.1.1-2) unstable; urgency=low [ Scott Kitterman ] * debian/rules: Remove src/pynotify.c on clean, so that it actually gets regenerated on build. Otherwise some functions like attach_to_status_icon() are missing. [ Piotr Ożarowski ] * Rename XS-Vcs-Svn field to Vcs-Svn * Add Vcs-Browser field [ Loic Minier ] * Add /svn to the Vcs-Svn URL to allow copy-paste in svn+ssh:// URLs. :-P * Depends on ${misc:Depends}. * Fix usage of spaces versus tab in rules; the fix for #434714 was in place, but had a syntax error; thanks Martin Pitt; closes: #434714. * Ship some testsuite scripts as examples; thanks Sebastien Bacher; closes: #440244. * Rewrite build completely without the autotools CDBS class and configure, make, and make install for each requested Python version; closes: #438928.

    2007-06-25 - Loic Minier <lool@dooz.org> notify-python (0.1.1-1) unstable; urgency=low [ Piotr Ozarowski ] * Added XS-Vcs-Svn field [ Loic Minier ] * Misc cleanups. * Update URL in copyright. * Set XS and XB-PV instead of debian/pyversions. * Only call dh_pysupport and not dh_python; fixup CDBS rule. * Use ${shlibs:Depends} instead of hardcoding the libnotify1 dependency. * New upstream release; closes: #425766. - Bump up libnotify-dev build-dep to >= 0.4.3. - Bump up python-gtk2-dev build-dep and python-gtk2 dep to >= 2.10 for gtk.StatusIcon.

    2006-07-04 - Gustavo Franco <stratus@debian.org> notify-python (0.1.0-1) unstable; urgency=low * Initial release (Closes: #366863)

    Advertisement
    Advertisement