python-nose_1.3.7-1_all.deb


Advertisement

Description

python-nose - test discovery and running of Python's unittest

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-nose
Package version 1.3.7
Package release 1
Package architecture all
Package type deb
Installed size 538 B
Download size 112.90 KB
Official Mirror archive.ubuntu.com
nose provides an alternate test discovery and running process for
unittest, one that is intended to mimic the behavior of py.test as
much as is reasonably possible without resorting to too much magic

Alternatives

Package Version Architecture Repository
python-nose_1.3.7-1_all.deb 1.3.7 all Ubuntu Universe
python-nose - - -

Requires

Name Value
python-pkg-resources -
python2.7:any -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-nose_1.3.7-1_all.deb
Source Package nose

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-nose deb package:
    # sudo apt-get install python-nose

Files

Path
/usr/bin/nosetests
/usr/bin/nosetests-2.7
/usr/lib/python2.7/dist-packages/nose/__init__.py
/usr/lib/python2.7/dist-packages/nose/__main__.py
/usr/lib/python2.7/dist-packages/nose/case.py
/usr/lib/python2.7/dist-packages/nose/commands.py
/usr/lib/python2.7/dist-packages/nose/config.py
/usr/lib/python2.7/dist-packages/nose/core.py
/usr/lib/python2.7/dist-packages/nose/exc.py
/usr/lib/python2.7/dist-packages/nose/failure.py
/usr/lib/python2.7/dist-packages/nose/importer.py
/usr/lib/python2.7/dist-packages/nose/inspector.py
/usr/lib/python2.7/dist-packages/nose/loader.py
/usr/lib/python2.7/dist-packages/nose/proxy.py
/usr/lib/python2.7/dist-packages/nose/pyversion.py
/usr/lib/python2.7/dist-packages/nose/result.py
/usr/lib/python2.7/dist-packages/nose/selector.py
/usr/lib/python2.7/dist-packages/nose/suite.py
/usr/lib/python2.7/dist-packages/nose/twistedtools.py
/usr/lib/python2.7/dist-packages/nose/usage.txt
/usr/lib/python2.7/dist-packages/nose/util.py
/usr/lib/python2.7/dist-packages/nose-1.3.7.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/nose-1.3.7.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/nose-1.3.7.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/nose-1.3.7.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/nose-1.3.7.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/nose/ext/__init__.py
/usr/lib/python2.7/dist-packages/nose/ext/dtcompat.py
/usr/lib/python2.7/dist-packages/nose/plugins/__init__.py
/usr/lib/python2.7/dist-packages/nose/plugins/allmodules.py
/usr/lib/python2.7/dist-packages/nose/plugins/attrib.py
/usr/lib/python2.7/dist-packages/nose/plugins/base.py
/usr/lib/python2.7/dist-packages/nose/plugins/builtin.py
/usr/lib/python2.7/dist-packages/nose/plugins/capture.py
/usr/lib/python2.7/dist-packages/nose/plugins/collect.py
/usr/lib/python2.7/dist-packages/nose/plugins/cover.py
/usr/lib/python2.7/dist-packages/nose/plugins/debug.py
/usr/lib/python2.7/dist-packages/nose/plugins/deprecated.py
/usr/lib/python2.7/dist-packages/nose/plugins/doctests.py
/usr/lib/python2.7/dist-packages/nose/plugins/errorclass.py
/usr/lib/python2.7/dist-packages/nose/plugins/failuredetail.py
/usr/lib/python2.7/dist-packages/nose/plugins/isolate.py
/usr/lib/python2.7/dist-packages/nose/plugins/logcapture.py
/usr/lib/python2.7/dist-packages/nose/plugins/manager.py
/usr/lib/python2.7/dist-packages/nose/plugins/multiprocess.py
/usr/lib/python2.7/dist-packages/nose/plugins/plugintest.py
/usr/lib/python2.7/dist-packages/nose/plugins/prof.py
/usr/lib/python2.7/dist-packages/nose/plugins/skip.py
/usr/lib/python2.7/dist-packages/nose/plugins/testid.py
/usr/lib/python2.7/dist-packages/nose/plugins/xunit.py
/usr/lib/python2.7/dist-packages/nose/sphinx/__init__.py
/usr/lib/python2.7/dist-packages/nose/sphinx/pluginopts.py
/usr/lib/python2.7/dist-packages/nose/tools/__init__.py
/usr/lib/python2.7/dist-packages/nose/tools/nontrivial.py
/usr/lib/python2.7/dist-packages/nose/tools/trivial.py
/usr/share/doc/python-nose/changelog.Debian.gz
/usr/share/doc/python-nose/copyright
/usr/share/man/man1/nosetests-2.7.1.gz
/usr/share/man/man1/nosetests.1.gz

Changelog

2016-02-03 - Dmitry Shachnev <mitya57@debian.org>
nose (1.3.7-1) unstable; urgency=medium
[ Brian May ]
* New upstream version.
[ Dmitry Shachnev ]
* Backport upstream commit that fixes tests failures with Python 3.5
(closes: #811468).
* Use HTTPS in Vcs-Git field and in debian/watch.
* Override Lintian false-positive warning about missing source for
unit_tests/support/doctest/noname_wrapped.not_pyc.
2015-04-10 - Dmitry Shachnev <mitya57@debian.org>
nose (1.3.6-1) unstable; urgency=medium
* New upstream bugfix release.
* Update debian/watch to use pypi.debian.net redirector.
* Bump debhelper compatibility level to 9.
* Bump Standards-Version to 3.9.6, no changes needed.
* Add John Szakmeister’s key to debian/upstream/signing-key.asc,
and tell uscan to verify it via debian/watch.
* Explicitly build-depend on dh-python.
2014-12-01 - Gustavo Noronha Silva <kov@debian.org>
nose (1.3.4-2) unstable; urgency=medium
* Change maintainer to the team.
2014-09-02 - Dmitry Shachnev <mitya57@debian.org>
nose (1.3.4-1) unstable; urgency=medium
* New upstream bugfix release.
* debian/patches/fix_constructor: drop, applied upstream.
* Update my email address.
* Update debian/copyright.
2014-08-11 - Brian May <bam@debian.org>
nose (1.3.3-2) unstable; urgency=low
* Add patch to make sure we call super constructor for LazySuite. Without
this, tests fail under Python3.4 as _removed_tests not defined. Patch
copied from https://github.com/nose-devs/nose/pull/811 which has been
included upstream in git. Closes: #757640.
2014-05-26 - Dmitry Shachnev <mitya57@gmail.com>
nose (1.3.3-1) unstable; urgency=medium
* New upstream bugfix release.
2014-05-04 - Dmitry Shachnev <mitya57@gmail.com>
nose (1.3.2-1) unstable; urgency=medium
* New upstream bugfix release.
* Drop patches applied upstream (for issues 780, 782, 783 and 788).
* Refresh disable-unstable-tests patch.
2014-03-28 - Dmitry Shachnev <mitya57@gmail.com>
nose (1.3.1-2) unstable; urgency=medium
* Backport a patch (issue780) to fix UnboundMethod regression with
Python 3.
* Add myself to Uploaders.
2014-03-19 - Dmitry Shachnev <mitya57@gmail.com>
nose (1.3.1-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Drop d/patches/issue759, applied in the new version.
* Add three new patches (issue782, issue783 and issue788) to fix
various test failures (closes: #741750).
* Disable one more unstable test.
* Remove unit_tests/support/doctest/noname_wrapped.not_pyc in
clean target.
2014-02-12 - Dmitry Shachnev <mitya57@gmail.com>
nose (1.3.0-3) unstable; urgency=medium
* Team upload.
* d/patches/issue759: Add a patch from Barry Warsaw to fix FTBFS
with Python 3.4. 
* d/control: Bump Standards-Version to 3.9.5, no changes needed.
* Rebuild closes: #730749.

See Also

Package Description
python-nosehtmloutput_0.0.4-3_all.deb plugin to produce test results in html
python-nosexcover_1.0.10-2_all.deb Add Cobertura-style XML coverage report to nose
python-notify2_0.3-3_all.deb desktop notifications API for Python
python-notify_0.1.1-4_amd64.deb Python bindings for libnotify
python-notmuch_0.21-3ubuntu2_all.deb python interface to the notmuch mail search and index library
python-nova-adminclient_0.1.8-0ubuntu2_amd64.deb client for administering Openstack Nova
python-nova.lxd_13.0.0-0ubuntu3_all.deb transitional dummy package for python-nova.lxd
python-novnc_0.4+dfsg+1+20131010+gitf68af8af3d-4_all.deb HTML5 VNC client - libraries
python-ns3_3.22+dfsg-2build1_amd64.deb Python binding of ns3
python-nss_0.16.0-1_amd64.deb Python bindings for Network Security Services (NSS)
python-ntdb_1.0-9_amd64.deb Python bindings for NTDB
python-ntlm_1.1.0-1_all.deb Python library that provides NTLM support
python-ntplib_0.3.1-1_all.deb Python NTP library
python-numexpr_2.4.3-1ubuntu1_amd64.deb Fast numerical array expression evaluator for Python and NumPy
python-numpydoc_0.5-2_all.deb Sphinx extension to support docstrings in Numpy format
Advertisement
Advertisement