python-nose-parameterized_0.3.4-3_all.deb


Advertisement

Description

python-nose-parameterized - decorator for parameterized testing with Nose - Python 2.x

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-nose-parameterized
Package version 0.3.4
Package release 3
Package architecture all
Package type deb
Installed size 34 B
Download size 6.83 KB
Official Mirror archive.ubuntu.com
nose-parameterized is a decorator for parameterized testing of Python code
with nose.
The provided decorators make it simple to pass lists, iterables, tuples or
callables to the test functions. This allows you to separate the data from the
test without having to subclass unittest.testcase.
This package contains the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-nose-parameterized_0.3.4-3_all.deb 0.3.4 all Ubuntu Universe
python-nose-parameterized - - -

Requires

Name Value
python-nose -
python:any << 2.8
python:any >= 2.7.5-5~

Download

Type URL
Binary Package python-nose-parameterized_0.3.4-3_all.deb
Source Package python-nose-parameterized

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-nose-parameterized deb package:
    # sudo apt-get install python-nose-parameterized

Files

Path
/usr/lib/python2.7/dist-packages/nose_parameterized/__init__.py
/usr/lib/python2.7/dist-packages/nose_parameterized/compat.py
/usr/lib/python2.7/dist-packages/nose_parameterized/parameterized.py
/usr/lib/python2.7/dist-packages/nose_parameterized/test.py
/usr/lib/python2.7/dist-packages/nose_parameterized-0.3.4.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/nose_parameterized-0.3.4.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/nose_parameterized-0.3.4.egg-info/top_level.txt
/usr/share/doc/python-nose-parameterized/changelog.Debian.gz
/usr/share/doc/python-nose-parameterized/copyright

Changelog

2015-09-22 - Thomas Goirand <zigo@debian.org>
python-nose-parameterized (0.3.4-3) unstable; urgency=medium
[ Ivan Udovichenko ]
* Remove Pre-Depends field from debian/control .
* Add python-nose and python3-nose as a dependency.
[ Thomas Goirand ]
* Added missing dh-python.
* Removed version in python-all build-depends.
* Watch file now using the PyPi redirector.
* Fixed gbp.conf.
2014-11-03 - Thomas Goirand <zigo@debian.org>
python-nose-parameterized (0.3.4-2) unstable; urgency=medium
* Using the new package long description from Guido G√ľnther <agx@sigxcpu.org>,
big thanks a lot to him!
2014-10-31 - Thomas Goirand <zigo@debian.org>
python-nose-parameterized (0.3.4-1) unstable; urgency=medium
* Initial release. (Closes: #767515)

See Also

Package Description
python-nose-testconfig_0.9-1_all.deb test configuration plugin for nosetests
python-nose-timer_0.3.0-2_all.deb timer plugin for nosetests - Python 2.x
python-nose-yanc_0.3.3-2_all.deb Color output plugin for nose
python-nose2-cov_1.0a4-2_all.deb nose2 plugin for coverage reporting
python-nose2-doc_0.6.4-1_all.deb next generation of nicer testing for Python (documentation)
python-nose2_0.6.4-1_all.deb next generation of nicer testing for Python (Python 2)
python-nose_1.3.7-1_all.deb test discovery and running of Python's unittest
python-nosehtmloutput_0.0.4-3_all.deb plugin to produce test results in html
python-nosexcover_1.0.10-2_all.deb Add Cobertura-style XML coverage report to nose
python-notify2_0.3-3_all.deb desktop notifications API for Python
python-notify_0.1.1-4_amd64.deb Python bindings for libnotify
python-notmuch_0.21-3ubuntu2_all.deb python interface to the notmuch mail search and index library
python-nova-adminclient_0.1.8-0ubuntu2_amd64.deb client for administering Openstack Nova
python-nova.lxd_13.0.0-0ubuntu3_all.deb transitional dummy package for python-nova.lxd
python-novnc_0.4+dfsg+1+20131010+gitf68af8af3d-4_all.deb HTML5 VNC client - libraries
Advertisement
Advertisement