python-ngs_1.2.3-2_amd64.deb


Advertisement

Description

python-ngs - Next Generation Sequencing language Bindings (Python bindings)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-ngs
Package version: 1.2.3
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 135 B
Download size: 15.28 KB
Official Mirror: archive.ubuntu.com
NGS is a new, domain-specific API for accessing reads, alignments and pileups produced from Next Generation Sequencing. The API itself is independent from any particular back-end implementation, and supports use of multiple back-ends simultaneously. It also provides a library for building new back-end "engines". The engine for accessing SRA data is contained within the sister repository ncbi-vdb. The API is currently expressed in C++, Java and Python languages. The design makes it possible to maintain a high degree of similarity between the code in one language and code in another - especially between C++ and Java. Python bindings.

Alternatives

    Download

    Source package: ngs-sdk

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-ngs deb package:
      # sudo apt-get install python-ngs

    Files

    • /usr/lib/python2.7/dist-packages/ngs-1.0.egg-info
    • /usr/lib/python2.7/dist-packages/ngs/Alignment.py
    • /usr/lib/python2.7/dist-packages/ngs/AlignmentIterator.py
    • /usr/lib/python2.7/dist-packages/ngs/ErrorMsg.py
    • /usr/lib/python2.7/dist-packages/ngs/Fragment.py
    • /usr/lib/python2.7/dist-packages/ngs/FragmentIterator.py
    • /usr/lib/python2.7/dist-packages/ngs/LibChecker.py
    • /usr/lib/python2.7/dist-packages/ngs/LibManager.py
    • /usr/lib/python2.7/dist-packages/ngs/Package.py
    • /usr/lib/python2.7/dist-packages/ngs/Pileup.py
    • /usr/lib/python2.7/dist-packages/ngs/PileupEvent.py
    • /usr/lib/python2.7/dist-packages/ngs/PileupEventIterator.py
    • /usr/lib/python2.7/dist-packages/ngs/PileupIterator.py
    • /usr/lib/python2.7/dist-packages/ngs/Read.py
    • /usr/lib/python2.7/dist-packages/ngs/ReadCollection.py
    • /usr/lib/python2.7/dist-packages/ngs/ReadGroup.py
    • /usr/lib/python2.7/dist-packages/ngs/ReadGroupIterator.py
    • /usr/lib/python2.7/dist-packages/ngs/ReadIterator.py
    • /usr/lib/python2.7/dist-packages/ngs/Refcount.py
    • /usr/lib/python2.7/dist-packages/ngs/Reference.py
    • /usr/lib/python2.7/dist-packages/ngs/ReferenceIterator.py
    • /usr/lib/python2.7/dist-packages/ngs/ReferenceSequence.py
    • /usr/lib/python2.7/dist-packages/ngs/Statistics.py
    • /usr/lib/python2.7/dist-packages/ngs/String.py
    • /usr/lib/python2.7/dist-packages/ngs/__init__.py
    • /usr/share/doc/python-ngs/changelog.Debian.gz
    • /usr/share/doc/python-ngs/copyright

    Changelog

    2016-02-06 - Andreas Tille <tille@debian.org> ngs-sdk (1.2.3-2) unstable; urgency=medium * debian/rules: create dynamic library in expected directory Closes: #813557 * Turn architecture checking for non-Intel architectures from error into warning that does not cause a failure Closes: #813559

    2016-02-01 - Olivier Sallou <osallou@debian.org> ngs-sdk (1.2.3-1) unstable; urgency=medium * Initial release (Closes: #809375)

    Advertisement
    Advertisement