python-nfqueue_0.5-1build2_amd64.deb


Advertisement

Description

python-nfqueue - Python bindings for nfqueue

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-nfqueue
Package version: 0.5
Package release: 1build2
Package architecture: amd64
Package type: deb
Installed size: 96 B
Download size: 23.61 KB
Official Mirror: archive.ubuntu.com
nfqueue-bindings is a set of high-level modules for several languages (Python and Perl, for the moment), for libnetfilter_queue. It provides a userspace API to access packets that have been queued by the kernel packet filter using the NFQUEUE target. This package contains the Python bindings for nfqueue.

Alternatives

Provides

  • python2.7-nfqueue

Replaces

  • nfqueue-bindings-python

    Download

    Source package: nfqueue-bindings

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-nfqueue deb package:
      # sudo apt-get install python-nfqueue

    Files

    • /usr/lib/python2.7/dist-packages/_nfqueue.so
    • /usr/lib/python2.7/dist-packages/nfqueue.py
    • /usr/share/doc/python-nfqueue/changelog.Debian.gz
    • /usr/share/doc/python-nfqueue/copyright
    • /usr/share/doc/python-nfqueue/examples/example.py
    • /usr/share/doc/python-nfqueue/examples/nfq_asyncore.py
    • /usr/share/doc/python-nfqueue/examples/nfq_dump_pcap.py
    • /usr/share/doc/python-nfqueue/examples/rewrite.py
    • /usr/share/doc/python-nfqueue/examples/za.py

    Changelog

    2015-12-18 - Colin Watson <cjwatson@ubuntu.com> nfqueue-bindings (0.5-1build2) xenial; urgency=medium * Rebuild for Perl 5.22.1.

    2014-08-21 - Colin Watson <cjwatson@ubuntu.com> nfqueue-bindings (0.5-1build1) utopic; urgency=medium * Rebuild for Perl 5.20.0.

    2014-07-30 - Pierre Chifflier <pollux@debian.org> nfqueue-bindings (0.5-1) unstable; urgency=medium * Imported Upstream version 0.5 * Remove watch file, URL changed, and new site is using self-signed https certificate * Remove 10-fix-ftbfs-uint32.patch and 20-FindPerlLib.patch, merged upstream * Bump Standards Version to 3.9.5 * Fix "hardcodes /usr/lib/perl5" (Closes: #752350) Make debian/libnfqueue-perl.install executable and use $Config{vendorarch} to determine target directory. Thanks to Gregor Herrmann for the patch.

    2013-10-09 - Pierre Chifflier <pollux@debian.org> nfqueue-bindings (0.4-6) unstable; urgency=low * Revert upstream signature change (Closes: #718894) Note: rollback is temporary, signature will change in next upstream version

    2013-07-08 - Pierre Chifflier <pollux@debian.org> nfqueue-bindings (0.4-5) unstable; urgency=low * Fix FTBFS "unknown type name 'uint32_t'" (Closes: #713742) * Use CMake internal script to find perl (Closes: #676274) * Bump Standards Version to 3.9.4 * Fix lintian warning (missing misc-depends)

    2013-07-08 - Pierre Chifflier <pollux@debian.org> nfqueue-bindings (0.4-4) unstable; urgency=low * Fix FTBFS "unknown type name 'uint32_t'" (Closes: #713742) * Use CMake internal script to find perl (Closes: #676274) Thanks to Gregor Herrmann for the original patch. * Bump Standards Version to 3.9.4

    2012-05-19 - Pierre Chifflier <pollux@debian.org> nfqueue-bindings (0.4-3) unstable; urgency=low * Add missing CPPFLAGS hardening flags (Closes: #670238). Thanks to Simon Ruderich for the bug report and patch. * Add 'bindnow' hardening flag

    2012-05-02 - Pierre Chifflier <pollux@debian.org> nfqueue-bindings (0.4-2) unstable; urgency=low * Build with python support in debhelper (Closes: #671060)

    2012-04-16 - Pierre Chifflier <pollux@debian.org> nfqueue-bindings (0.4-1) unstable; urgency=low * Imported Upstream version 0.4 * Drop patches, merged upstream * Fix installation path and build with specific Python version (Closes: #665230) * Bump Standards Version to 3.9.3 * Switch to debhelper 9: shorten the rules file, and enable hardening flags * Install examples

    2011-06-05 - Pierre Chifflier <pollux@debian.org> nfqueue-bindings (0.3-4) unstable; urgency=low * Switch to dh_python2 (Closes: #616916) * Build package for all recent versions of Python (Closes: #629280) - Add patch to support extra arguments in Makefile * Bump Standards Version to 3.9.2

    Advertisement
    Advertisement