python-neuroshare_0.9.2-1_amd64.deb


Advertisement

Description

python-neuroshare - Python interface and tools for Neuroshare

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-neuroshare
Package version: 0.9.2
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 106 B
Download size: 19.75 KB
Official Mirror: archive.ubuntu.com
The Neuroshare API is a standardized interface to access electrophysiology data stored in various different file formats. To do so, it uses format- specific shared libraries. This package provides a high-level Python interface to the Neuroshare API that focuses on convenience for the user and enables access to all available metadata and data. The data is returned in NumPy arrays, which provides a quick route to further examination and analysis. In addition, this package contains the ns2hdf converter tool that converts neuroshare-compatible files into the HDF5 (Hierarchical Data Format, ver. 5) file format.

Alternatives

    Download

    Source package: python-neuroshare

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-neuroshare deb package:
      # sudo apt-get install python-neuroshare

    Files

    • /usr/bin/ns-convert
    • /usr/lib/python2.7/dist-packages/neuroshare/AnalogEntity.py
    • /usr/lib/python2.7/dist-packages/neuroshare/Entity.py
    • /usr/lib/python2.7/dist-packages/neuroshare/EventEntity.py
    • /usr/lib/python2.7/dist-packages/neuroshare/File.py
    • /usr/lib/python2.7/dist-packages/neuroshare/Library.py
    • /usr/lib/python2.7/dist-packages/neuroshare/NeuralEntity.py
    • /usr/lib/python2.7/dist-packages/neuroshare/SegmentEntity.py
    • /usr/lib/python2.7/dist-packages/neuroshare/__init__.py
    • /usr/lib/python2.7/dist-packages/neuroshare/_capi.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/neuroshare-0.9.2.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/neuroshare-0.9.2.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/neuroshare-0.9.2.egg-info/top_level.txt
    • /usr/share/doc/python-neuroshare/README.Debian
    • /usr/share/doc/python-neuroshare/changelog.Debian.gz
    • /usr/share/doc/python-neuroshare/copyright

    Changelog

    2014-06-02 - Christian Kellner <ck@xatom.net> python-neuroshare (0.9.2-1) unstable; urgency=medium [ Christian Kellner ] * New upstream release (0.9.2) * debian/patches: - Update sphinx-pipy-upload patch * debian/copyright: - Include license for docs theme (Closes: #747869) [ Michael Hanke ] * Bumped Standards version to 3.9.5; no changes necessary * -doc package now adds symlink to /usr/share/doc/python-neuroshare pointing to the documentation in HTML format * Make debian/rules clean target remove *.egg files to make package build more robust.

    2014-04-22 - Christian Kellner <ck@xatom.net> python-neuroshare (0.9.1-2) unstable; urgency=low * debian/watch: - update to point to GitHub release page * debian/rules: - add get-orig-source target to fetch org. tarball

    2014-04-13 - Christian Kellner <ck@xatom.net> python-neuroshare (0.9.1-1) UNRELEASED; urgency=low * New upstream release (0.9.1) * debian/patches: - Drop all patches (fixed upstream) - Add a patch to remove sphinx-pipy-upload - Clean _capi.so from neuroshare (inline extension building) * debian/rules: Fix building of documentation

    2014-04-11 - Christian Kellner <ck@xatom.net> python-neuroshare (0.9-1) unstable; urgency=low * New upstream release (0.9) * debian/control: - Add python-neuroshare-doc package - Switch to dh-python - Depend on dh-python instead of python-support - Remove XB-Python-Version and replace with X-Python-Version - Binary package depends on python-h5py (Closes: #684746) * debian/rules: - Changes for dh-python support - Build sphix documentation * debian/patches: - Add patches to fix doc package building * debian/source/options: - Ignore *.egg/ directories

    2012-04-11 - Michael Hanke <mih@debian.org> python-neuroshare (0.8.5-1) unstable; urgency=low [ Christian Kellner ] * Initial Debian packaging. Closes: #663116 Many thanks to Michael Hanke <mih@debian.org> for the initial packaging help! [ Michael Hanke ] * Call dh_humpy (if available) to get proper dependencies on the respective NumPy ABI. * Add missing build-dependency on python-setuptools.

    Advertisement
    Advertisement