python-netlib_0.15.1-1_amd64.deb


Advertisement

Description

python-netlib - collection of network utility classes (python2)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-netlib
Package version: 0.15.1
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 222 B
Download size: 44.77 KB
Official Mirror: archive.ubuntu.com
Netlib is a collection of network utility classes, used by the pathod and mitmproxy projects. It differs from other projects in some fundamental respects, because both pathod and mitmproxy often need to violate standards. This means that protocols are implemented as small, well-contained and flexible functions, and are designed to allow misbehaviour when needed.

Alternatives

Provides

  • python2.7-netlib

    Download

    Source package: python-netlib

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-netlib deb package:
      # sudo apt-get install python-netlib

    Files

    • /usr/lib/python2.7/dist-packages/netlib/__init__.py
    • /usr/lib/python2.7/dist-packages/netlib/certutils.py
    • /usr/lib/python2.7/dist-packages/netlib/encoding.py
    • /usr/lib/python2.7/dist-packages/netlib/exceptions.py
    • /usr/lib/python2.7/dist-packages/netlib/odict.py
    • /usr/lib/python2.7/dist-packages/netlib/socks.py
    • /usr/lib/python2.7/dist-packages/netlib/tcp.py
    • /usr/lib/python2.7/dist-packages/netlib/tutils.py
    • /usr/lib/python2.7/dist-packages/netlib/utils.py
    • /usr/lib/python2.7/dist-packages/netlib/version.py
    • /usr/lib/python2.7/dist-packages/netlib/version_check.py
    • /usr/lib/python2.7/dist-packages/netlib/wsgi.py
    • /usr/lib/python2.7/dist-packages/netlib-0.15.1.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/netlib-0.15.1.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/netlib-0.15.1.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/netlib-0.15.1.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/netlib-0.15.1.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/netlib/http/__init__.py
    • /usr/lib/python2.7/dist-packages/netlib/http/authentication.py
    • /usr/lib/python2.7/dist-packages/netlib/http/cookies.py
    • /usr/lib/python2.7/dist-packages/netlib/http/headers.py
    • /usr/lib/python2.7/dist-packages/netlib/http/message.py
    • /usr/lib/python2.7/dist-packages/netlib/http/request.py
    • /usr/lib/python2.7/dist-packages/netlib/http/response.py
    • /usr/lib/python2.7/dist-packages/netlib/http/status_codes.py
    • /usr/lib/python2.7/dist-packages/netlib/http/user_agents.py
    • /usr/lib/python2.7/dist-packages/netlib/http/http1/__init__.py
    • /usr/lib/python2.7/dist-packages/netlib/http/http1/assemble.py
    • /usr/lib/python2.7/dist-packages/netlib/http/http1/read.py
    • /usr/lib/python2.7/dist-packages/netlib/http/http2/__init__.py
    • /usr/lib/python2.7/dist-packages/netlib/http/http2/connections.py
    • /usr/lib/python2.7/dist-packages/netlib/http/http2/frame.py
    • /usr/lib/python2.7/dist-packages/netlib/websockets/__init__.py
    • /usr/lib/python2.7/dist-packages/netlib/websockets/frame.py
    • /usr/lib/python2.7/dist-packages/netlib/websockets/protocol.py
    • /usr/share/doc/python-netlib/changelog.Debian.gz
    • /usr/share/doc/python-netlib/copyright

    Changelog

    2016-02-10 - Sebastien Delafond <seb@debian.org> python-netlib (0.15.1-1) unstable; urgency=medium * Import new upstream version 0.15.1 * New build dependencies for 0.15.1

    2015-11-25 - Sebastien Delafond <seb@debian.org> python-netlib (0.14-1) unstable; urgency=medium * Imported Upstream version 0.14 * New build dependencies for 0.14

    2015-10-29 - Sebastien Delafond <seb@debian.org> python-netlib (0.13.1-1) unstable; urgency=medium * New upstream version (Closes: #789783)

    2015-10-01 - Sebastien Delafond <seb@debian.org> python-netlib (0.12.1-1) unstable; urgency=medium * New upstream version (Closes: #789782)

    2015-05-19 - Sebastien Delafond <seb@debian.org> python-netlib (0.11.2-2) unstable; urgency=medium * Build-Depend on python-setuptools (Closes: #784931)

    2015-05-02 - Sebastien Delafond <seb@debian.org> python-netlib (0.11.2-1) unstable; urgency=medium * New upstream version * Remove patch 0001-netscape-cert-type-breaks-iceweasel, included upstream * Bump-up Standards-Version

    2014-06-29 - Sebastien Delafond <seb@debian.org> python-netlib (0.10-2) unstable; urgency=medium * Patch to prevent Iceweasel >= 31 from breaking on "Netscape Cert Type" extension. Thanks to Jakub Wilk <jwilk@debian.org> for the patch (Closes: #753014). * Bump up Standards-Version

    2014-02-10 - Sebastien Delafond <seb@debian.org> python-netlib (0.10-1) unstable; urgency=low * New upstream release

    2013-12-30 - Sebastien Delafond <seb@debian.org> python-netlib (0.9.2-2) unstable; urgency=low * Change architecture to "all"

    2013-12-29 - Sebastien Delafond <seb@debian.org> python-netlib (0.9.2-1) unstable; urgency=low * New upstream release (Closes: #731994) * Update watch file to point at new upstream location

    Advertisement
    Advertisement