python-netcdf4_1.2.2-2_amd64.deb


Advertisement

Description

python-netcdf4 - Python interface to the netCDF4 (network Common Data Form) library

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-netcdf4
Package version: 1.2.2
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 1.40 KB
Download size: 400.85 KB
Official Mirror: archive.ubuntu.com
NetCDF version 4 has many features not found in earlier versions of the library and is implemented on top of HDF5. This module can read and write files in both the new netCDF 4 and the old netCDF 3 format, and can create files that are readable by HDF5 clients. The API is modelled after Scientific.IO.NetCDF, and should be familiar to users of that module. Most new features of netCDF 4 are implemented, such as multiple unlimited dimensions, groups and zlib data compression. All the new numeric data types (such as 64 bit and unsigned integer types) are implemented. Compound and variable length (vlen) data types are supported, but the enum and opaque data types are not. Mixtures of compound and vlen data types (compound types containing vlens, and vlens containing compound types) are not supported. This package contains the netCDF 4 module for Python 2.

Alternatives

    Download

    Source package: netcdf4-python

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-netcdf4 deb package:
      # sudo apt-get install python-netcdf4

    Files

    • /usr/lib/python2.7/dist-packages/netCDF4/__init__.py
    • /usr/lib/python2.7/dist-packages/netCDF4/_netCDF4.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/netCDF4/utils.py
    • /usr/lib/python2.7/dist-packages/netCDF4-1.2.2.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/netCDF4-1.2.2.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/netCDF4-1.2.2.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/netCDF4-1.2.2.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/netCDF4-1.2.2.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/netcdftime/__init__.py
    • /usr/lib/python2.7/dist-packages/netcdftime/_datetime.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/netcdftime/netcdftime.py
    • /usr/share/doc/python-netcdf4/changelog.Debian.gz
    • /usr/share/doc/python-netcdf4/copyright
    • /usr/share/doc/python-netcdf4/examples/README.md
    • /usr/share/doc/python-netcdf4/examples/bench.py
    • /usr/share/doc/python-netcdf4/examples/bench_compress.py
    • /usr/share/doc/python-netcdf4/examples/bench_compress2.py
    • /usr/share/doc/python-netcdf4/examples/bench_compress3.py
    • /usr/share/doc/python-netcdf4/examples/bench_diskless.py
    • /usr/share/doc/python-netcdf4/examples/json_att.py
    • /usr/share/doc/python-netcdf4/examples/reading_netCDF.ipynb.gz
    • /usr/share/doc/python-netcdf4/examples/subset.py
    • /usr/share/doc/python-netcdf4/examples/test_stringarr.py
    • /usr/share/doc/python-netcdf4/examples/threaded_read.py
    • /usr/share/doc/python-netcdf4/examples/tutorial.py.gz
    • /usr/share/doc/python-netcdf4/examples/writing_netCDF.ipynb.gz

    Changelog

    2016-01-21 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.2.2-2) unstable; urgency=medium * Bump minimum required libnetcdf-dev to 4.4.0.

    2016-01-02 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.2.2-1) unstable; urgency=medium * New upstream release.

    2015-11-01 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.2.1-2) unstable; urgency=medium * Bump minimum required libnetcdf-dev to 4.4.0~rc3.

    2015-10-18 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.2.1-1) unstable; urgency=medium * New upstream release. * Drop patches, applied upstream.

    2015-09-24 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.2.0-1) unstable; urgency=medium * New upstream release. * Update Vcs-Browser URL to use HTTPS. * Add patch to fix 'homogeneous' typo.

    2015-08-19 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.1.9-2) unstable; urgency=medium * Bump minimum required libnetcdf-dev to 4.4.0~rc2. * Move from experimental to unstable.

    2015-07-31 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.1.9-2~exp2) experimental; urgency=medium * Bump minimum required libnetcdf-dev to 4.4.0~rc2-1~exp4 for serial HDF5. * Revert HDF5 MPI changes.

    2015-07-31 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.1.9-2~exp1) experimental; urgency=medium * Use mpi-default-dev to select the architecture specific HDF5 MPI flavor.

    2015-07-31 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.1.9-1) unstable; urgency=medium * New upstream release. * Drop patches, applied upstream. * Update watch file, changes: - Force lowercase RC in uversionmangle - Handle other tar extensions in filenamemangle

    2015-07-29 - Bas Couwenberg <sebastic@debian.org> netcdf4-python (1.1.8-3~exp3) experimental; urgency=medium * Use HDF5 mpich variant on s390x.

    Advertisement
    Advertisement