python-mvpa2-lib_2.4.1-1_amd64.deb


Advertisement

Description

python-mvpa2-lib - low-level implementations and bindings for PyMVPA v. 2

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-mvpa2-lib
Package version: 2.4.1
Package release: 1
Package architecture: amd64
Package type: deb
Installed size: 135 B
Download size: 26.81 KB
Official Mirror: archive.ubuntu.com
This is an add-on package for the PyMVPA framework. It provides a low-level implementation of an SMLR classifier and custom Python bindings for the LIBSVM library. This is a package of a development snapshot. The latest released version is provided by the python-mvpa-lib package.

Provides

  • python2.7-mvpa2-lib

    Download

    Source package: pymvpa2

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-mvpa2-lib deb package:
      # sudo apt-get install python-mvpa2-lib

    Files

    • /usr/lib/python2.7/dist-packages/mvpa2/clfs/libsmlrc/smlrc.so
    • /usr/lib/python2.7/dist-packages/mvpa2/clfs/libsvmc/_svmc.so
    • /usr/share/doc/python-mvpa2-lib/changelog.Debian.gz
    • /usr/share/doc/python-mvpa2-lib/copyright

    Changelog

    2015-11-18 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.4.1-1) unstable; urgency=medium * Fresh upstream release * debian/{control,rules} - Use swig2.0 (or swig3.0 < 3.0.5). See https://github.com/swig/swig/issues/563

    2015-10-21 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.4.0.1-1) unstable; urgency=medium * Upstream snapshot release - addresses compatibility issue with recent scipy * debian/patches/0001-BF-allow-to-compare-SmartVersion-None.patch - CPed from PR to resolve failing test whenever IPython is N/A

    2015-05-10 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.4.0-1) unstable; urgency=medium * New upstream yet to be released release - drop support of Python 2.6 * debian/control - boosted policy to 3.9.6 - added statsmodels to build-depends and recommends, joblib to recommends - recommend python-shogun instead of dated shogun-python-modular

    2014-10-28 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.3.1-2) unstable; urgency=medium * debian/patches - changeset_f12e1c41b7cf6b59b686c8f78d55ffba1eced8e1.diff + debian/rules changes to cache intersphinx mappings under debian/intersphinx (Closes: #765300). Thanks Sandro Tosi for the report and pointers to the resolution - changeset_5f62f33a7d84dca01c2aae69a4d4c0a00469ae7b.diff to fix up url to the h5py intersphinx * debian/upstream -> debian/upstream/metadata * debian/patches - deb_no_twitter_privacy_breach -- just refer to twitter instead

    2014-05-20 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.3.1-1) unstable; urgency=medium * Fresh upstream release (should be tollerant now to scipy API change in 1.4.0) * debian/watch - adjusted to monitor/fetch from github tags * debian/patches - all removed * debian/{control,rules} - use dh_python2 instead of deprecated pysupport - add matplotlib to build-depends and set its backend to Agg during testing

    2014-05-01 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.3.0-3) unstable; urgency=low * debian/control - man2html to build-depends * debian/patches - 2.3.0-37-g269c43c.diff to resolve FTBFS on trusty

    2014-03-05 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.3.0-1) unstable; urgency=low * Perspective fresh upstream release - contains all patches from under debian/patches/ so those are dropped * debian/control - recommend python-nipy * debian/rules - do not compress .sh scripts (cmdline examples)

    2013-12-12 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.2.0-4) unstable; urgency=low * debian/control: - specify git branch for debian packaging of pymvpa2. Thanks Julien Cristau for the report - build-depends on python-numpydoc - recommend python-pprocess (removed from the Debian archive since we missed a dependency on it and otherwise was unused, but is present from NeuroDebian ) - policy boosted to 3.9.5 (no changes) * debian/rules: - mkdir target -lib directories before moving .so files. It should resolve FTBFS with debhelper 9.20130507 and robustify build - quote paths with globs to avoid their expansion in find command. Thanks Julien Cristau for the hint

    2013-05-06 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.2.0-3) unstable; urgency=low * debian/patches - changeset_bab55a4a390c9c4b337ead5877868f7f7debc208.diff Tollerate "Probabalistic" (mention the typo) and "fixed" FSL atlases

    2013-04-30 - Yaroslav Halchenko <debian@onerussian.com> pymvpa2 (2.2.0-2) unstable; urgency=low * debian/patches - changeset_79bc8ecad13fe43447f8a262ed03147cbe7da326.diff changeset_cdba16f73f5aa74cf3002f027a1d38e408b0361b.diff Address numpy 1.7.1 compatibility in unittests

    Advertisement
    Advertisement