python-mpi4py-doc_1.3.1+hg20131106-2ubuntu5_all.deb


Advertisement

Description

python-mpi4py-doc - bindings of the MPI standard -- documentation

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-mpi4py-doc
Package version 1.3.1+hg20131106
Package release 2ubuntu5
Package architecture all
Package type deb
Installed size 290 B
Download size 46.50 KB
Official Mirror archive.ubuntu.com
MPI for Python (mpi4py) provides bindings of the Message Passing
Interface (MPI) standard for the Python programming language,
allowing any Python program to exploit multiple processors.
mpi4py is constructed on top of the MPI-1/MPI-2 specification
and provides an object oriented interface which closely follows MPI-2
C++ bindings.  It supports point-to-point (sends, receives) and
collective (broadcasts, scatters, gathers) communications of any
picklable Python object as well as optimized communications of Python
object exposing the single-segment buffer interface (NumPy arrays,
builtin bytes/string/array objects).
This package provides HTML rendering of the user's manual.

Alternatives

Package Version Architecture Repository
python-mpi4py-doc_1.3.1+hg20131106-2ubuntu5_all.deb 1.3.1+hg20131106 all Ubuntu Universe
python-mpi4py-doc - - -

Requires

Name Value
libjs-sphinxdoc >= 1.0

Download

Type URL
Binary Package python-mpi4py-doc_1.3.1+hg20131106-2ubuntu5_all.deb
Source Package mpi4py

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-mpi4py-doc deb package:
    # sudo apt-get install python-mpi4py-doc

Files

Path
/usr/share/doc-base/mpi4py
/usr/share/doc/python-mpi4py-doc/changelog.Debian.gz
/usr/share/doc/python-mpi4py-doc/copyright
/usr/share/doc/python-mpi4py-doc/html/appendix.html
/usr/share/doc/python-mpi4py-doc/html/genindex.html
/usr/share/doc/python-mpi4py-doc/html/index.html
/usr/share/doc/python-mpi4py-doc/html/install.html
/usr/share/doc/python-mpi4py-doc/html/intro.html
/usr/share/doc/python-mpi4py-doc/html/manual.html
/usr/share/doc/python-mpi4py-doc/html/mpi4py.html
/usr/share/doc/python-mpi4py-doc/html/objects.inv
/usr/share/doc/python-mpi4py-doc/html/search.html
/usr/share/doc/python-mpi4py-doc/html/searchindex.js
/usr/share/doc/python-mpi4py-doc/html/tutorial.html
/usr/share/doc/python-mpi4py-doc/html/_sources/appendix.txt
/usr/share/doc/python-mpi4py-doc/html/_sources/index.txt
/usr/share/doc/python-mpi4py-doc/html/_sources/install.txt
/usr/share/doc/python-mpi4py-doc/html/_sources/intro.txt
/usr/share/doc/python-mpi4py-doc/html/_sources/manual.txt
/usr/share/doc/python-mpi4py-doc/html/_sources/mpi4py.txt
/usr/share/doc/python-mpi4py-doc/html/_sources/tutorial.txt
/usr/share/doc/python-mpi4py-doc/html/_static/ajax-loader.gif
/usr/share/doc/python-mpi4py-doc/html/_static/basic.css
/usr/share/doc/python-mpi4py-doc/html/_static/classic.css
/usr/share/doc/python-mpi4py-doc/html/_static/comment-bright.png
/usr/share/doc/python-mpi4py-doc/html/_static/comment-close.png
/usr/share/doc/python-mpi4py-doc/html/_static/comment.png
/usr/share/doc/python-mpi4py-doc/html/_static/default.css
/usr/share/doc/python-mpi4py-doc/html/_static/doctools.js
/usr/share/doc/python-mpi4py-doc/html/_static/down-pressed.png
/usr/share/doc/python-mpi4py-doc/html/_static/down.png
/usr/share/doc/python-mpi4py-doc/html/_static/file.png
/usr/share/doc/python-mpi4py-doc/html/_static/jquery.js
/usr/share/doc/python-mpi4py-doc/html/_static/minus.png
/usr/share/doc/python-mpi4py-doc/html/_static/plus.png
/usr/share/doc/python-mpi4py-doc/html/_static/pygments.css
/usr/share/doc/python-mpi4py-doc/html/_static/searchtools.js
/usr/share/doc/python-mpi4py-doc/html/_static/sidebar.js
/usr/share/doc/python-mpi4py-doc/html/_static/underscore.js
/usr/share/doc/python-mpi4py-doc/html/_static/up-pressed.png
/usr/share/doc/python-mpi4py-doc/html/_static/up.png

Changelog

2016-02-15 - Matthias Klose <doko@ubuntu.com>
mpi4py (1.3.1+hg20131106-2ubuntu5) xenial; urgency=medium
* Ignore test results on s390x.
2016-02-06 - Matthias Klose <doko@ubuntu.com>
mpi4py (1.3.1+hg20131106-2ubuntu4) xenial; urgency=medium
* No-change rebuild for openmpi on s390x.
2016-02-01 - Matthias Klose <doko@ubuntu.com>
mpi4py (1.3.1+hg20131106-2ubuntu3) xenial; urgency=medium
* No-change rebuild for openmpi transition.
2016-01-19 - Matthias Klose <doko@ubuntu.com>
mpi4py (1.3.1+hg20131106-2ubuntu2) xenial; urgency=medium
* No-change rebuild to drop python3.4 support.
2015-07-28 - Steve Langasek <steve.langasek@ubuntu.com>
mpi4py (1.3.1+hg20131106-2ubuntu1) wily; urgency=medium
* debian/patches/python3.5-compat: update code for python3.5
compatibility.
2014-11-16 - Yaroslav Halchenko <debian@onerussian.com>
mpi4py (1.3.1+hg20131106-2) unstable; urgency=medium
* debian/rules
- assure absent reliance on network via http*_proxy env var
* debian/patches
- up_tests_network_attr tag BaseTestSpawn tests as relying on network
access and exclude them from running at pkg build time (Closes: #769801)
2013-11-06 - Yaroslav Halchenko <debian@onerussian.com>
mpi4py (1.3.1+hg20131106-1) unstable; urgency=low
* Fresh upstream snapshot which includes 1.3.1 stable release
* debian/rules:
- get-orig-dev-source to generate snapshot tarballs out from HG
* debian/rules,control:
- use dh_autoreconf and rebuild Cython extensions if cython is newer
than 0.19.1
- use dh_sphinxdoc (build-depends version for sphinx boosted to
1.0.7+dfsg~) and remove manual symlinking of jquery.js
(Closes: #725601)
* debian/control
- boost policy to 3.9.4
2013-05-09 - Yaroslav Halchenko <debian@onerussian.com>
mpi4py (1.3+hg20130509-1) unstable; urgency=low
* Fresh upstream snapshot:
- fixes Cython 0.19 compatibility (Closes: #707314)
- incorporates patches cython_version_check.patch,
up_test_win_python3.3.patch)
2013-02-20 - Yaroslav Halchenko <debian@onerussian.com>
mpi4py (1.3+hg20120611-3) unstable; urgency=medium
* Create a suffixed (e.g. python3.2mu) python3 directory matching the
one present on the system for the given version of python3  (Closes:
#700995)
2012-10-23 - Yaroslav Halchenko <debian@onerussian.com>
mpi4py (1.3+hg20120611-2) unstable; urgency=low
* Cherry-picked patch from upstream for python3.3 compatibility (failing
unittests) (Closes: #691244)

See Also

Package Description
python-mpi4py_1.3.1+hg20131106-2ubuntu5_amd64.deb bindings of the Message Passing Interface (MPI) standard
python-mpikmeans_1.5+dfsg-4build1_amd64.deb Python bindings for MPIKmeans
python-mpld3_0.3git+20140910dfsg-3_all.deb D3 viewer for matplotlib
python-mplexporter_0.0.1+20140921-2_all.deb general matplotlib exporter
python-mpltoolkits.basemap-data_1.0.7+dfsg-3build2_all.deb matplotlib toolkit to plot on map projections (data package)
python-mpltoolkits.basemap-doc_1.0.7+dfsg-3build2_all.deb matplotlib toolkit to plot on map projections (documentation)
python-mpltoolkits.basemap_1.0.7+dfsg-3build2_amd64.deb matplotlib toolkit to plot on map projections
python-mpmath-doc_0.19-3_all.deb library for arbitrary-precision floating-point arithmetic - Documentation
python-mpmath_0.19-3_all.deb library for arbitrary-precision floating-point arithmetic
python-mpop_1.0.0-1_all.deb Meteorological Post-Processing Package (MPoP)
python-mrjob_0.3.3.2-1_all.deb MapReduce framework for writing and running Hadoop Streaming jobs
python-mtbl_0.4.0-1_amd64.deb immutable sorted string table library (Python bindings)
python-multi-key-dict_2.0.3-1_all.deb multi key dictionary implementation - Python 2.7
python-multicorn_1.3.2-1_amd64.deb multicorn utility module for postgresql-X.Y-python-multicorn
python-multipartposthandler_0.1.0-2_all.deb handler for urllib2 to enable multipart form uploading
Advertisement
Advertisement