python-mongoengine_0.10.6-1_all.deb


Advertisement

Description

python-mongoengine - Python Document-Object Mapper for working with MongoDB

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-mongoengine
Package version: 0.10.6
Package release: 1
Package architecture: all
Package type: deb
Installed size: 376 B
Download size: 67.83 KB
Official Mirror: archive.ubuntu.com
MongoEngine is a Document-Object Mapper (think ORM, but for document databases) for working with MongoDB from Python. It uses a simple declarative API, similar to the Django ORM. This is the Python 2 package.

Alternatives

Provides

  • python2.7-mongoengine

    Download

    Source package: python-mongoengine

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-mongoengine deb package:
      # sudo apt-get install python-mongoengine

    Files

    • /usr/lib/python2.7/dist-packages/mongoengine/__init__.py
    • /usr/lib/python2.7/dist-packages/mongoengine/common.py
    • /usr/lib/python2.7/dist-packages/mongoengine/connection.py
    • /usr/lib/python2.7/dist-packages/mongoengine/context_managers.py
    • /usr/lib/python2.7/dist-packages/mongoengine/dereference.py
    • /usr/lib/python2.7/dist-packages/mongoengine/document.py
    • /usr/lib/python2.7/dist-packages/mongoengine/errors.py
    • /usr/lib/python2.7/dist-packages/mongoengine/fields.py
    • /usr/lib/python2.7/dist-packages/mongoengine/python_support.py
    • /usr/lib/python2.7/dist-packages/mongoengine/signals.py
    • /usr/lib/python2.7/dist-packages/mongoengine-0.10.6.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/mongoengine-0.10.6.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/mongoengine-0.10.6.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/mongoengine-0.10.6.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/mongoengine/base/__init__.py
    • /usr/lib/python2.7/dist-packages/mongoengine/base/common.py
    • /usr/lib/python2.7/dist-packages/mongoengine/base/datastructures.py
    • /usr/lib/python2.7/dist-packages/mongoengine/base/document.py
    • /usr/lib/python2.7/dist-packages/mongoengine/base/fields.py
    • /usr/lib/python2.7/dist-packages/mongoengine/base/metaclasses.py
    • /usr/lib/python2.7/dist-packages/mongoengine/queryset/__init__.py
    • /usr/lib/python2.7/dist-packages/mongoengine/queryset/base.py
    • /usr/lib/python2.7/dist-packages/mongoengine/queryset/field_list.py
    • /usr/lib/python2.7/dist-packages/mongoengine/queryset/manager.py
    • /usr/lib/python2.7/dist-packages/mongoengine/queryset/queryset.py
    • /usr/lib/python2.7/dist-packages/mongoengine/queryset/transform.py
    • /usr/lib/python2.7/dist-packages/mongoengine/queryset/visitor.py
    • /usr/share/doc/python-mongoengine/changelog.Debian.gz
    • /usr/share/doc/python-mongoengine/copyright

    Changelog

    2016-03-09 - Orestis Ioannou <orestis@oioannou.com> python-mongoengine (0.10.6-1) unstable; urgency=low * Team upload. * Svn to git migration. [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. * Remove DM-Upload-Allowed; it's no longer used by the archive software. [ Orestis Ioannou ] * New upstream release (Closes: #738503, #789980). * Use pybuild to build package. * Provide Python 3 package. * Move compat version to 9. * Pump up standards version to 3.9.7. Nothing to change. * Run wrap-and-sort. * Add dependencies for running tests. * Use pypi.debian.net for d/watch. * Added a patch to use libjs-modernizr instead of downloading from cdn. * Switch Vcs-git field to https.

    2012-06-27 - Janos Guljas <janos@resenje.org> python-mongoengine (0.6.13-2) unstable; urgency=low * Preserve _sources from html documentation to make sphinx search work.

    2012-06-24 - Janos Guljas <janos@resenje.org> python-mongoengine (0.6.13-1) unstable; urgency=low * New upstream release.

    2012-06-21 - Janos Guljas <janos@resenje.org> python-mongoengine (0.6.12-1) unstable; urgency=low * New upstream release. * debian/watch - Update source location. * debian/copyright - Update source location.

    2012-05-16 - Janos Guljas <janos@resenje.org> python-mongoengine (0.6.8-1) unstable; urgency=low * New upstream release. * debian/source/options - Ignore mongoengine.egg-info changes after build. (Closes: #671422) * debian/rules - Remove unused variable PREFIX. - Remove relocation of 'tests' directory. * Add exclude-tests-from-packaging.patch to exclude 'tests' from packaging it in global namespace.

    2012-04-22 - Janos Guljas <janos@resenje.org> python-mongoengine (0.6.4-1) unstable; urgency=low * New upstream release.

    2012-03-06 - Janos Guljas <janos@resenje.org> python-mongoengine (0.6.1-1) unstable; urgency=low * New upstream release. * Update version regular expression in debian/watch. * Bump standards to 3.9.3. * Update debian/copyright Format value.

    2011-11-18 - Janos Guljas <janos@resenje.org> python-mongoengine (0.5.2-1) unstable; urgency=low * New upstream release. * Add libjs-underscore dependency to python-mongoengine-doc binary package. * Add DM-Upload-Allowed control field.

    2011-09-13 - Janos Guljas <janos@resenje.org> python-mongoengine (0.5-1) unstable; urgency=low * New upstream release. * Bump standards version to 3.9.2. * Remove version from build dependencies python-all and python-pymongo. * Remove XS-Python-Version and XB-Python-Version. * Make package synopsis compliant with Debian Reference section 6.2.2. * Override dh_installchangelogs to install upstream changelog. * Remove debian/patches/fix-pymongo-1.10-compatibility. * Add debian/source/local-options. * Fix debian/copyright DEP5 errors. * Add debian/python-mongoengine-doc.links for jquery libraries.

    2011-04-02 - Janos Guljas <janos@resenje.org> python-mongoengine (0.4-2) unstable; urgency=low * Move tests to mongoengine module. (Closes: #620397) * Add debian/patches/fix-pymongo-1.10-compatibility - PyMongo changed map_reduce method in Collection class to require third parameter 'out' for output collection name. This patch is fixing this without breaking compatibility with earlier versions of PyMongo.

    Advertisement
    Advertisement