python-mode_6.2.2-1_all.deb


Advertisement

Description

python-mode - Python mode for GNU Emacs and XEmacs

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-mode
Package version: 6.2.2
Package release: 1
Package architecture: all
Package type: deb
Installed size: 1.08 KB
Download size: 144.34 KB
Official Mirror: archive.ubuntu.com
Provides a major mode for GNU Emacs and XEmacs to edit, debug, and develop Python programs and doctests. If you install this with XEmacs 21, it will replace the included python-mode.el, which may or may not be a more recent version (use "C-h v py-version" to compare). Since this package automagically loads after Python mode shipped with GNU emacs >= 22, installation of this package makes python-mode's mode the default for editing Python code in emacs.

Alternatives

Provides

  • python-elisp

Conflicts

  • python-elisp
  • python1.5-elisp
  • python2.1-elisp
  • python2.2-elisp

Replaces

  • python-elisp
  • python1.5-elisp
  • python2.1-elisp
  • python2.2-elisp

    Download

    Source package: python-mode

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-mode deb package:
      # sudo apt-get install python-mode

    Files

    • /etc/emacs/site-start.d/50python-mode.el
    • /usr/lib/emacsen-common/packages/compat/python-mode
    • /usr/lib/emacsen-common/packages/install/python-mode
    • /usr/lib/emacsen-common/packages/remove/python-mode
    • /usr/lib/python2.7/dist-packages/pycomplete.py
    • /usr/share/doc/python-mode/NEWS.Debian.gz
    • /usr/share/doc/python-mode/README.Debian
    • /usr/share/doc/python-mode/changelog.Debian.gz
    • /usr/share/doc/python-mode/copyright
    • /usr/share/emacs/site-lisp/python-mode/doctest-mode.el
    • /usr/share/emacs/site-lisp/python-mode/python-mode.el
    • /usr/share/emacs/site-lisp/python-mode/completion/auto-complete-pycomplete.el
    • /usr/share/emacs/site-lisp/python-mode/completion/company-pycomplete.el
    • /usr/share/emacs/site-lisp/python-mode/completion/pycomplete.el
    • /usr/share/pyshared/pycomplete.py

    Changelog

    2016-02-11 - Barry Warsaw <barry@debian.org> python-mode (1:6.2.2-1) unstable; urgency=medium * New upstream release. (Closes: #679967) * d/control: - Bump Standards-Version to 3.9.6 with no other changes needed. - Update Vcs-* headers for conversion to git and push to collab-maint. - Update Depends as per Debian Emacs Policy. * d/rules: Add emacsen-common compat file as per Debian Emacs Policy. (Closes: #775596)

    2014-07-10 - Barry Warsaw <barry@debian.org> python-mode (1:6.1.3-2) unstable; urgency=medium * d/control: Updated Depends to generic 'emacs' to remove dependency on the soon-to-be removed Emacs 23. (Closes: #754016)

    2014-02-03 - Barry Warsaw <barry@debian.org> python-mode (1:6.1.3-1) unstable; urgency=medium * New upstream release. * d/control: + Update Maintainer field to my debian.org address. + Bump Standards-Version to 3.9.5 with no additional changes necessary.

    2013-02-25 - Barry Warsaw <barry@python.org> python-mode (1:6.1.1-1) unstable; urgency=low * New upstream release. (Closes: #681502) * debian/patches/no-pymacs.patch: Removed, applied upstream.

    2012-10-05 - Barry Warsaw <barry@python.org> python-mode (1:6.0.12-2) unstable; urgency=low [ Urs Fleisch ] * debian/emacsen-install, debian/rules: A correct fix for the installation of pycomplete.el. [ Barry Warsaw ] * debian/control: Update Vcs-Browser and Vcs-Bzr urls. * debian/copyright: Update. (Closes: #689327)

    2012-09-28 - Barry Warsaw <barry@python.org> python-mode (1:6.0.12-1) unstable; urgency=low * New upstream release. Closes: #679968 * Fix 50python-mode.el's auto-mode-alist to match python-mode.el. Closes: #670332 * Add python2.7, python3, and python3.2 to interpreter-mode-alist in 50python-mode.el * debian/rules, debian/patches/no-pymacs.patch: Copy completion/pycomplete.el and test/doctest-mode.el to /usr/share/emacs/site-list/python-mode/ to restore their functionality. The patch is necessary to avoid byte-compilation errors on package install when pymacs is not available. Closes: #688037 * debian/emacsen-install: Skip emacs21, which doesn't have flymake as required by python-mode.el. Closes: #680577

    2012-07-16 - Hilko Bengen <bengen@debian.org> python-mode (1:6.0.10-1.1) unstable; urgency=low * Non-maintainer upload * Fixed upgrade failure: Symlinks are sufficient (Closes: #679591)

    2012-06-28 - Barry Warsaw <barry@python.org> python-mode (1:6.0.10-1) unstable; urgency=low * New upstream release. + Closes: #159628 + Closes: #160130 + Closes: #311398 + Closes: #654398 + Closes: #670332 + Closes: #676397 * debian/README.debian: Updated. * debian/README.source: Added. * debian/NEWS: Added. * debian/compat: Update to version 9 compatibility. * debian/control: + Install myself as Maintainer w/previous maintainers approval. + Update Standards-Version and Build-Depends. + Add X-Python{,3}-Version headers. + Update Vcs-* headers. + Demote pymacs from a Depends to a Recommends. + B-D on debhelper 9. * debian/copyright: Updated to reflect upstream reality. * debian/emacsen-install: Symlink to the .el file from the FLAVOR directory so that python-mode.el is on load-path. (Closes: #311382) * debian/rules: + dh_clean -k -> dh_prep + dh_pycentral -> dh_python2 * debian/source/format: 3.0 (quilt) * debian/watch: Fixed for new tarball releases.

    Advertisement
    Advertisement