python-manuel_1.8.0-4_all.deb


Advertisement

Description

python-manuel - Python library for testable documents and documented tests

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-manuel
Package version: 1.8.0
Package release: 4
Package architecture: all
Package type: deb
Installed size: 373 B
Download size: 51.77 KB
Official Mirror: archive.ubuntu.com
Manuel is a Python library for writing tested documentation which makes it possible to mix traditional doctests with custom test syntax. Several plug-ins providing different test features are included, but Manuel is also open to create custom plugins. Currently, unittests and zope.testing are the supported test runners. This package contains the modules for Python.

Alternatives

    Download

    Source package: manuel

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-manuel deb package:
      # sudo apt-get install python-manuel

    Files

    • /usr/lib/python2.7/dist-packages/manuel/__init__.py
    • /usr/lib/python2.7/dist-packages/manuel/capture.py
    • /usr/lib/python2.7/dist-packages/manuel/codeblock.py
    • /usr/lib/python2.7/dist-packages/manuel/doctest.py
    • /usr/lib/python2.7/dist-packages/manuel/footnote.py
    • /usr/lib/python2.7/dist-packages/manuel/ignore.py
    • /usr/lib/python2.7/dist-packages/manuel/isolation.py
    • /usr/lib/python2.7/dist-packages/manuel/testcase.py
    • /usr/lib/python2.7/dist-packages/manuel/testing.py
    • /usr/lib/python2.7/dist-packages/manuel-1.8.0.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/manuel-1.8.0.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/manuel-1.8.0.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/manuel-1.8.0.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/manuel-1.8.0.egg-info/top_level.txt
    • /usr/share/doc-base/python-manuel
    • /usr/share/doc/python-manuel/changelog.Debian.gz
    • /usr/share/doc/python-manuel/copyright
    • /usr/share/doc/python-manuel/html/README.html
    • /usr/share/doc/python-manuel/html/bugs.html
    • /usr/share/doc/python-manuel/html/capture.html
    • /usr/share/doc/python-manuel/html/genindex.html
    • /usr/share/doc/python-manuel/html/index.html
    • /usr/share/doc/python-manuel/html/objects.inv
    • /usr/share/doc/python-manuel/html/search.html
    • /usr/share/doc/python-manuel/html/searchindex.js
    • /usr/share/doc/python-manuel/html/table-example.html
    • /usr/share/doc/python-manuel/html/_sources/README.txt
    • /usr/share/doc/python-manuel/html/_sources/bugs.txt
    • /usr/share/doc/python-manuel/html/_sources/capture.txt
    • /usr/share/doc/python-manuel/html/_sources/index.txt
    • /usr/share/doc/python-manuel/html/_sources/table-example.txt
    • /usr/share/doc/python-manuel/html/_static/ajax-loader.gif
    • /usr/share/doc/python-manuel/html/_static/alabaster.css
    • /usr/share/doc/python-manuel/html/_static/basic.css
    • /usr/share/doc/python-manuel/html/_static/comment-bright.png
    • /usr/share/doc/python-manuel/html/_static/comment-close.png
    • /usr/share/doc/python-manuel/html/_static/comment.png
    • /usr/share/doc/python-manuel/html/_static/doctools.js
    • /usr/share/doc/python-manuel/html/_static/down-pressed.png
    • /usr/share/doc/python-manuel/html/_static/down.png
    • /usr/share/doc/python-manuel/html/_static/file.png
    • /usr/share/doc/python-manuel/html/_static/jquery.js
    • /usr/share/doc/python-manuel/html/_static/minus.png
    • /usr/share/doc/python-manuel/html/_static/plus.png
    • /usr/share/doc/python-manuel/html/_static/pygments.css
    • /usr/share/doc/python-manuel/html/_static/searchtools.js
    • /usr/share/doc/python-manuel/html/_static/underscore.js
    • /usr/share/doc/python-manuel/html/_static/up-pressed.png
    • /usr/share/doc/python-manuel/html/_static/up.png

    Changelog

    2015-11-03 - Daniel Stender <debian@danielstender.com> manuel (1.8.0-4) unstable; urgency=medium [ Daniel Stender ] * removed deb/tests/tests. [ Barry Warsaw ] * d/patches/disable-tests-requires.patch: Added to workaround an issue where Python will still try to download tests_requires from PyPI.

    2015-06-29 - Daniel Stender <debian@danielstender.com> manuel (1.8.0-3) unstable; urgency=medium * deb/copyright: updated. * Added docs-no-updated-timestamp.diff (closes: #788941). * Added DEP-8 test suite.

    2015-06-13 - W. Martin Borgert <debacle@debian.org> manuel (1.8.0-2) unstable; urgency=low * Added Zope license for bootstrap.py to debian/copyright. * Added myself to uploaders. * Still initial release (Closes: #776871).

    2015-04-29 - Daniel Stender <debian@danielstender.com> manuel (1.8.0-1) unstable; urgency=medium * Initial release (Closes: #776871).

    Advertisement
    Advertisement