python-magic_5.25-2ubuntu1_all.deb


Advertisement

Description

python-magic - File type determination library using "magic" numbers (Python bindings)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-magic
Package version: 5.25
Package release: 2ubuntu1
Package architecture: all
Package type: deb
Installed size: 53 B
Download size: 5.25 KB
Official Mirror: archive.ubuntu.com
This library can be used to classify files according to magic number tests. It implements the core functionality of the file command. This package contains the Python bindings.

Alternatives

Provides

  • python2.7-magic

    Download

    Source package: file

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-magic deb package:
      # sudo apt-get install python-magic

    Files

    • /usr/lib/python2.7/dist-packages/Magic_file_extensions-0.2.egg-info
    • /usr/lib/python2.7/dist-packages/magic.py
    • /usr/share/doc/python-magic/changelog.Debian.gz
    • /usr/share/doc/python-magic/copyright
    • /usr/share/doc/python-magic/examples/example.py

    Changelog

    2015-11-20 - Marc Deslauriers <marc.deslauriers@ubuntu.com> file (1:5.25-2ubuntu1) xenial; urgency=medium * Merge from Debian unstable. Remaining changes: - Adjust python build dependencies for cross builds. - Allow the package to cross-build.

    2015-09-22 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de> file (1:5.25-2) unstable; urgency=medium * Fix --mime-encoding. Closes: #799690

    2015-09-18 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de> file (1:5.25-1) unstable; urgency=low * New upstream version 5.25 * Import important commits post 5.25 release: - PR/479: check the format length modifiers, protect against 0-divide and offset out of bounds reads - print annotations * Disable detection of VAX COFF executables. Closes: #697846

    2015-09-13 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de> file (1:5.24-2) unstable; urgency=medium * Fix handling of file's --parameter option. Closes: #798410 * Fix strength of Python script detection. Closes: #698569, #798796

    2015-09-04 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de> file (1:5.24-1) unstable; urgency=low * New upstream version 5.24. Addresses: - mistakes some PDFs, Closes: #520098 - '#!' should have a bigger strength, Closes: #698569 * Update build dependencies: - dh-python - Recent dpkg-dev version for minimal restriction formula support

    2015-05-21 - Marc Deslauriers <marc.deslauriers@ubuntu.com> file (1:5.22+15-2ubuntu1) wily; urgency=medium * Merge from Debian unstable. Remaining changes: - Adjust python build dependencies for cross builds. - Allow the package to cross-build. * Dropped patches included in new version: - debian/patches/CVE-2014-3710.patch - debian/patches/CVE-2014-8116.patch - debian/patches/CVE-2014-8117.patch - debian/patches/pr398-truncate-pascal-strings.patch

    2015-03-10 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de> file (1:5.22+15-2) unstable; urgency=medium * Restore detection of some jpeg files. Closes: #780095

    2015-01-09 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de> file (1:5.22+15-1) unstable; urgency=high * Use upstream commit FILE5_22-11-ge452600 to include yet another security fix (PR/411).

    2015-01-03 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de> file (1:5.22+2-1) unstable; urgency=medium * New upstream version. Closes: #774219 * Use upstream commit FILE5_22-2-g9f0601f to include all recent fixes.

    2014-12-21 - Christoph Biedl <debian.axhn@manchmal.in-ulm.de> file (1:5.21+15-1) unstable; urgency=high * Fixes a security issue, urgency set to high * New upstream version 5.21 - Limit number of elf program and sections processing - Reduce the number of recursion levels Closes: #773148 (CVE-2014-8116, CVE-2014-8117) * Use upstream commit FILE5_21-15-ge7e96a9 to include all recent fixes.

    Advertisement
    Advertisement