python-logilab-constraint_0.5.0-2_all.deb


Advertisement

Description

python-logilab-constraint - constraints satisfaction solver in Python

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-logilab-constraint
Package version 0.5.0
Package release 2
Package architecture all
Package type deb
Installed size 230 B
Download size 28.17 KB
Official Mirror archive.ubuntu.com
Extensible constraint satisfaction problem solver written in pure
Python, using constraint propagation algorithms. The
logilab.constraint module provides finite domains with arbitrary
values, finite interval domains, and constraints which can be applied
to variables linked to these domains.

Alternatives

Package Version Architecture Repository
python-logilab-constraint_0.5.0-2_all.deb 0.5.0 all Ubuntu Universe
python-logilab-constraint - - -

Requires

Name Value
python-logilab-common >= 0.45.0
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-logilab-constraint_0.5.0-2_all.deb
Source Package logilab-constraint

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-logilab-constraint deb package:
    # sudo apt-get install python-logilab-constraint

Files

Path
/usr/lib/python2.7/dist-packages/logilab_constraint-0.5.0.egg-info
/usr/lib/python2.7/dist-packages/logilab/constraint/__init__.py
/usr/lib/python2.7/dist-packages/logilab/constraint/__pkginfo__.py
/usr/lib/python2.7/dist-packages/logilab/constraint/distributors.py
/usr/lib/python2.7/dist-packages/logilab/constraint/fd.py
/usr/lib/python2.7/dist-packages/logilab/constraint/fi.py
/usr/lib/python2.7/dist-packages/logilab/constraint/interfaces.py
/usr/lib/python2.7/dist-packages/logilab/constraint/propagation.py
/usr/share/doc-base/python-logilab-constraint
/usr/share/doc/python-logilab-constraint/CONTRIBUTORS
/usr/share/doc/python-logilab-constraint/README
/usr/share/doc/python-logilab-constraint/changelog.Debian.gz
/usr/share/doc/python-logilab-constraint/copyright
/usr/share/doc/python-logilab-constraint/documentation.html
/usr/share/doc/python-logilab-constraint/documentation.xml
/usr/share/doc/python-logilab-constraint/examples/chess.py
/usr/share/doc/python-logilab-constraint/examples/conferences.py
/usr/share/doc/python-logilab-constraint/examples/intervals.py
/usr/share/doc/python-logilab-constraint/examples/knights.py
/usr/share/doc/python-logilab-constraint/examples/menza.py
/usr/share/doc/python-logilab-constraint/examples/menza2.py
/usr/share/doc/python-logilab-constraint/examples/menza_brute_force.py
/usr/share/doc/python-logilab-constraint/examples/money.py
/usr/share/doc/python-logilab-constraint/examples/money2.py
/usr/share/doc/python-logilab-constraint/examples/queens.py
/usr/share/doc/python-logilab-constraint/examples/queens2.py
/usr/share/doc/python-logilab-constraint/examples/queens3.py
/usr/share/doc/python-logilab-constraint/examples/rooks.py
/usr/share/doc/python-logilab-constraint/examples/sudoku.py
/usr/share/doc/python-logilab-constraint/test/__profile__.py
/usr/share/doc/python-logilab-constraint/test/test_constraints.py
/usr/share/doc/python-logilab-constraint/test/test_distributors.py
/usr/share/doc/python-logilab-constraint/test/test_domains.py
/usr/share/doc/python-logilab-constraint/test/test_fi.py
/usr/share/doc/python-logilab-constraint/test/test_propagation.py
/usr/share/doc/python-logilab-constraint/test/test_validation.py

Changelog

2014-02-21 - Sandro Tosi <morph@debian.org>
logilab-constraint (0.5.0-2) unstable; urgency=medium
* debian/control
- switch me to Maintainer (team to Uploaders)
- remove Provides field, useless
* debian/pycompat
- removed
* debian/source/format
- switch to 3.0 (quilt) format
* Switch to dh_python2; addresses #739565
* Switch to dh sequencer
2014-01-04 - Sandro Tosi <morph@debian.org>
logilab-constraint (0.5.0-1) unstable; urgency=low
[ Sandro Tosi ]
* New upstream release
* debian/python-logilab-constraint.doc-base
- added doc-base
* debian/watch
- adjusted to new location
* debian/copyright
- updated to new copyright format
- extended packaging copyright years
- updated copyright years and licence for upstream code
* debian/control
- removed python-constraint transitional package
- bump Standards-Version to 3.9.5 (no changes needed)
* debian/compat
- bump compat level to 9
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2009-09-28 - Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
logilab-constraint (0.4.0-5) unstable; urgency=low
[ Luca Falavigna ]
* debian/rules:
- Use *-packages wildcard when removing files, Python 2.6 installs files
under /usr/lib/python*/dist-packages (Closes: #547829).
2009-09-15 - Sandro Tosi <morph@debian.org>
logilab-constraint (0.4.0-4) unstable; urgency=medium
[ Alexandre Fayolle ]
* debian/control 
- renamed binary package to python-logilab-constraint, added Provides,
Replaces, Conflicts for transition (closes: #523107)
[ Julien Lavergne ]
* From Ubuntu, prepare for the future python 2.6 transition:
- debian/rules: Add --install-layout=deb to setup.py install to install to
the right location.
- debian/control: Bump build-depends to python (>= 2.5.4-1~)
for --install-layout=deb support.
[ Mauro Lizaur ]
* debian/control 
- modified python-constraint to be just a dummy transitional 
package depending on the (new) python-logilab-constraint. 
Also, added against which version Replaces/Conflicts.
[ Sandro Tosi ]
* debian/python-logilab-constraint.*
- renamed from python-constraint.*
* debian/rules
- fixed for binary package rename
- properly install upstream changelog
* debian/control
- added me to uploaders
- bump Standards-Version to 3.8.3 (no changes needed)
- bump versioned depends on python-logilab-common (to better handling the
migration pycentral->pysupport, hence the severity)
- rename source package from constraint to logilab-constraint
* debian/constraint-test.dirs
- removed, not needed
* debian/copyright
- clearly separated license and copyright
- indent upstream author, license and copyright with 4 spaces
- link to GPL-2 local file
- extended copyright years to match all the files in the tarball
* debian/python-logilab-constraint.{postinst, prerm}
- removed since empty
2009-04-07 - Alexandre Fayolle <afayolle@debian.org>
constraint (0.4.0-3) unstable; urgency=low
[ Alexandre Fayolle ]
* Moved to Alioth's Python Module Packaging team
* Updated debian/watch
* Moved packaging to pysupport (closes: #522883), fixed dependency on
python-logilab-common
* upload to Debian of version 0.4
[ Sandro Tosi]
* debian/watch
- fixed
* debian/control
- moved python b-d to b-d-i (lintian warning)
2008-08-08 - Sylvain Thénault <sylvain.thenault@logilab.fr>
constraint (0.4.0-2) unstable; urgency=low
* updated debian standards to 3.7.2
* add debian/compat (5)
* remove deprecated dh_python
2008-08-07 - Sylvain Thénault <sylvain.thenault@logilab.fr>
constraint (0.4.0-1) unstable; urgency=low
* new upstream release
2006-06-14 - Alexandre Fayolle <afayolle@debian.org>
constraint (0.3.0-5) unstable; urgency=low
* updated debian standards to 3.7.2
* use debhelper 5
* updated to new Python policy (closes: #373308)

See Also

Package Description
python-logsparser_0.4-1_all.deb Python library for log parsing, tagging and analysis
python-loofah_0.1-1_all.deb debile helper to rebuild a set of existing packages
python-louie_1.1-2_all.deb Python signal dispatching mechanism
python-louis_2.6.4-2_all.deb Python bindings for liblouis
python-ltsp_0.2-0ubuntu3_all.deb provides ltsp related functions
python-lua_0.3-1.1_all.deb library for using lua scripts from python
python-lucene_3.5.0-1.2_amd64.deb Python extension for accessing Java Lucene
python-lunar_2.0.1-2.3ubuntu1_amd64.deb Python bindings for the Chinese Lunar library
python-lunch_0.4.0-2_all.deb distributed process launcher
python-lvm2_2.02.133-1ubuntu10_amd64.deb LVM2 application library - Python 2 binding
python-lxc_0.1-0ubuntu6_amd64.deb Linux container userspace tools (Python 2.x bindings)
python-ly-doc_0.9.3-1_all.deb Tool and library for manipulating LilyPond files (documentation)
python-lz4_0.7.0+dfsg-3build1_amd64.deb Python interface to the lz4 compression library
python-lzma_0.5.3-3_amd64.deb Python bindings for liblzma
python-lzo_1.08-1_amd64.deb Python bindings for the LZO data compression library
Advertisement
Advertisement