python-llfuse_0.41.1+dfsg-4build1_amd64.deb


Advertisement

Description

python-llfuse - Python bindings for the low-level FUSE API

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-llfuse
Package version 0.41.1+dfsg
Package release 4build1
Package architecture amd64
Package type deb
Installed size 402 B
Download size 107.86 KB
Official Mirror archive.ubuntu.com
Python-llfuse is a set of Python bindings for the low level
FUSE API. Bindings for the high level API are provided
by the python-fuse package.
FUSE (Filesystem in USErspace) is a simple interface for userspace
programs to export a virtual filesystem to the Linux kernel. FUSE
also aims to provide a secure method for non privileged users to
create and mount their own filesystem implementations.

Alternatives

Package Version Architecture Repository
python-llfuse_0.41.1+dfsg-4build1_i386.deb 0.41.1+dfsg i386 Ubuntu Universe
python-llfuse - - -

Requires

Name Value
libc6 >= 2.4
libfuse2 >= 2.8.0
python << 2.8
python >= 2.7~
python:any >= 2.7.5-5~

Provides

Name Value
python2.7-llfuse -

Replaces

Name Value
s3ql <= 0.28

Download

Type URL
Binary Package python-llfuse_0.41.1+dfsg-4build1_amd64.deb
Source Package python-llfuse

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-llfuse deb package:
    # sudo apt-get install python-llfuse

Files

Path
/usr/lib/python2.7/dist-packages/llfuse/__init__.py
/usr/lib/python2.7/dist-packages/llfuse/capi.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/llfuse/pyapi.py
/usr/lib/python2.7/dist-packages/llfuse-0.41.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/llfuse-0.41.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/llfuse-0.41.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/llfuse-0.41.1.egg-info/zip-safe
/usr/share/doc/python-llfuse/changelog.Debian.gz
/usr/share/doc/python-llfuse/copyright
/usr/share/lintian/overrides/python-llfuse

Changelog

2016-01-19 - Matthias Klose <doko@ubuntu.com>
python-llfuse (0.41.1+dfsg-4build1) xenial; urgency=medium
* No-change rebuild to drop python3.4 support.
2015-09-16 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.41.1+dfsg-4) unstable; urgency=medium
* Added patches/mips_dev_t.diff to work around bug in mips/mipsel libc
(cf. https://sourceware.org/bugzilla/show_bug.cgi?id=17786).
Closes: #635197.
2015-09-10 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.41.1+dfsg-3) unstable; urgency=medium
* Bumped Cython dependency to >= 0.21.1. Older versions don't have
posix/time.pxi.
* Added patches/setattr_compat.diff to restore full backwards
compatibility with version 0.40 (some applications were relying
on undocumented behavior were broken by the update to 0.41.1).
2015-08-22 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.41.1+dfsg-1) unstable; urgency=medium
* Added test suite.
* 'nostrip' build option is now honored.
* New upstream release.
2015-08-21 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.41+dfsg-1) unstable; urgency=medium
* New upstream release.
* Use Python 3 versions of Cython and Sphinx.
* Dropped build dependency on cython3-dbg (fixed upstream).
2015-07-29 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.40+dfsg-2) unstable; urgency=medium
* Correctly handle symlink-to-directory transition of 
/usr/share/doc/{python,python3}-llfuse-dbg when upgrading from jessie.
Closes: #788161.
* Add versioned Breaks and Conflicts to -dbg packages to avoid
upgrade problems due to moved file. Closes: #781652.
* Put debugging symbols for regular interpreter into -dbg
package again. Closes: #781719.
* Bumped Standards-Version to 3.9.6 (no changes needed).
* Added missing build-depends on cython3 and cython-dbg. 
Closes: #794056.
2014-07-10 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.40+dfsg-1) unstable; urgency=medium
* Updated watch file to use pypi, and validate pgp signature.
* Remove minified javascript files from upstream source.
* Switched package build system to pybuild.
* Updated project URL.
2013-11-27 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.40-2) unstable; urgency=low
* Some cosmetic fixes to debian/
* Bumped standards version to 3.9.5, no other changes required.
* Added force_xattr_api.diff to support compilation under GNU/kFreeBSD.
2013-11-26 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.40-1) unstable; urgency=low
* New upstream release.
2013-05-11 - Nikolaus Rath <Nikolaus@rath.org>
python-llfuse (0.39-1) unstable; urgency=low
[ Nikolaus Rath ]
* Bumped standards version to 3.9.4, no other changes required.
* Bumped debhelper compatibility level to 9 to get support for
dpkg-buildflags.
* Added lintian override for hardening-no-fortify-functions,
this is a false positive.
* Build depend on newer Cython (> 0.16).
* New upstream release.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.

See Also

Package Description
python-lmdb_0.86-1build2_amd64.deb Python binding for LMDB Lightning Memory-Mapped Database
python-lmfit-doc_0.9.2+dfsg-2_all.deb Least-Squares Minimization with Constraints (Documentation)
python-lmfit_0.9.2+dfsg-2_all.deb Least-Squares Minimization with Constraints (Python 2)
python-logbook-doc_0.12.3-1_all.deb logging system for Python that replaces the standard library's module (doc)
python-logbook_0.12.3-1_all.deb logging system for Python that replaces the standard library's module
python-logging-tree_1.4-1_all.deb introspect and display the logging tree in Python
python-loggingx_0.1.3-1.1build1_all.deb Generic utilities for the Python logging facility
python-logilab-common_1.1.0-1_all.deb useful miscellaneous modules used by Logilab projects
python-logilab-constraint_0.5.0-2_all.deb constraints satisfaction solver in Python
python-logsparser_0.4-1_all.deb Python library for log parsing, tagging and analysis
python-loofah_0.1-1_all.deb debile helper to rebuild a set of existing packages
python-louie_1.1-2_all.deb Python signal dispatching mechanism
python-louis_2.6.4-2_all.deb Python bindings for liblouis
python-ltsp_0.2-0ubuntu3_all.deb provides ltsp related functions
python-lua_0.3-1.1_all.deb library for using lua scripts from python
Advertisement
Advertisement