python-libxmp_2.0.1+git20140309.5437b0a-1_all.deb


Advertisement

Description

python-libxmp - Python library for XMP metadata

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-libxmp
Package version 2.0.1+git20140309.5437b0a
Package release 1
Package architecture all
Package type deb
Installed size 170 B
Download size 22.44 KB
Official Mirror archive.ubuntu.com
Python XMP Toolkit is a library for working with XMP metadata, as well as
reading/writing XMP metadata stored in many different file formats.
XMP (Extensible Metadata Platform) facilitates embedding metadata in files
using a subset of RDF. Most notably XMP supports embedding metadata in PDF and
many image formats, though it is designed to support nearly any file type.
This package provides Python bindings.

Alternatives

Package Version Architecture Repository
python-libxmp_2.0.1+git20140309.5437b0a-4~nd16.04+1_all.deb 2.0.1+git20140309.5437b0a all NeuroDebian Main
python-libxmp_2.0.1+git20140309.5437b0a-4~nd16.04+1_all.deb 2.0.1+git20140309.5437b0a all NeuroDebian Main
python-libxmp_2.0.1+git20140309.5437b0a-1_all.deb 2.0.1+git20140309.5437b0a all Ubuntu Universe
python-libxmp - - -

Requires

Name Value
libexempi3 -
python-tz -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-libxmp_2.0.1+git20140309.5437b0a-1_all.deb
Source Package python-xmp-toolkit

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-libxmp deb package:
    # sudo apt-get install python-libxmp

Files

Path
/usr/lib/python2.7/dist-packages/libxmp/__init__.py
/usr/lib/python2.7/dist-packages/libxmp/consts.py
/usr/lib/python2.7/dist-packages/libxmp/core.py
/usr/lib/python2.7/dist-packages/libxmp/exempi.py
/usr/lib/python2.7/dist-packages/libxmp/files.py
/usr/lib/python2.7/dist-packages/libxmp/utils.py
/usr/lib/python2.7/dist-packages/libxmp/version.py
/usr/lib/python2.7/dist-packages/python_xmp_toolkit-2.0.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/python_xmp_toolkit-2.0.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/python_xmp_toolkit-2.0.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/python_xmp_toolkit-2.0.1.egg-info/top_level.txt
/usr/share/doc/python-libxmp/README.rst
/usr/share/doc/python-libxmp/changelog.Debian.gz
/usr/share/doc/python-libxmp/copyright

Changelog

2015-05-01 - Daniel Stender <debian@danielstender.com>
python-xmp-toolkit (2.0.1+git20140309.5437b0a-1) unstable; urgency=medium
* Changed package versioning scheme to keep correct order.
* deb/control:
+ bumped standards to 3.9.6 (no changes needed).
+ updated Vcs fields (moved to Git).
+ added Suggests on docs package to module packages.
* deb/copyright:
+ removed unused file paragraph (refered to build time files).
+ updated.
* deb/rules:
+ improved sphinxdoc build (dropped deb/python-libxmp-doc.docs).
+ contribute README.rst directly through dh_installdocs (dropped
deb/python{,3}-libxmp.docs).
+ removed Vim setup line.
* deb/watch: watch pypi.debian.net.
* Added DEP-8 test suite.
* Added deb/gbp.conf, docs-no-updated-timestamp.patch (Closes: #782337).
2014-08-29 - Daniel Stender <debian@danielstender.com>
python-xmp-toolkit (2.0.1~git20140309.5437b0a-1) unstable; urgency=low
* Uploaded to unstable.
* New upstream revision: updated hardcode-library-name.diff, removed
fix-deprecated-unittest-methods.diff (applied upstream).
* Changed to build with setuptools:
+ Removed patches/no-setuptools.diff, added b-ds on python(3)-setuptools.
* deb/control:
+ Change of maintainer (Closes: #708545).
+ Bumped debhelper level to 9 (also in debian/compat).
+ B-ds: dropped python-support, added python3-all, python(3)-tz,
python(3)-mock (needed by test suite), and dh-python.
+ Bumped standards to 3.9.5 (no changes needed).
+ Changed Homepage URL (Google Code became obsolete).
+ Added X-Python(3)-Versions.
* deb/copyright:
+ Updated Format URI [ Jakub Wilk ].
+ Straightened, removed trailing commas, updated.
* deb/rules:
+ Added DH_VERBOSE, DEB_BUILD_OPTIONS and PYBUILD_NAME export lines.
+ Reduced to build with dh sequencer.
* deb/watch: changed from Google Code (obsolete) to Pypi.
* Upstream ships with Sphinx documentation:
+ Removed deb/get-orig.source.sh (to create dfsg is not needed anymore).
+ deb/control: added b-d for python-sphinx, and doc package description.
+ deb/rules: overrides for building docs, removal of docs/_build,
and dh_sphinxdoc.
+ Added deb/python-libxmp-doc.docs and deb/python-libxmp-doc.doc-base.
* Added python(3)-libxmp.docs for inclusion of README.rst.
* Wrapped and sorted.
2012-01-26 - Jakub Wilk <jwilk@debian.org>
python-xmp-toolkit (1.0.2+dfsg-1) experimental; urgency=low
* Initial release (closes: #657270).
* Disable use of setuptools. (no-setuptools.diff)
* Hardcode library name instead of using ctypes.util.find_library.
(hardcode-library-name.diff)
* Remove pre-built HTML documentation from the .orig tarball, as it contains
some sourceless JavaScript code.

See Also

Package Description
python-lightblue_0.3.2-5build1_amd64.deb cross-platform Bluetooth API for Python
python-linaro-image-tools_2014.11-1_all.deb Python library for the manipulation of Linaro bootable media
python-linop-doc_0.8.2-3_all.deb Linear mathematical operators in Python (documentation)
python-linop_0.8.2-3_amd64.deb Linear mathematical operators in Python (Python 2)
python-livereload-doc_2.4.0-1_all.deb automatic browser refresher (documentation)
python-livereload_2.4.0-1_all.deb automatic browser refresher
python-livestreamer-doc_1.12.2-1_all.deb library to extract video streams from various services - documentation
python-livestreamer_1.12.2-1_all.deb library to extract video streams from various services - Python 2
python-lldb-3.5_3.5.2-3ubuntu1_amd64.deb Next generation, high-performance debugger, python lib
python-lldb-3.7_3.7.1-2ubuntu2_amd64.deb Next generation, high-performance debugger, python lib
python-llfuse-doc_0.41.1+dfsg-4build1_all.deb Python bindings for the low-level FUSE API (documentation)
python-llfuse_0.41.1+dfsg-4build1_amd64.deb Python bindings for the low-level FUSE API
python-lmdb_0.86-1build2_amd64.deb Python binding for LMDB Lightning Memory-Mapped Database
python-lmfit-doc_0.9.2+dfsg-2_all.deb Least-Squares Minimization with Constraints (Documentation)
python-lmfit_0.9.2+dfsg-2_all.deb Least-Squares Minimization with Constraints (Python 2)
Advertisement
Advertisement