python-libstoragemgmt_1.2.3-1_all.deb


Advertisement

Description

python-libstoragemgmt - library for storage array management - Python libraries

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-libstoragemgmt
Package version: 1.2.3
Package release: 1
Package architecture: all
Package type: deb
Installed size: 775 B
Download size: 113.80 KB
Official Mirror: archive.ubuntu.com
vendor agnostic library interface to manage storage arrays. libstoragemgmt provides a single, unified, agnostic API library interface to storage arrays This package contains the Python libraries

Alternatives

    Download

    Source package: libstoragemgmt

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-libstoragemgmt deb package:
      # sudo apt-get install python-libstoragemgmt

    Files

    • /usr/lib/python2.7/dist-packages/lsm/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/_client.py
    • /usr/lib/python2.7/dist-packages/lsm/_common.py
    • /usr/lib/python2.7/dist-packages/lsm/_data.py
    • /usr/lib/python2.7/dist-packages/lsm/_iplugin.py
    • /usr/lib/python2.7/dist-packages/lsm/_pluginrunner.py
    • /usr/lib/python2.7/dist-packages/lsm/_transport.py
    • /usr/lib/python2.7/dist-packages/lsm/version.py
    • /usr/lib/python2.7/dist-packages/lsm/external/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/external/xmltodict.py
    • /usr/lib/python2.7/dist-packages/lsm/lsmcli/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/lsmcli/cmdline.py
    • /usr/lib/python2.7/dist-packages/lsm/lsmcli/data_display.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/hpsa/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/hpsa/hpsa.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/hpsa/utils.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/megaraid/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/megaraid/megaraid.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/megaraid/utils.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/nstor/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/nstor/nstor.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/ontap/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/ontap/na.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/ontap/ontap.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/sim/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/sim/simarray.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/sim/simulator.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/dmtf.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/smis.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/smis_ag.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/smis_cap.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/smis_common.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/smis_disk.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/smis_pool.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/smis_sys.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/smis_vol.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/smispy/utils.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/targetd/__init__.py
    • /usr/lib/python2.7/dist-packages/lsm/plugin/targetd/targetd.py
    • /usr/share/doc/python-libstoragemgmt/changelog.Debian.gz
    • /usr/share/doc/python-libstoragemgmt/copyright

    Changelog

    2015-07-16 - Ritesh Raj Sarraf <rrs@debian.org> libstoragemgmt (1.2.3-1) unstable; urgency=medium [ vaidyanath ] * [a37accc] Imported Upstream version 1.2.3 [ Ritesh Raj Sarraf ] * [79a906a] Update upstream URL * [f592979] Bump library version * [ef683f1] Revert "Add +License: LGPL-2.1+" * [8ca62b2] Update debian/copyright with license and copyright information * [4d2c178] Drop reference to non-existent daemon.py

    2015-06-26 - vaidyanath <vaidyanath.m@gmail.com> libstoragemgmt (1.1.0-1) unstable; urgency=medium [ vaidyanath ] * [413d404] Imported Upstream version 1.1.0 * [42fa020] Refresh patch debian/patches/fix-build-lsm-tests.patch * [63566a5] Drop patch -fix-build-warning-format-error.patch * [a727373] Add libssl-dev as build dependency * [ee6eee6] Add python-yaml as build dependency * [b58dd55] Add libmicrohttpd-dev as build dependency * [04aaf09] Add libjson-c-dev as build dependency * [89c4ca5] Add dh-python as build dependency * [3bdfe79] Add License: LGPL-2.1+ [ Ritesh Raj Sarraf ] * [6b915d7] Use autoreconf. Thanks to Brahadambal Srinivasan (Closes: #757216) * [ef65916] Update gbp.conf of the deprecation warning

    2014-02-24 - Ritesh Raj Sarraf <rsarraf@netapp.com> libstoragemgmt (0.0.20-2) unstable; urgency=medium * [6edc8d9] Restrict build to Linux platforms only * [08002c6] Disable tests until the next release * [24989c9] Fix build warning for format error

    2013-06-26 - Ritesh Raj Sarraf <rrs@debian.org> libstoragemgmt (0.0.20-1) unstable; urgency=low * [3aa8f15] Add dependency on python-m2crypto module * [d19de01] Imported Upstream version 0.0.20 * upload to unstable

    2012-09-25 - Ritesh Raj Sarraf <rrs@debian.org> libstoragemgmt (0.0.12-1) experimental; urgency=low * [893e0f5] Imported Upstream version 0.0.12 * [6bbf4d0] Add build-dep on libglib2.0-dev, python-m2crypto * [26ccf33] Add Depends on shared library shlibdeps

    2012-08-01 - Ritesh Raj Sarraf <rrs@debian.org> libstoragemgmt (0.0.9-1) experimental; urgency=low * Initail release (Closes: #649483)

    Advertisement
    Advertisement