python-libcec_3.0.1+dfsg2-9build1_amd64.deb


Advertisement

Description

python-libcec - Python bindings for USB CEC Adaptor

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-libcec
Package version: 3.0.1+dfsg2
Package release: 9build1
Package architecture: amd64
Package type: deb
Installed size: 641 B
Download size: 105.16 KB
Official Mirror: archive.ubuntu.com
This library provides support for the Pulse-Eight USB-CEC adapter and other CEC capable hardware, like the Raspberry Pi. This package provides Python bindings for libcec.

Alternatives

    Download

    Source package: libcec

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-libcec deb package:
      # sudo apt-get install python-libcec

    Files

    • /usr/lib/python2.7/dist-packages/cec/__init__.py
    • /usr/lib/python2.7/dist-packages/cec/_cec.x86_64-linux-gnu.so
    • /usr/share/doc/python-libcec/changelog.Debian.gz
    • /usr/share/doc/python-libcec/copyright
    • /usr/share/doc/python-libcec/examples/pyCecClient.py.gz

    Changelog

    2016-02-07 - Matthias Klose <doko@ubuntu.com> libcec (3.0.1+dfsg2-9build1) xenial; urgency=medium * No-change rebuild for ncurses6 transition.

    2015-11-28 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-9) unstable; urgency=medium * Cherry-pick patch from upstream for locking with flock()

    2015-10-07 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-8) unstable; urgency=medium * Handle transition from libcec3v4 to libcec3

    2015-09-28 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-7) unstable; urgency=medium * Stop using lockdev again (Closes: #728023)

    2015-09-12 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-6) unstable; urgency=medium * Fix SOVERSION handling in CEC clients (Closes: #798472)

    2015-09-06 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-5) unstable; urgency=medium * Fix crash on systems lacking /sys/class/drm (Closes: #798190)

    2015-08-16 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-4) unstable; urgency=medium * Update symbols based on armel build failure

    2015-08-07 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-3) experimental; urgency=medium * Add versioned build dependencies for the GCC 5 transition (Closes: #791103) * Update symbols file with the GCC 5 transition changes * Make build more deterministic * Fix libdir in pkgconfig file

    2015-08-01 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-2) experimental; urgency=medium * Update symbols file based on powerpc build

    2015-07-07 - Balint Reczey <balint@balintreczey.hu> libcec (3.0.1+dfsg2-1) experimental; urgency=medium * New Upstream version 3.0.1 * Merge upstream packaging changes * Drop patches integrated upstream * Add libcec-platform-dev as build dependency * Use cec-platform * Call cmake from debian/rules more conventionally * Fix pkgconfig file install location * Stop shipping libcec.a * Fix missing space in debian/control * Add misc:Depends to python-libcec dependencies * Update debian/copyright with changed and excluded files * Build depend on Debhelper 9 * Drop libcec meta package * Fix library SONAME version * Update symbols file * Install CLI utilities in cec-utils and Python scripts in python-libcec * Add shlibs:Depends and python:Depends to python-libcec dependencies * Build depend on dh-python * Extend extended description a bit * Call debhelper with python2 in debian/rules * Install Python client script as an example * Add repack suffix to debian/watch * Drop prebuilt windows binary from source * Drop obsoleted Lintian override

    Advertisement
    Advertisement