python-levenshtein_0.12.0-2build1_amd64.deb


Advertisement

Description

python-levenshtein - extension for computing string similarities and edit distances

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-levenshtein
Package version: 0.12.0
Package release: 2build1
Package architecture: amd64
Package type: deb
Installed size: 128 B
Download size: 34.84 KB
Official Mirror: archive.ubuntu.com
The Levenshtein module computes Levenshtein distances, similarity ratios, generalized medians and set medians of Unicode or non-Unicode strings. Because it's implemented in C, it's much faster than the corresponding Python library functions and methods. The Levenshtein distance is the minimum number of single-character insertions, deletions, and substitutions to transform one string into another. It is useful for spell checking, or fuzzy matching of gettext messages.

Alternatives

    Download

    Source package: python-levenshtein

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-levenshtein deb package:
      # sudo apt-get install python-levenshtein

    Files

    • /usr/lib/python2.7/dist-packages/Levenshtein/__init__.py
    • /usr/lib/python2.7/dist-packages/Levenshtein/_levenshtein.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/python_Levenshtein-0.12.0.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/python_Levenshtein-0.12.0.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/python_Levenshtein-0.12.0.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/python_Levenshtein-0.12.0.egg-info/namespace_packages.txt
    • /usr/lib/python2.7/dist-packages/python_Levenshtein-0.12.0.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/python_Levenshtein-0.12.0.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/python_Levenshtein-0.12.0.egg-info/top_level.txt
    • /usr/share/doc-base/python-levenshtein
    • /usr/share/doc/python-levenshtein/Levenshtein.html
    • /usr/share/doc/python-levenshtein/NEWS.gz
    • /usr/share/doc/python-levenshtein/README.rst
    • /usr/share/doc/python-levenshtein/changelog.Debian.gz
    • /usr/share/doc/python-levenshtein/copyright
    • /usr/share/doc/python-levenshtein/examples/StringMatcher.py
    • /usr/share/python/ns/python-levenshtein

    Changelog

    2016-01-18 - Matthias Klose <doko@ubuntu.com> python-levenshtein (0.12.0-2build1) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2015-08-02 - Sandro Tosi <morph@debian.org> python-levenshtein (0.12.0-2) unstable; urgency=medium * upload to unstable

    2015-04-10 - Sandro Tosi <morph@debian.org> python-levenshtein (0.12.0-1) experimental; urgency=medium * New upstream release; Closes: #781301 * debian/watch - use PyPI redirector * debian/patches/6c654dad56edf9ba4e38b5ab5f5dd6fcf5fffa54.patch - dropped, merged upstream * debian/patches, debian/rules - docs no longer need to be built, install the files from upstream tarball * debian/rules - keep installing StringMatcher.py as an example - remove unnecessary installed source code files

    2014-11-03 - Sandro Tosi <morph@debian.org> python-levenshtein (0.11.2-2) unstable; urgency=medium * debian/patches/6c654dad56edf9ba4e38b5ab5f5dd6fcf5fffa54.patch - fix a crash when using seq*() functions; thanks to Emil Langrock for the report; Closes: #597609 * debian/control - bump Standards-Version to 3.9.6 (no changes needed)

    2014-02-02 - Sandro Tosi <morph@debian.org> python-levenshtein (0.11.2-1) unstable; urgency=low [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Sandro Tosi ] * New upstream release * debian/control - switch me to Maintainer (team to Uploaders) - bump Standards-Version to 3.9.5 (no changes needed) - add python{,3}-setuptools to b-d * debian/watch - udpate download location * debian/{control, copyright} - update homepage information * debian/copyright - convert to DEP-5 format * Switch to dh_python2/3 * added Python 3 packages

    2012-01-10 - Sandro Tosi <morph@debian.org> python-levenshtein (0.10.1-2) unstable; urgency=low * debian/control - adopt it under DMPT umbrella; thanks to Nicolas for his previous work; Closes: #654348 - add Vcs-* fields - rename XS-P-V fields to X-P-V - remove useless XB-P-V field - bump Standards-Version to 3.9.2 - added ${misc:Depends} to binary Depends - update Homepage field; Closes: #479626 * Switch to 3.0 (quilt) source format * debian/{control, rules} - use python-support instead of python-central; Closes: #617011 - build debug extension * Switch to short debian/rules file format * debian/watch - remove template header

    2010-03-01 - Sandro Tosi <morph@debian.org> python-levenshtein (0.10.1-1.1) unstable; urgency=low * Non-maintainer upload, to prepare for Python 2.6 transition * debian/rules - use '--install-layout=deb' when installing the module; thanks to Jakub Wilk for the report; Closes: #571507 * debian/control - bump b-d in python-all-dev to '>= 2.5.3-1~', to support install-layout

    2008-03-29 - Nicolas FRANCOIS (Nekral) <nicolas.francois@centraliens.net> python-levenshtein (0.10.1-1) unstable; urgency=low * Initial Release. Closes: #473274

    Advertisement
    Advertisement