python-letsencrypt_0.4.1-1_all.deb


Advertisement

Description

python-letsencrypt - Let's Encrypt main library

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-letsencrypt
Package version 0.4.1
Package release 1
Package architecture all
Package type deb
Installed size 705 B
Download size 126.00 KB
Official Mirror archive.ubuntu.com
The objective of Let's Encrypt and the ACME (Automated Certificate
Management Environment) protocol is to make it possible to set up an
HTTPS server and have it automatically obtain a browser-trusted
certificate, without any human intervention. This is accomplished by
running a certificate management agent on the web server.
This agent is used to:
- Automatically prove to the Let's Encrypt CA that you control the website
- Obtain a browser-trusted certificate and set it up on your web server
- Keep track of when your certificate is going to expire, and renew it
- Help you revoke the certificate if that ever becomes necessary.
This package contains the main libraries.

Alternatives

Package Version Architecture Repository
python-letsencrypt_0.4.1-1_all.deb 0.4.1 all Ubuntu Universe
python-letsencrypt - - -

Requires

Name Value
python-acme >= 0.4.1
python-configargparse -
python-configobj -
python-cryptography >= 0.7
python-dialog -
python-mock -
python-openssl -
python-parsedatetime -
python-pkg-resources -
python-psutil -
python-rfc3339 -
python-six -
python-tz -
python-zope.component -
python-zope.interface -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-letsencrypt_0.4.1-1_all.deb
Source Package python-letsencrypt

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-letsencrypt deb package:
    # sudo apt-get install python-letsencrypt

Files

Path
/usr/lib/python2.7/dist-packages/letsencrypt/__init__.py
/usr/lib/python2.7/dist-packages/letsencrypt/account.py
/usr/lib/python2.7/dist-packages/letsencrypt/achallenges.py
/usr/lib/python2.7/dist-packages/letsencrypt/auth_handler.py
/usr/lib/python2.7/dist-packages/letsencrypt/cli.py
/usr/lib/python2.7/dist-packages/letsencrypt/client.py
/usr/lib/python2.7/dist-packages/letsencrypt/colored_logging.py
/usr/lib/python2.7/dist-packages/letsencrypt/configuration.py
/usr/lib/python2.7/dist-packages/letsencrypt/constants.py
/usr/lib/python2.7/dist-packages/letsencrypt/continuity_auth.py
/usr/lib/python2.7/dist-packages/letsencrypt/crypto_util.py
/usr/lib/python2.7/dist-packages/letsencrypt/error_handler.py
/usr/lib/python2.7/dist-packages/letsencrypt/errors.py
/usr/lib/python2.7/dist-packages/letsencrypt/interfaces.py
/usr/lib/python2.7/dist-packages/letsencrypt/le_util.py
/usr/lib/python2.7/dist-packages/letsencrypt/log.py
/usr/lib/python2.7/dist-packages/letsencrypt/notify.py
/usr/lib/python2.7/dist-packages/letsencrypt/proof_of_possession.py
/usr/lib/python2.7/dist-packages/letsencrypt/reporter.py
/usr/lib/python2.7/dist-packages/letsencrypt/reverter.py
/usr/lib/python2.7/dist-packages/letsencrypt/storage.py
/usr/lib/python2.7/dist-packages/letsencrypt-0.4.1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/letsencrypt-0.4.1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/letsencrypt-0.4.1.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/letsencrypt-0.4.1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/letsencrypt-0.4.1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/letsencrypt/display/__init__.py
/usr/lib/python2.7/dist-packages/letsencrypt/display/enhancements.py
/usr/lib/python2.7/dist-packages/letsencrypt/display/ops.py
/usr/lib/python2.7/dist-packages/letsencrypt/display/util.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/__init__.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/common.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/common_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/disco.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/disco_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/manual.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/manual_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/null.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/null_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/standalone.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/standalone_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/util.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/util_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/webroot.py
/usr/lib/python2.7/dist-packages/letsencrypt/plugins/webroot_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/__init__.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/account_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/acme_util.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/auth_handler_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/cli_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/client_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/colored_logging_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/configuration_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/continuity_auth_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/crypto_util_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/error_handler_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/errors_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/le_util_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/log_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/notify_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/proof_of_possession_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/reporter_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/reverter_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/storage_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/test_util.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/display/__init__.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/display/enhancements_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/display/ops_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/display/util_test.py
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/cert-san.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/cert.b64jose
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/cert.der
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/cert.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/cli.ini
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/csr-6sans.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/csr-nosans.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/csr-san.der
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/csr-san.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/csr.der
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/csr.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/dsa512_key.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/dsa_cert.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/matching_cert.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/rsa256_key.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/rsa512_key.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/rsa512_key_2.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/sample-renewal-ancient.conf
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/sample-renewal.conf
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/webrootconftest.ini
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/archive/sample-renewal/cert1.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/archive/sample-renewal/chain1.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/archive/sample-renewal/fullchain1.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/archive/sample-renewal/privkey1.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/live/sample-renewal/cert.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/live/sample-renewal/chain.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/live/sample-renewal/fullchain.pem
/usr/lib/python2.7/dist-packages/letsencrypt/tests/testdata/live/sample-renewal/privkey.pem
/usr/share/doc/python-letsencrypt/changelog.Debian.gz
/usr/share/doc/python-letsencrypt/copyright

Changelog

2016-02-29 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.4.1-1) unstable; urgency=medium
* New upstream release.
* Match version restriction on python-parsedatetime
* Bump S-V; no changes needed
* Fix Vcs-git URL
2016-02-11 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.4.0-1) unstable; urgency=medium
* New upstream version. (Closes: #813689)
* Ship the upstream tests and testdata. (Closes: #814010)
2016-01-28 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.3.0-1) unstable; urgency=medium
* New upstream version.  (Closes: #812223)
* Switch Vcs-git to https.
2016-01-15 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.2.0-1) unstable; urgency=medium
* New upstream version.
* Delete config and log directories on purge (closes: #809355)
* Drop priority to extra due to transitive dep on python-mock.
* Drop dep on pyopenssl to 0.13, include dep version for configargparse.
* Drop permission-failures patch applied upstream.
2015-12-22 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.1.1-3) unstable; urgency=medium
* New version to fix FTBFS.  (Closes: #808361)
2015-12-19 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.1.1-2) unstable; urgency=medium
* Dynamically generate d/control.
2015-12-15 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.1.1-1) unstable; urgency=medium
* New upstream version.
2015-12-10 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.1.0-2) unstable; urgency=medium
* First release for sid.
2015-12-03 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.1.0-1) experimental; urgency=medium
* New upstream release.
* Refresh patches.
* Switch PGP key to new upstream key.
2015-12-01 - Harlan Lieberman-Berg <hlieberman@setec.io>
python-letsencrypt (0.0.0.dev20151123-2) experimental; urgency=medium
* Alter dependency to solve unsatisfiable dependency. (Closes: #805738)

See Also

Package Description
python-leveldb_0~svn68-2build4_amd64.deb Python wrapper for LevelDB (Python 2)
python-levenshtein_0.12.0-2build1_amd64.deb extension for computing string similarities and edit distances
python-lfc_1.8.10-1build3_amd64.deb LCG File Catalog (LFC) python bindings
python-lhapdf_5.9.1-4_amd64.deb Python Bindings for LHAPDF
python-libapparmor_2.10.95-0ubuntu2_amd64.deb AppArmor library Python bindings
python-libarchive-c_2.1-3_all.deb Python interface to libarchive
python-libavg_1.8.1-2_amd64.deb High-level development platform for media-centric applications
python-libbde_20160110-2_amd64.deb BitLocker Drive Encryption access library -- Python 2 bindings
python-libbtbb-pcapdump_2015.09.R2-1_all.deb pcapdump is a Python module for pcap delivered by libbtbb
python-libcec_3.0.1+dfsg2-9build1_amd64.deb Python bindings for USB CEC Adaptor
python-libcharmstore_0.0.3-0ubuntu1_all.deb Python library to access Juju charmstore data
python-libcloud_0.20.0-1_all.deb unified Python interface into the cloud
python-libconcord_1.2-1build1_all.deb Harmony remote configuration tool - Python bindings
python-libdiscid-doc_0.4.1-5build1_all.deb libdiscid binding for Python (documentation)
python-libdiscid_0.4.1-5build1_amd64.deb libdiscid binding for Python 2
Advertisement
Advertisement