python-lasso_2.5.0-3ubuntu2_amd64.deb


Advertisement

Description

python-lasso - Library for Liberty Alliance and SAML protocols - Python bindings

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-lasso
Package version: 2.5.0
Package release: 3ubuntu2
Package architecture: amd64
Package type: deb
Installed size: 898 B
Download size: 109.65 KB
Official Mirror: archive.ubuntu.com
Lasso is an implementation of Liberty Alliance and related protocols, for network identity federations, single sign-on and other web services protocols. The main specifications implemented by the library are ID-FF, ID-WSF and SAML. This package contains Python bindings for liblasso, needed to use lasso in Python applications.

Alternatives

Provides

  • liblasso0-python2.3
  • python2.7-lasso

Conflicts

  • liblasso0-python2.3
  • python2.3-lasso
  • python2.4-lasso

Replaces

  • liblasso0-python2.3
  • python2.3-lasso
  • python2.4-lasso

    Download

    Source package: lasso

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-lasso deb package:
      # sudo apt-get install python-lasso

    Files

    • /usr/lib/python2.7/dist-packages/_lasso.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/lasso.py
    • /usr/share/doc/python-lasso/changelog.Debian.gz
    • /usr/share/doc/python-lasso/copyright

    Changelog

    2016-04-05 - Nishanth Aravamudan <nish.aravamudan@canonical.com> lasso (2.5.0-3ubuntu2) xenial; urgency=medium * Add build-dependency on dh-autoreconf as php-dev no longer pulls it in (LP: #1566404).

    2016-04-05 - Nishanth Aravamudan <nish.aravamudan@canonical.com> lasso (2.5.0-3ubuntu1) xenial; urgency=medium * Disable PHP bindings as they only support PHP5 (LP: #1566404).

    2016-01-19 - Matthias Klose <doko@ubuntu.com> lasso (2.5.0-3build1) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2016-01-11 - Frederic Peters <fpeters@debian.org> lasso (2.5.0-3) unstable; urgency=medium * d/p/0001-perl-remove-quotes-from-PERL-V-ccflags-output.patch: new patch, make sure to remove quotes given by "perl -V::ccflags:" as they ultimately cause the 32bit builds to fail. (closes: #809759) * Thanks to Niko Tyni for the detailed diagnostic. * d/rules: enable verbose builds. (closes: #809760)

    2016-01-03 - Frederic Peters <fpeters@debian.org> lasso (2.5.0-2) unstable; urgency=medium * Build against latest Perl release.

    2015-09-04 - Frederic Peters <fpeters@debian.org> lasso (2.5.0-1) unstable; urgency=medium * New upstream release. * d/control, d/rules: add new package for Python 3 bindings.

    2014-08-28 - Frederic Peters <fpeters@debian.org> lasso (2.4.1-1) unstable; urgency=medium * New upstream release. * d/p/perl-get-required-CFLAGS-from-perl-V-ccflags.patch: merged upstream * d/p/Use-INSTALLDIRS-vendor-for-the-Perl-bindings-as-per-.patch: refreshed

    2014-06-25 - Frederic Peters <fpeters@debian.org> lasso (2.4.0-4) unstable; urgency=medium * d/p/Use-INSTALLDIRS-vendor-for-the-Perl-bindings-as-per-.patch: use INSTALLDIRS=vendor for the Perl bindings, as per the Debian Perl policy. (thanks Niko Tyni) * debian/rules, debian/liblasso-perl.install: don't hardcode /usr/lib/perl5 (thanks Niko Tyni, again) (closes: #752703)

    2014-04-08 - Frederic Peters <fpeters@debian.org> lasso (2.4.0-3) unstable; urgency=medium * d/p/perl-get-required-CFLAGS-from-perl-V-ccflags.patch (stolen from git): get required CFLAGS from $(perl -V::ccflags:) (closes: #742522)

    2014-01-13 - Frederic Peters <fpeters@debian.org> lasso (2.4.0-2) unstable; urgency=medium * debian/php5-lasso.prerm: fix call to php5dismod. (closes: #734767)

    Advertisement
    Advertisement