python-kde4_4.14.2-0ubuntu6_amd64.deb


Advertisement

Description

python-kde4 - Python bindings for the KDE Development Platform

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-kde4
Package version 4.14.2
Package release 0ubuntu6
Package architecture amd64
Package type deb
Installed size 16.62 KB
Download size 2.36 MB
Official Mirror archive.ubuntu.com
This package contains PyKDE, the Python bindings for the KDE
libraries, that allow you to write KDE programs using Python instead of
C++. It contains at least the following modules under the
PyKDE namespace:
* dnssd
* kdecore
* kdeui
* khtml
* kio
* knewstuff
* kparts
* kterminal
* ktexteditor
* kutils
* plasma
* solid
And a few KDE related technologies like:
* akonadi
* phonon
* soprano
This package provides modules for all supported Python versions.

Alternatives

Package Version Architecture Repository
python-kde4_4.14.2-0ubuntu6_i386.deb 4.14.2 i386 Ubuntu Universe
python-kde4 - - -

Requires

Name Value
kde-runtime -
libc6 >= 2.14
libkcmutils4 >= 4:4.14.2
libkdecore5 >= 4:4.14.2
libkdeui5 >= 4:4.14.9
libkdnssd4 >= 4:4.14.2
libkemoticons4 >= 4:4.14.2
libkfile4 >= 4:4.14.2
libkhtml5 >= 4:4.14.2
libkidletime4 >= 4:4.14.2
libkio5 >= 4:4.14.2
libknewstuff2-4 >= 4:4.14.2
libknewstuff3-4 >= 4:4.14.2
libkparts4 >= 4:4.14.2
libkprintutils4 >= 4:4.14.2
libkpty4 >= 4:4.14.2
libktexteditor4 >= 4:4.14.2
libphonon4 >= 4:4.6.0really4.5.0
libplasma3 >= 4:4.14.2
libpython2.7 >= 2.7
libqt4-network >= 4:4.7.1
libqt4-svg >= 4:4.7.1
libqt4-xml >= 4:4.7.1
libqtcore4 >= 4:4.7.1
libqtgui4 >= 4:4.8.0
libsolid4 >= 4:4.14.2
libstdc++6 >= 4.1.1
phonon -
python >= 2.7
python << 2.8
python-qt4 >= 4.8.3-3~
python-sip -
sip-api-11.2 -

Download

Type URL
Binary Package python-kde4_4.14.2-0ubuntu6_amd64.deb
Source Package pykde4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-kde4 deb package:
    # sudo apt-get install python-kde4

Files

Path
/usr/lib/kde4/kpythonpluginfactory.so
/usr/lib/python2.7/dist-packages/PyKDE4/__init__.py
/usr/lib/python2.7/dist-packages/PyKDE4/dnssd.so
/usr/lib/python2.7/dist-packages/PyKDE4/kdecore.so
/usr/lib/python2.7/dist-packages/PyKDE4/kdeui.so
/usr/lib/python2.7/dist-packages/PyKDE4/khtml.so
/usr/lib/python2.7/dist-packages/PyKDE4/kio.so
/usr/lib/python2.7/dist-packages/PyKDE4/knewstuff.so
/usr/lib/python2.7/dist-packages/PyKDE4/kparts.so
/usr/lib/python2.7/dist-packages/PyKDE4/kterminal.so
/usr/lib/python2.7/dist-packages/PyKDE4/ktexteditor.so
/usr/lib/python2.7/dist-packages/PyKDE4/kutils.so
/usr/lib/python2.7/dist-packages/PyKDE4/phonon.so
/usr/lib/python2.7/dist-packages/PyKDE4/plasma.so
/usr/lib/python2.7/dist-packages/PyKDE4/pykdeconfig.py
/usr/lib/python2.7/dist-packages/PyKDE4/solid.so
/usr/lib/python2.7/dist-packages/PyQt4/uic/pykdeuic4.py
/usr/lib/python2.7/dist-packages/PyQt4/uic/widget-plugins/kde4.py
/usr/share/doc/python-kde4/README
/usr/share/doc/python-kde4/changelog.Debian.gz
/usr/share/doc/python-kde4/copyright
/usr/share/lintian/overrides/python-kde4

Changelog

2016-01-19 - Matthias Klose <doko@ubuntu.com>
pykde4 (4:4.14.2-0ubuntu6) xenial; urgency=medium
* No-change rebuild to drop python3.4 support.
2015-10-23 - Matthias Klose <doko@ubuntu.com>
pykde4 (4:4.14.2-0ubuntu5) xenial; urgency=medium
* No-change rebuild for python3 defaults change.
2015-08-17 - Harald Sitter <sitter@kde.org>
pykde4 (4:4.14.2-0ubuntu4) wily; urgency=medium
[ Harald Sitter ]
* Build without kdepimlibs5-dev present to facilitate the kdepim frameworks
5 transition. kdepimlibs as of KDE Applications 15.08 will be frameworks
based and not co-installable with the old libs (due to data files).
Disable the pimlibs in pykde4.
[ Jonathan Riddell ]
* Remove build-dep on libsoprano-dev
2015-08-08 - Matthias Klose <doko@ubuntu.com>
pykde4 (4:4.14.2-0ubuntu3) wily; urgency=medium
* Unversioned boost build dependency
2015-07-25 - Steve Langasek <steve.langasek@ubuntu.com>
pykde4 (4:4.14.2-0ubuntu2) wily; urgency=medium
* No-change rebuild for python3.5 transition
2014-10-10 - Scarlett Clark <sgclark@kubuntu.org>
pykde4 (4:4.14.2-0ubuntu1) vivid; urgency=medium
* New upstream release
2014-09-22 - Scarlett Clark <scarlett@scarlettgatelyclark.com>
pykde4 (4:4.14.1-0ubuntu1) utopic; urgency=medium
* New upstream release
* Repair optional_install_sip_files.diff so it applies. 
2014-08-20 - Jonathan Riddell <jriddell@ubuntu.com>
pykde4 (4:4.14.0-0ubuntu1) utopic; urgency=medium
* New upstream release
2014-08-08 - Scott Kitterman <scott@kitterman.com>
pykde4 (4:4.13.97-0ubuntu2) utopic; urgency=medium
* Rebuild without nepomuk support
* Drop references to nepomuk from package descriptions
2014-07-31 - Scarlett Clark <scarlett@scarlettgatelyclark.com>
pykde4 (4:4.13.97-0ubuntu1) utopic; urgency=medium
[ Scarlett Clark ]
* New upstream beta release RC
[ Jonathan Riddell ]
* Refresh patches
* Call dh_python2 with --no-shebang-rewrite as this fails on pyuickde4
symlink

See Also

Package Description
python-kdtree_0.7.1+git20101123-4build3_amd64.deb container for kd-tree sorting for Python
python-kerberos_1.1.5-2build1_amd64.deb GSSAPI interface module - Python 2.x
python-keybinder_0.3.1-1_amd64.deb registers global key bindings for applications - Python bindings
python-keyczar_0.715+ds-2_all.deb toolkit for safe and simple cryptography for Python
python-keyrings.alt_1.1.1-1_all.deb alternate backend implementations for python-keyring
python-keyutils_0.3.0-3_amd64.deb Python2 bindings for keyutils
python-kid_0.9.6-3_all.deb simple Pythonic template language for XML based vocabularies
python-kineticstools_0.5.1+20150828+git3aa3d96+dfsg-1_amd64.deb detection of DNA modifications (Python 2 library)
python-kinterbasdb_3.3.0-3_amd64.deb Python DB API 2.0 extension for Firebird and Interbase
python-kitchen_1.1.1-1_all.deb Python library of containers, text and i18n helpers
python-kivy-examples_1.9.0-3build1_all.deb Kivy - Multimedia / Multitouch framework in Python (examples)
python-kivy_1.9.0-3build1_amd64.deb Kivy - Multimedia / Multitouch framework in Python (Python 2)
python-kiwi_1.9.22-4_all.deb a graphical framework to construct simple UI
python-kjbuckets_1.0.0-16_amd64.deb Set and graph data types for Python
python-kml_1.3.0-1_amd64.deb Library to manipulate KML 2.2 OGC standard files - Python extension
Advertisement
Advertisement