python-jsonpipe_0.0.8-5_all.deb


Advertisement

Description

python-jsonpipe - Convert JSON to a UNIX-friendly line-based format

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-jsonpipe
Package version: 0.0.8
Package release: 5
Package architecture: all
Package type: deb
Installed size: 63 B
Download size: 7.60 KB
Official Mirror: archive.ubuntu.com
jsonpipe traverses a JSON object and produces a simple, line-based textual format which can be processed by all your UNIX favourites like grep, sed, awk, cut and diff. It may also be valuable within programming languages---in fact, it was originally conceived as a way of writing simple test assertions against JSON output without coupling the tests too closely to the specific structure used.

Alternatives

Provides

  • python2.7-jsonpipe

    Download

    Source package: jsonpipe

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-jsonpipe deb package:
      # sudo apt-get install python-jsonpipe

    Files

    • /usr/bin/jsonpipe
    • /usr/bin/jsonunpipe
    • /usr/lib/python2.7/dist-packages/jsonpipe/__init__.py
    • /usr/lib/python2.7/dist-packages/jsonpipe/pipe.py
    • /usr/lib/python2.7/dist-packages/jsonpipe/sh.py
    • /usr/lib/python2.7/dist-packages/jsonpipe-0.0.8.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/jsonpipe-0.0.8.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/jsonpipe-0.0.8.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/jsonpipe-0.0.8.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/jsonpipe-0.0.8.egg-info/top_level.txt
    • /usr/share/doc/python-jsonpipe/changelog.Debian.gz
    • /usr/share/doc/python-jsonpipe/copyright

    Changelog

    2014-02-01 - Dominique Belhachemi <domibel@debian.org> jsonpipe (0.0.8-5) unstable; urgency=medium * remove outdated distribute support (Closes: #733438) * switch from cdbs to dh * Bump debhelper 9 * Bump Standards-Version to 3.9.5

    2012-04-08 - Dominique Belhachemi <domibel@debian.org> jsonpipe (0.0.8-4) unstable; urgency=low * removed argparse dependency from setup.py (Closes: #664615) since python 2.7 it is maintained within the Python standard library * added missing python-pkg-resources runtime dependency * bump Standards-Version to 3.9.3

    2012-01-03 - Dominique Belhachemi <domibel@debian.org> jsonpipe (0.0.8-3) unstable; urgency=low * debian/control: Added alternative dependency python (>= 2.7) which includes argparse (Closes: #653649)

    2011-10-24 - Dominique Belhachemi <domibel@debian.org> jsonpipe (0.0.8-2) unstable; urgency=low * Bump Standards-Version to 3.9.2 * Bump debhelper 8 * Switch to dh_python2 * remove patch distribute.diff

    2011-10-24 - Dominique Belhachemi <domibel@debian.org> jsonpipe (0.0.8-1) unstable; urgency=low * new upstream release

    2011-10-21 - Dominique Belhachemi <domibel@debian.org> jsonpipe (0.0.7-1) unstable; urgency=low * Initial release (Closes: #646183) * use an older distribute_setup.py from calabash for lucid * Switch to dpkg-source 3.0 (quilt) format

    Advertisement
    Advertisement