python-jsonpickle_0.9.2-1_all.deb


Advertisement

Description

python-jsonpickle - Python library for serializing object graphs into JSON (Python 2)

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-jsonpickle
Package version 0.9.2
Package release 1
Package architecture all
Package type deb
Installed size 99 B
Download size 21.51 KB
Official Mirror archive.ubuntu.com
jsonpickle is a Python library for serialization and deserialization of
complex Python objects to and from JSON. The standard Python libraries for
encoding Python into JSON, such as the stdlib’s json, simplejson, and
demjson,  can only handle Python primitives that have a direct JSON
equivalent (e.g. dicts, lists, strings, ints, etc.). jsonpickle builds on
top of these libraries and allows more complex data structures to be
serialized to JSON. jsonpickle is highly configurable and
extendable–allowing the user to choose the JSON backend  and add additional
backends.
This is the Python 2 version of the package.

Alternatives

Package Version Architecture Repository
python-jsonpickle_0.9.2-1_all.deb 0.9.2 all Ubuntu Universe
python-jsonpickle - - -

Requires

Name Value
python:any >= 2.7.5-5~
python:any << 2.8

Provides

Name Value
python2.7-jsonpickle -

Download

Type URL
Binary Package python-jsonpickle_0.9.2-1_all.deb
Source Package jsonpickle

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-jsonpickle deb package:
    # sudo apt-get install python-jsonpickle

Files

Path
/usr/lib/python2.7/dist-packages/jsonpickle-0.9.2.egg-info
/usr/lib/python2.7/dist-packages/jsonpickle/__init__.py
/usr/lib/python2.7/dist-packages/jsonpickle/backend.py
/usr/lib/python2.7/dist-packages/jsonpickle/compat.py
/usr/lib/python2.7/dist-packages/jsonpickle/handlers.py
/usr/lib/python2.7/dist-packages/jsonpickle/pickler.py
/usr/lib/python2.7/dist-packages/jsonpickle/tags.py
/usr/lib/python2.7/dist-packages/jsonpickle/unpickler.py
/usr/lib/python2.7/dist-packages/jsonpickle/util.py
/usr/lib/python2.7/dist-packages/jsonpickle/version.py
/usr/lib/python2.7/dist-packages/jsonpickle/ext/__init__.py
/usr/lib/python2.7/dist-packages/jsonpickle/ext/numpy.py
/usr/share/doc/python-jsonpickle/changelog.Debian.gz
/usr/share/doc/python-jsonpickle/copyright

Changelog

2015-09-13 - Jan Dittberner <jandd@debian.org>
jsonpickle (0.9.2-1) unstable; urgency=medium
* New upstream version
* use PyPI redirector for watch file
* disable debian/patches/disable-tests-for-unpackaged-libraries.patch
* add python-numpy and python3-numpy to Build-Depends for new tests
* change debian/compat to 9, bump debhelper version to >= 9
* bump Standards-Version to 3.9.6 (no changes needed)
* install docs/source/changelog.rst as upstream changelog
* add debian/upstream/signing-key.asc and add pgpsigurlmangle to watch
file
* add Suggests for python-numpy for python-jsonpickle and python3-
numpy for python3-jsonpickle
2014-09-28 - Jan Dittberner <jandd@debian.org>
jsonpickle (0.8.0-1) unstable; urgency=medium
* New upstream version
* change debian/copyright to machine readable format, update copyright years
* simplify debian/rules and build documentation in
override_dh_sphinxdoc
2014-02-02 - Jan Dittberner <jandd@debian.org>
jsonpickle (0.6.1-1) unstable; urgency=medium
* New upstream version
* run wrap-and-sort
* bump Standards-Version to 3.9.5 (no changes)
* enable unit tests:
- add python-feedparser and python-simplejson to Build-Depends
- add override_dh_auto_test in debian/rules to run tests/runtests.py
- use debian source format 3.0 (quilt) to enable patching
* add Python 3 support:
- add new binary package python3-jsonpickle
- add dh-python, python3, python3-feedparse and python3-simplejson to
Build-Depends
- use pybuild as buildsystem
- add X-Python-Version and X-Python3-Version to source package stanza
* add doc package:
- add new binary package python-jsonpickle-doc
- add python-sphinx to Build-Depends
- add patch debian/patches/disable-unsupported-sphinx-extension.patch to
disable Sphinx extensions that are either not packaged in Debian or need
remote access at build time
- add override_dh_auto_build, override_dh_auto_install and
override_dh_sphinxdoc to build and install Sphinx documentation properly
- add debian/python-jsonpickle-doc.doc-base for docbase registration
2011-06-22 - Jan Dittberner <jandd@debian.org>
jsonpickle (0.4.0-1) unstable; urgency=low
[ John Paulett ]
* New upstream release
* Bump Standards-Version to 3.9.2
[ Jan Dittberner ]
* update copyright years in debian/copyright
* switch from python-support to dh_python2
- drop python-support Dependency
- bump python dependency to 2.6.6-3~
- add --with python2 to dh invocation in debian/rules
* add myself to Uploaders
* change Vcs-Svn and Vcs-Browser in debian/control to new anonscm URLs
2010-08-23 - Mike O'Connor <stew@debian.org>
jsonpickle (0.3.1-2) unstable; urgency=low
* Add dependency on ${python:Depends} (Closes: 591986)
* add explicit copy of license to debian/copyright
2009-11-16 - John Paulett <john@paulett.org>
jsonpickle (0.3.1-1) unstable; urgency=low
* Initial release (Closes: bug#560877)

See Also

Package Description
python-jsonpipe_0.0.8-5_all.deb Convert JSON to a UNIX-friendly line-based format
python-jsonrpc2_0.4.1-2_all.deb Python WSGI Framework for JSON RPC 2.0 (Python 2)
python-jsonrpclib_0.1.3-1build1_all.deb implementation of the JSON-RPC v2.0 specification
python-jswebkit_0.0.3-2build1_amd64.deb WebKit/JavaScriptCore Python bindings
python-jujubundlelib_0.4.1-0ubuntu1_all.deb Python 2 library for working with Juju bundles
python-jujuclient_0.50.5-0ubuntu1_all.deb Python API client for Juju (Python 2)
python-junit.xml_1.6-1_all.deb creates JUnit XML test result docs readable by tools such as Jenkins
python-junitxml_0.6-1.1ubuntu1_all.deb PyUnit extension for reporting in JUnit compatible XML
python-jwcrypto_0.2.1-1_all.deb Python implementation of JOSE Web standards
python-kaa-base_0.6.0+svn4596-1_amd64.deb Base Kaa Framework for all Kaa Modules
python-kaa-imlib2_0.2.3+svn4596-2_amd64.deb Imlib2 Wrapper for Python
python-kaa-metadata_0.7.7+svn4596-4_amd64.deb Media Metadata for Python
python-kafka-doc_0.9.3-2_all.deb Pure Python client for Apache Kafka - doc
python-kafka_0.9.3-2_all.deb Pure Python client for Apache Kafka - Python 2.x
python-kajiki_0.5.3-1_all.deb Really fast well-formed xml templates - Python 2.x
Advertisement
Advertisement