python-jedi_0.9.0-1_all.deb


Advertisement

Description

python-jedi - autocompletion tool for Python

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-jedi
Package version: 0.9.0
Package release: 1
Package architecture: all
Package type: deb
Installed size: 538 B
Download size: 105.38 KB
Official Mirror: archive.ubuntu.com
Jedi is an autocompletion tool for Python. It works. With and without syntax errors. Sometimes it sucks, but that's normal in dynamic languages. But it sucks less than other tools. It understands almost all of the basic Python syntax elements including many builtins.

Alternatives

    Download

    Source package: python-jedi

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-jedi deb package:
      # sudo apt-get install python-jedi

    Files

    • /usr/lib/python2.7/dist-packages/jedi/__init__.py
    • /usr/lib/python2.7/dist-packages/jedi/__main__.py
    • /usr/lib/python2.7/dist-packages/jedi/_compatibility.py
    • /usr/lib/python2.7/dist-packages/jedi/cache.py
    • /usr/lib/python2.7/dist-packages/jedi/common.py
    • /usr/lib/python2.7/dist-packages/jedi/debug.py
    • /usr/lib/python2.7/dist-packages/jedi/refactoring.py
    • /usr/lib/python2.7/dist-packages/jedi/settings.py
    • /usr/lib/python2.7/dist-packages/jedi/utils.py
    • /usr/lib/python2.7/dist-packages/jedi-0.9.0.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/jedi-0.9.0.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/jedi-0.9.0.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/jedi/api/__init__.py
    • /usr/lib/python2.7/dist-packages/jedi/api/classes.py
    • /usr/lib/python2.7/dist-packages/jedi/api/helpers.py
    • /usr/lib/python2.7/dist-packages/jedi/api/interpreter.py
    • /usr/lib/python2.7/dist-packages/jedi/api/keywords.py
    • /usr/lib/python2.7/dist-packages/jedi/api/replstartup.py
    • /usr/lib/python2.7/dist-packages/jedi/api/usages.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/__init__.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/analysis.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/cache.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/docstrings.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/dynamic.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/finder.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/flow_analysis.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/helpers.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/imports.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/iterable.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/param.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/precedence.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/recursion.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/representation.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/stdlib.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/sys_path.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/__init__.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake.py
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake/_functools.pym
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake/_sqlite3.pym
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake/_sre.pym
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake/_weakref.pym
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake/builtins.pym
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake/datetime.pym
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake/io.pym
    • /usr/lib/python2.7/dist-packages/jedi/evaluate/compiled/fake/posix.pym
    • /usr/lib/python2.7/dist-packages/jedi/parser/__init__.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/fast.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/grammar2.7.txt
    • /usr/lib/python2.7/dist-packages/jedi/parser/grammar3.4.txt
    • /usr/lib/python2.7/dist-packages/jedi/parser/token.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/tokenize.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/tree.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/user_context.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/pgen2/__init__.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/pgen2/grammar.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/pgen2/parse.py
    • /usr/lib/python2.7/dist-packages/jedi/parser/pgen2/pgen.py
    • /usr/share/doc/python-jedi/changelog.Debian.gz
    • /usr/share/doc/python-jedi/copyright

    Changelog

    2015-06-07 - Piotr Ożarowski <piotr@debian.org> python-jedi (0.9.0-1) unstable; urgency=medium * New upstream release * debian/watch: use pypi.debian.net redirector

    2014-10-10 - Piotr Ożarowski <piotr@debian.org> python-jedi (0.8.1-1) unstable; urgency=medium * New upstream release (closes: 764746) * Update debian/watch file to remove "final" from upstream version * Standards-Version bumped to 3.9.6 (no changes needed)

    2014-05-05 - Piotr Ożarowski <piotr@debian.org> python-jedi (0.8.0-1) unstable; urgency=medium * New upstream release * Add vim-python to vim-python-jedi's Depends (closes: 727835)

    2013-08-20 - Piotr Ożarowski <piotr@debian.org> python-jedi (0.7.0-1) unstable; urgency=low * New upstream release - switched from LGPL to MIT license * debian/copyright updated - license of debian/* files changed to Expat, to match upstream * CHANGELOG.rst installed as upstream changelog

    2013-08-08 - Piotr Ożarowski <piotr@debian.org> python-jedi (0.6.0-2) unstable; urgency=low [ Jakub Wilk ] * Add Vcs-* fields. [ Piotr Ożarowski ] * Bump minimum required Python version to 2.6 (due to b'' syntax) * Add DPMT to Uploaders * Upload to unstable * Add dh-python to Build-Depends

    2013-05-14 - Piotr Ożarowski <piotr@debian.org> python-jedi (0.6.0-1) experimental; urgency=low * New upstream release

    2013-01-19 - Piotr Ożarowski <piotr@debian.org> python-jedi (0.5~b5-1) experimental; urgency=low * Initial release (closes: #696195)

    Advertisement
    Advertisement