python-ipy_0.83-1_all.deb


Advertisement

Description

python-ipy - Python module for handling IPv4 and IPv6 addresses and networks

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-ipy
Package version: 0.83
Package release: 1
Package architecture: all
Package type: deb
Installed size: 121 B
Download size: 27.54 KB
Official Mirror: archive.ubuntu.com
IPy is a Python module for handling IPv4 and IPv6 addresses and networks in a fashion similar to perl's Net::IP and friends. The IP class allows a comfortable parsing and handling for most notations in use for IPv4 and IPv6 addresses and networks.

Alternatives

    Download

    Binary package: python-ipy_0.83-1_all.deb
    Source package: ipy

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-ipy deb package:
      # sudo apt-get install python-ipy

    Files

    • /usr/lib/python2.7/dist-packages/IPy-0.83.egg-info
    • /usr/lib/python2.7/dist-packages/IPy.py
    • /usr/share/doc-base/python-ipy
    • /usr/share/doc/python-ipy/IPy.html
    • /usr/share/doc/python-ipy/README.gz
    • /usr/share/doc/python-ipy/changelog.Debian.gz
    • /usr/share/doc/python-ipy/copyright
    • /usr/share/doc/python-ipy/examples/confbuilder
    • /usr/share/doc/python-ipy/examples/confbuilder.py.gz
    • /usr/share/lintian/overrides/python-ipy

    Changelog

    2015-08-21 - Bernd Zeimetz <bzed@debian.org> ipy (1:0.83-1) unstable; urgency=medium * Team upload * New upstream release.

    2015-01-24 - Hugo Lefeuvre <hugo6390@orange.fr> ipy (1:0.82a-1) experimental; urgency=low * Team upload. * New upstream release. * debian/control: - Bump Standards-Version to 3.9.6. * debian/watch: - Update regex (The old url led to an useless blank page).

    2014-02-13 - Bernd Zeimetz <bzed@debian.org> ipy (1:0.81-1) unstable; urgency=low * Team Upload [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. [ Jackson Doak ] * New upstream release. * Create debian/source/format * Create doc-base files * debian/control: - Bump debhelper to 9 - Bump standards-version to 3.9.4 - Add X-Python fields

    2012-01-18 - Scott Kitterman <scott@kitterman.com> ipy (1:0.75-1) unstable; urgency=low * Team upload * New upstream version - Update debian/copyright * Convert to dh_python2 - Drop build-depends on python-support - Remove debian/pyversions - Version python-all build-dep - Build --with python2 * Add support for Python3 - Add new python3-ipy binary to debian/control - Add python3-all to build-depends - Build --with python3 - Override dh_auto_build/install to build for python and python3 - Override dh_auto_clean to remove python3 build directory - Not running tests for python3, since test/test_IPy.py is python only - Rename debian/docs to python-ipy.docs and python3-ipy.docs so docs are installed in both packages * Drop old conflicts on python2.3/2.4-ipy * Drop unneeded python:Provides * Bump standards version to 3.9.2 without further change * Update Homepage: field in debian/control with new upstream location on github

    2011-02-14 - Bernd Zeimetz <bzed@debian.org> ipy (1:0.72-1) unstable; urgency=low * New upstream version.

    2009-11-06 - Bernd Zeimetz <bzed@debian.org> ipy (1:0.70-1) unstable; urgency=low * New upstream version.

    2009-08-25 - Bernd Zeimetz <bzed@debian.org> ipy (1:0.64-1) unstable; urgency=low [ Sandro Tosi ] * debian/control - switch Vcs-Browser field to viewsvn [ Bernd Zeimetz ] * New upstream version. * debian/pycompat: - Deleting file, not needed. * debian/control, debian/rules: - Use the new dh to build the package. - Run the new test suite, which is provided by upstream since this version instead of the buggy docstring test. - Bump Standards-Version to 3.8.3, no changes needed. * debian/clean: - Add file. * debian/compat: - Bump to level 7.

    2008-06-29 - Bernd Zeimetz <bzed@debian.org> ipy (1:0.62-1) unstable; urgency=low * New upstream version.

    2008-06-22 - Bernd Zeimetz <bzed@debian.org> ipy (1:0.61-1) unstable; urgency=low * New upstream version.

    2008-05-27 - Bernd Zeimetz <bzed@debian.org> ipy (1:0.60-1) unstable; urgency=low * New upstream version. * debian/README.Debian-source: - Deleting file, not needed anymore.

    Advertisement
    Advertisement