python-iplib_1.1-3.1ubuntu1_all.deb


Advertisement

Description

python-iplib - Python library to convert amongst many different IPv4 notations

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-iplib
Package version: 1.1
Package release: 3.1ubuntu1
Package architecture: all
Package type: deb
Installed size: 57 B
Download size: 12.76 KB
Official Mirror: archive.ubuntu.com
You can use this Python module to convert amongst many different notations and to manage couples of address/netmask in the CIDR notation.

Alternatives

    Download

    Source package: python-iplib

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-iplib deb package:
      # sudo apt-get install python-iplib

    Files

    • /usr/lib/python2.7/dist-packages/iplib-1.1.egg-info
    • /usr/lib/python2.7/dist-packages/iplib.py
    • /usr/share/doc/python-iplib/README.Debian
    • /usr/share/doc/python-iplib/README.iplib.gz
    • /usr/share/doc/python-iplib/README.txt
    • /usr/share/doc/python-iplib/changelog.Debian.gz
    • /usr/share/doc/python-iplib/copyright
    • /usr/share/doc/python-iplib/examples/cidrinfo.py
    • /usr/share/doc/python-iplib/examples/ipconv.py
    • /usr/share/doc/python-iplib/examples/nmconv.py

    Changelog

    2016-03-27 - Artur Rona <ari-tczew@ubuntu.com> python-iplib (1.1-3.1ubuntu1) xenial; urgency=low * Merge from Debian unstable. Remaining changes: - debian/control: + Bump debhelper to 7. + Bump Standards-Version to 3.9.3. + Add X-Python-Version field. + Drop XB-P-V and Provides. - debian/rules: + Use tiny version. - Switch to dpkg-source 3.0 (quilt) format.

    2015-08-20 - Andrey Rahmatullin <wrar@debian.org> python-iplib (1.1-3.1) unstable; urgency=medium * Non-maintainer upload. * Port from python-support to dh_python (Closes: #786024) * Drop debian/pycompat * Drop Conflicts/Replaces on old python2.x-iplib

    2012-11-09 - Charlie Smotherman <cjsmo@cableone.net> python-iplib (1.1-3ubuntu2) raring; urgency=low * Updating to be more inline with current debian python policy. * Increase debian/compat to 7. * Removed debian/pycompat not needed. * Changed to Source Format 3.0 (quilt). * debian/control - increased debhelper to >= 7.0.53. - increased python-all to (>= 2.6.6-3~). - removed B-D-I on python-support it is now depreceated. - increased Standards Version to 3.9.3 no changes needed. - use X-P-V instead of XS-P-V. - removed XB-P-V not needed. - removed Provides. * debian/rules - update to use dh7 tiny rules and dh_python2.

    2012-11-03 - Logan Rosen <logatronico@gmail.com> python-iplib (1.1-3ubuntu1) raring; urgency=low * Merge from Debian unstable. Remaining changes: - debian/control: add XS-Python-Version field - debian/rules: change hashbangs "#!/usr/bin/env python" to more policy compliant "#!/usr/bin/python"

    2011-04-24 - Christoph Haas <haas@debian.org> python-iplib (1.1-3) unstable; urgency=low * Re-upload to remove binary dependency on Python 2.5 that is now being removed the repository (closes: #623920)

    2008-12-06 - Devid Antonio Filoni <d.filoni@ubuntu.com> python-iplib (1.1-2ubuntu1) jaunty; urgency=low * Merge from Debian unstable, remaining Ubuntu changes: - debian/control: add XS-Python-Version field - debian/rules: change hashbangs "#!/usr/bin/env python" to more policy compliant "#!/usr/bin/python"

    2008-09-18 - Christoph Haas <haas@debian.org> python-iplib (1.1-2) unstable; urgency=low * Minor lintian fixes.

    2008-02-25 - Andrea Gasparini <gaspa@yattaweb.it> python-iplib (1.1-1ubuntu1) intrepid; urgency=low * Merge from Debian unstable (LP: #231057). Remaining Ubuntu changes: - debian/control: * modified Maintainer value to match specifications (LP: #230350) * added XS-Python-Version field - debian/rules: changed hashbangs "#!/usr/bin/env python" to more policy compliant "#!/usr/bin/python"

    2008-02-24 - Christoph Haas <haas@debian.org> python-iplib (1.1-1) unstable; urgency=low * New upstream release.

    2007-01-15 - Matthias Klose <doko@ubuntu.com> python-iplib (1.0-2ubuntu1) feisty; urgency=low * Install for all supported python versions. * Remove dependency on versioned python package.

    Advertisement
    Advertisement