python-iowait_0.1-1.1build1_all.deb


Advertisement

Description

python-iowait - Platform-independent module for I/O completion events

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-iowait
Package version 0.1
Package release 1.1build1
Package architecture all
Package type deb
Installed size 58 B
Download size 6.37 KB
Official Mirror archive.ubuntu.com
Different operating systems provide different ways to wait for I/O completion
events: there's select(), poll(), epoll() and kqueue(). For cross-platform
applications it can be a pain to support all this system functions, especially
because each one provides a different interface.
IOWait solves this problem by providing a unified interface and using always
the best and faster function available in the platform. Its only limitation is
that, on Windows, it only works for sockets.

Alternatives

Package Version Architecture Repository
python-iowait_0.1-1.1build1_all.deb 0.1 all Ubuntu Universe
python-iowait - - -

Requires

Name Value
python << 2.8
python >= 2.7.1-0ubuntu2
python2.7 -

Download

Type URL
Binary Package python-iowait_0.1-1.1build1_all.deb
Source Package python-iowait

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-iowait deb package:
    # sudo apt-get install python-iowait

Files

Path
/usr/lib/python2.7/dist-packages/iowait-0.1.egg-info
/usr/lib/python2.7/dist-packages/iowait.py
/usr/share/doc/python-iowait/README
/usr/share/doc/python-iowait/changelog.Debian.gz
/usr/share/doc/python-iowait/copyright
/usr/share/pyshared/iowait-0.1.egg-info
/usr/share/pyshared/iowait.py

Changelog

2011-12-31 - Matthias Klose <doko@ubuntu.com>
python-iowait (0.1-1.1build1) precise; urgency=low
* Rebuild to drop python2.6 dependencies.
2011-05-08 - Piotr O┼╝arowski <piotr@debian.org>
python-iowait (0.1-1.1) unstable; urgency=low
* Non-maintainer upload.
* Rebuild to add Python 2.7 support
2011-01-24 - Andrea Corbellini <andrea.corbellini@ubuntu.com>
python-iowait (0.1-1) unstable; urgency=low
* Initial release.

See Also

Package Description
python-ipaclient_4.3.1-0ubuntu1_all.deb FreeIPA centralized identity framework -- Python modules for ipaclient
python-ipalib_4.3.1-0ubuntu1_amd64.deb FreeIPA centralized identity framework -- shared Python modules
python-ipaserver_4.3.1-0ubuntu1_all.deb FreeIPA centralized identity framework -- Python modules for server
python-ipatests_4.3.1-0ubuntu1_all.deb FreeIPA centralized identity framework -- Python modules for tests
python-ipcalc_1.1.3-1_all.deb Python IP subnet calculator
python-ipdb_0.8.1-1_all.deb IPython-based pdb replacement
python-iplib_1.1-3.1ubuntu1_all.deb Python library to convert amongst many different IPv4 notations
python-iptcdata_1.0.4-4ubuntu1_amd64.deb Python bindings for the iptcdata library
python-ipy_0.83-1_all.deb Python module for handling IPv4 and IPv6 addresses and networks
python-ipython-genutils_0.1.0-1_all.deb IPython vestigial utilities for Python 2
python-irc_8.5.3+dfsg-2_all.deb Internet Relay Chat (IRC) protocol client library for Python
python-irclib_0.4.8-1.1_all.deb IRC client library for Python
python-ironic-inspector-client_1.5.0-2_all.deb client for Ironic Inspector - Python 2.7
python-ironic-inspector_3.2.0-2_all.deb discovering hardware properties for OpenStack Ironic - Python 2.7
python-ironic-lib_1.1.0-1_all.deb common library used by various Ironic projects - Python 2.7
Advertisement
Advertisement