python-invoke_0.11.1+dfsg1-1_all.deb


Advertisement

Description

python-invoke - Pythonic task execution - Python 2.x

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-invoke
Package version: 0.11.1+dfsg1
Package release: 1
Package architecture: all
Package type: deb
Installed size: 190 B
Download size: 44.75 KB
Official Mirror: archive.ubuntu.com
Invoke is a Python (2.6+ and 3.2+) task execution tool and library, drawing inspiration from various sources to arrive at a powerful and clean feature set. Like Ruby's Rake tool and Invoke's own predecessor Fabric 1.x, it provides a clean, high level API for running shell commands and defining/organizing task functions from a tasks.py file. From GNU Make, it inherits an emphasis on minimal boilerplate for common patterns and the ability to run multiple tasks in a single invocation. Following the lead of most Unix CLI applications, it offers a traditional flag-based style of command-line parsing, deriving flag names and value types from task signatures. Like many of its predecessors, it offers advanced features as well: namespacing, task aliasing, before/after hooks, parallel execution and more. This package contains the Python 2.x module.

Alternatives

    Download

    Source package: python-invoke

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-invoke deb package:
      # sudo apt-get install python-invoke

    Files

    • /usr/bin/python2-inv
    • /usr/bin/python2-invoke
    • /usr/lib/python2.7/dist-packages/invoke/__init__.py
    • /usr/lib/python2.7/dist-packages/invoke/_version.py
    • /usr/lib/python2.7/dist-packages/invoke/cli.py
    • /usr/lib/python2.7/dist-packages/invoke/collection.py
    • /usr/lib/python2.7/dist-packages/invoke/config.py
    • /usr/lib/python2.7/dist-packages/invoke/context.py
    • /usr/lib/python2.7/dist-packages/invoke/env.py
    • /usr/lib/python2.7/dist-packages/invoke/exceptions.py
    • /usr/lib/python2.7/dist-packages/invoke/executor.py
    • /usr/lib/python2.7/dist-packages/invoke/loader.py
    • /usr/lib/python2.7/dist-packages/invoke/platform.py
    • /usr/lib/python2.7/dist-packages/invoke/runners.py
    • /usr/lib/python2.7/dist-packages/invoke/tasks.py
    • /usr/lib/python2.7/dist-packages/invoke/util.py
    • /usr/lib/python2.7/dist-packages/invoke-0.11.1.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/invoke-0.11.1.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/invoke-0.11.1.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/invoke-0.11.1.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/invoke/parser/__init__.py
    • /usr/lib/python2.7/dist-packages/invoke/parser/argument.py
    • /usr/lib/python2.7/dist-packages/invoke/parser/context.py
    • /usr/lib/python2.7/dist-packages/invoke/parser/parser.py
    • /usr/lib/python2.7/dist-packages/invoke/vendor/__init__.py
    • /usr/lib/python2.7/dist-packages/invoke/vendor/fluidity/__init__.py
    • /usr/lib/python2.7/dist-packages/invoke/vendor/fluidity/backwardscompat.py
    • /usr/lib/python2.7/dist-packages/invoke/vendor/fluidity/machine.py
    • /usr/lib/python2.7/dist-packages/invoke/vendor/lexicon/__init__.py
    • /usr/lib/python2.7/dist-packages/invoke/vendor/lexicon/alias_dict.py
    • /usr/lib/python2.7/dist-packages/invoke/vendor/lexicon/attribute_dict.py
    • /usr/share/doc/python-invoke/changelog.Debian.gz
    • /usr/share/doc/python-invoke/copyright

    Changelog

    2015-10-28 - Thomas Goirand <zigo@debian.org> python-invoke (0.11.1+dfsg1-1) unstable; urgency=medium * New upstream release: - Fixes FTBFS (Closes: #802894). * Rewrote unvendorize-six.patch. * Switched to git tags packaging workflow. * Fixed watch file to use github tag rather than broken pypi. * Removed unit testing, because upstream now uses spec, which isn't in Debian. * Using HTTPS for VCS URLs. * Fix debian/copyright ordering, years, and six.py removal.

    2015-10-24 - Thomas Goirand <zigo@debian.org> python-invoke (0.9.0-2) unstable; urgency=medium * override_dh_python3 to fix Py3 shebang.

    2014-11-10 - Thomas Goirand <zigo@debian.org> python-invoke (0.9.0-1) unstable; urgency=medium * Initial release. (Closes: #768952)

    Advertisement
    Advertisement