python-inotifyx_0.2.0-1_amd64.deb


Advertisement

Description

python-inotifyx - simple Python binding to the Linux inotify

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-inotifyx
Package version 0.2.0
Package release 1
Package architecture amd64
Package type deb
Installed size 81 B
Download size 10.05 KB
Official Mirror archive.ubuntu.com
inotifyx is a Python extension providing access to the Linux
inotify file system event notification API. It is primarily
written in C but has some Python window dressing
inotifyx exists as an alternative to the much known pyinotify bindings
Reasons you might choose inotifyx over pyinotify
* inotifyx is a C extension and does not use ctypes, making it
faster and less prone to subtle breakage due to changes in the inotify API
* inotifyx is a much thinner wrapper around inotify. pyinotify is more
complicated. It does provide features that inotifyx does not, but many of
them are not needed by most applications
* The API provided by pyinotify seems to change in incompatible ways on a
fairly regular basis and with little justification. inotifyx has a simple
API that will change rarely, if ever.

Alternatives

Package Version Architecture Repository
python-inotifyx_0.2.0-1_i386.deb 0.2.0 i386 Ubuntu Universe
python-inotifyx - - -

Requires

Name Value
libc6 >= 2.4
python << 2.8
python >= 2.7.1-0ubuntu2
python2.7 -

Provides

Name Value
python2.7-inotifyx -

Download

Type URL
Binary Package python-inotifyx_0.2.0-1_amd64.deb
Source Package inotifyx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-inotifyx deb package:
    # sudo apt-get install python-inotifyx

Files

Path
/usr/lib/pyshared/python2.7/inotifyx/binding.so
/usr/lib/python2.7/dist-packages/inotifyx-0.2.0.egg-info
/usr/lib/python2.7/dist-packages/inotifyx/__init__.py
/usr/lib/python2.7/dist-packages/inotifyx/binding.so
/usr/lib/python2.7/dist-packages/inotifyx/distinfo.py
/usr/share/doc/python-inotifyx/README
/usr/share/doc/python-inotifyx/changelog.Debian.gz
/usr/share/doc/python-inotifyx/copyright
/usr/share/pyshared/inotifyx-0.2.0.egg-info
/usr/share/pyshared/inotifyx/__init__.py
/usr/share/pyshared/inotifyx/distinfo.py

Changelog

2011-08-15 - Ritesh Raj Sarraf <rrs@debian.org>
inotifyx (0.2.0-1) unstable; urgency=low
* New Upstream Release 
* [63bfabd] add comress for changelogs
* [b48aae1] update debian/watch for launchpad hosting
* [de64451] Switch to dh_python2.
Thanks to Barry  Warsaw (Closes: 633911)
* [41164bf] drop html docs
* [caee400] drop epydoc doc generation
* [c106e5e] drop python-epydoc from build-dep
* [e3ba5ee] add build-arch and build-indep targets
* [4d1b0fc] Update Standards Version to 3.9.2. No changes required
* [12befdb] drop duplicate changelog
* [c1a91fd] remove html install files and doc-base
2011-04-11 - Ritesh Raj Sarraf <rrs@debian.org>
inotifyx (0.1.2-1) unstable; urgency=low
* New Upstream Release (Closes: #620329) 
* Change address to my official Debian address
* Add debian/source/format to explictly specify the source format
* debian/rules:
- Drop the example as it is not shipped any more
- Update clean target
* debian/control:
- Add misc:Depends
- Update Standards Version to 3.9.1
2009-10-28 - Ritesh Raj Sarraf <rrs@researchut.com>
inotifyx (0.1.1-1) unstable; urgency=low
* New Upstream Release
* Have a versioned build dependency on python-(all)-dev since we are using
python helper scripts during build. (Closes: #551684)
* Build Depend on python-all-dev to support different python versions
2009-09-29 - Ritesh Raj Sarraf <rrs@researchut.com>
inotifyx (0.1.0-4) unstable; urgency=low
* Don't manipulate site-packages/ directly, this fails going forward with
Python 2.6. Thanks to Luca Falavigna for the patch
(Closes: #547879) 
* Add doc-base as Recommends since we are now registering the docs with
doc-base
2009-09-03 - Ritesh Raj Sarraf <rrs@researchut.com>
inotifyx (0.1.0-3) unstable; urgency=low
* Update Standards-Version to 3.8.3 (No changes required)
* debian/rules
- Update get-orig-source target to use uscan
- This is an architecture dependent package. Thus binary-arch is the
correct target to be used.
(Closes: #539151)
- Clean the html doc generated from the sources in clean target
- Really ship the generated doc
2009-07-30 - Ritesh Raj Sarraf <rrs@researchut.com>
inotifyx (0.1.0-2) unstable; urgency=low
* debian/rules
- Separate the build and install target. Earlier we were directly
building and installing in the install target which led to build
failure on the s390 arch which called the build target.
(Closes: #539151)
* debian/control
- Switch Version Control from git to subversion to better align with
the Python packaging team
* Update Standards-Version to 3.8.2 (No changes required)
2009-05-27 - Ritesh Raj Sarraf <rrs@researchut.com>
inotifyx (0.1.0-1) unstable; urgency=low
* Initial release (Closes: #527205)

See Also

Package Description
python-input-pad_1.0.3-1_amd64.deb On-screen Input Pad to Send Characters with Mouse - python
python-instagram_1.3.2+git20160108~dfeebe9-4_all.deb Python 2 client for the Instagram REST and Search APIs
python-instant_1.6.0-1_all.deb simple inlining of C / C++ code in Python
python-interactive-markers_1.11.1-2_all.deb Robot OS interactive_markers python package
python-invocations_0.6.2-2_all.deb reusable invoke tasks - Python 2.x
python-invoke_0.11.1+dfsg1-1_all.deb Pythonic task execution - Python 2.x
python-ioprocess_0.15.1-2ubuntu1_all.deb Python bindings for ioprocess
python-iowait_0.1-1.1build1_all.deb Platform-independent module for I/O completion events
python-ipaclient_4.3.1-0ubuntu1_all.deb FreeIPA centralized identity framework -- Python modules for ipaclient
python-ipalib_4.3.1-0ubuntu1_amd64.deb FreeIPA centralized identity framework -- shared Python modules
python-ipaserver_4.3.1-0ubuntu1_all.deb FreeIPA centralized identity framework -- Python modules for server
python-ipatests_4.3.1-0ubuntu1_all.deb FreeIPA centralized identity framework -- Python modules for tests
python-ipcalc_1.1.3-1_all.deb Python IP subnet calculator
python-ipdb_0.8.1-1_all.deb IPython-based pdb replacement
python-iplib_1.1-3.1ubuntu1_all.deb Python library to convert amongst many different IPv4 notations
Advertisement
Advertisement