python-imposm_2.6.0+ds-2_amd64.deb


Advertisement

Description

python-imposm - importer for OpenStreetMap data - Python module

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-imposm
Package version: 2.6.0+ds
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 1.00 KB
Download size: 145.31 KB
Official Mirror: archive.ubuntu.com
Imposm is an importer for OpenStreetMap data. It reads XML and PBF files and can import the data into PostgreSQL/PostGIS databases. It is designed to create databases that are optimized for rendering/WMS services. This package contains the Python module

Alternatives

Provides

  • python2.7-imposm

    Download

    Source package: imposm

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-imposm deb package:
      # sudo apt-get install python-imposm

    Files

    • /usr/lib/python2.7/dist-packages/imposm-2.6.0-nspkg.pth
    • /usr/lib/python2.7/dist-packages/imposm/900913.sql
    • /usr/lib/python2.7/dist-packages/imposm/app.py
    • /usr/lib/python2.7/dist-packages/imposm/base.py
    • /usr/lib/python2.7/dist-packages/imposm/config.py
    • /usr/lib/python2.7/dist-packages/imposm/dbimporter.py
    • /usr/lib/python2.7/dist-packages/imposm/defaultmapping.py
    • /usr/lib/python2.7/dist-packages/imposm/geom.py
    • /usr/lib/python2.7/dist-packages/imposm/mapping.py
    • /usr/lib/python2.7/dist-packages/imposm/merge.py
    • /usr/lib/python2.7/dist-packages/imposm/multipolygon.py
    • /usr/lib/python2.7/dist-packages/imposm/psqldb.py
    • /usr/lib/python2.7/dist-packages/imposm/reader.py
    • /usr/lib/python2.7/dist-packages/imposm/version.py
    • /usr/lib/python2.7/dist-packages/imposm/writer.py
    • /usr/lib/python2.7/dist-packages/imposm-2.6.0.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/imposm-2.6.0.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/imposm-2.6.0.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/imposm-2.6.0.egg-info/namespace_packages.txt
    • /usr/lib/python2.7/dist-packages/imposm-2.6.0.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/imposm-2.6.0.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/imposm/cache/__init__.py
    • /usr/lib/python2.7/dist-packages/imposm/cache/internal.cc
    • /usr/lib/python2.7/dist-packages/imposm/cache/internal.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/imposm/cache/osm.py
    • /usr/lib/python2.7/dist-packages/imposm/cache/tc.c
    • /usr/lib/python2.7/dist-packages/imposm/cache/tc.pyx
    • /usr/lib/python2.7/dist-packages/imposm/cache/tc.x86_64-linux-gnu.so
    • /usr/lib/python2.7/dist-packages/imposm/db/__init__.py
    • /usr/lib/python2.7/dist-packages/imposm/db/config.py
    • /usr/lib/python2.7/dist-packages/imposm/db/postgis.py
    • /usr/lib/python2.7/dist-packages/imposm/test/__init__.py
    • /usr/lib/python2.7/dist-packages/imposm/test/test_cache.py
    • /usr/lib/python2.7/dist-packages/imposm/test/test_dbimporter.py
    • /usr/lib/python2.7/dist-packages/imposm/test/test_field_types.py
    • /usr/lib/python2.7/dist-packages/imposm/test/test_imported.py
    • /usr/lib/python2.7/dist-packages/imposm/test/test_large_limit_to_geom.py
    • /usr/lib/python2.7/dist-packages/imposm/test/test_limit_to.py
    • /usr/lib/python2.7/dist-packages/imposm/test/test_multipolygon.py
    • /usr/lib/python2.7/dist-packages/imposm/test/test_tag_mapper.py
    • /usr/lib/python2.7/dist-packages/imposm/util/__init__.py
    • /usr/lib/python2.7/dist-packages/imposm/util/geom.py
    • /usr/lib/python2.7/dist-packages/imposm/util/lib.py
    • /usr/lib/python2.7/dist-packages/imposm/util/ogr.py
    • /usr/share/doc/python-imposm/changelog.Debian.gz
    • /usr/share/doc/python-imposm/copyright
    • /usr/share/python-imposm/900913.sql
    • /usr/share/python/ns/python-imposm

    Changelog

    2015-09-01 - Bas Couwenberg <sebastic@debian.org> imposm (2.6.0+ds-2) unstable; urgency=medium * Team upload. * Add build dependencies on python-rtree, libgeos-dev, libgdal-dev & libspatialindex-dev. * Add Recommends on python-rtree and libgdal-dev to python-imposm.

    2015-08-31 - Bas Couwenberg <sebastic@debian.org> imposm (2.6.0+ds-1) unstable; urgency=medium * Team upload. * New upstream release. * Change Maintainer from Debian OpenStreetMap Team to Debian GIS Project. * Update watch file to use pypi.debian.net. * Update copyright file, changes: - Rename Upstream-Author to Upstream-Contact - Rename Upstream-Source to Source - Drop © character from copyright statements - Use more common Apache-2.0 standalone license paragraph - Update copyright years for Omniscale * Restructure control file with cme, changes: - Bump Standards-Version to 3.9.6, no changes - Update Vcs-Browser URL to use cgit instead of gitweb, and HTTPS * Add gbp.conf to use pristine-tar by default. * Use pybuild buildsystem and enable parallel builds. * Add upstream metadata. * Repack upstream tarball to exclude .egg-info directory. * Add build dependencies for tests: python-shapely, python-nose, python-psycopg2 & python-imposm-parser. * Override dh_auto_test to ignore test failures. * Add patch to fix Shapely geos_capi_version check. * Drop sql file location patch in favor of symlinks.

    2013-11-04 - David Paleino <dapal@debian.org> imposm (2.5.0-3) unstable; urgency=low * Really fix Vcs-Browser url.

    2013-11-04 - David Paleino <dapal@debian.org> imposm (2.5.0-2) unstable; urgency=low * Upload to unstable. * Standards-Version bump to 3.9.5, no changes needed. * Use canonical Vcs-* urls.

    2012-12-12 - David Paleino <dapal@debian.org> imposm (2.5.0-1) experimental; urgency=low * Acknowledge NMU. * New upstream version. * Standards-Version bump to 3.9.4, no changes needed. * debhelper compat bumped to 9.

    2012-12-04 - Michael Stapelberg <stapelberg@debian.org> imposm (2.4.0+dfsg-0.1) unstable; urgency=low * Non-maintainer upload. * Remove generated file without source cache/kc.c from upstream tarball (Closes: #694972).

    2012-04-08 - David Paleino <dapal@debian.org> imposm (2.4.0-1) unstable; urgency=low * New upstream version * Updated debian/copyright * Standards-Version bump to 3.9.3, no changes needed

    2011-10-14 - David Paleino <dapal@debian.org> imposm (2.3.2-2) unstable; urgency=low * Add missing dependency on python-pkg-resources (Closes: #645253)

    2011-10-11 - David Paleino <dapal@debian.org> imposm (2.3.2-1) unstable; urgency=low * Initial release (Closes: #645026)

    Advertisement
    Advertisement