python-impacket_0.9.12-1_all.deb


Advertisement

Description

python-impacket - Python module to easily build and dissect network protocols

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-impacket
Package version 0.9.12
Package release 1
Package architecture all
Package type deb
Installed size 4.33 KB
Download size 607.56 KB
Official Mirror archive.ubuntu.com
Impacket  is a  collection  of Python  classes  focused on  providing
access  to network  packets.   Impacket allows  Python developers  to
craft and decode network packets in simple and consistent manner.  It
includes support for low-level protocols  such as IP, UDP and TCP, as
well as higher-level protocols such as NMB and SMB.
Impacket is highly  effective when used in conjunction  with a packet
capture utility or package such as Pcapy.  Packets can be constructed
From  scratch, as  well as  parsed from  raw data.   Furthermore, the
object  oriented API  makes  it  simple to  work  with deep  protocol
hierarchies.

Alternatives

Package Version Architecture Repository
python-impacket_0.9.12-1_all.deb 0.9.12 all Ubuntu Universe
python-impacket - - -

Requires

Name Value
python << 2.8
python >= 2.7
python-crypto >= 2.6

Download

Type URL
Binary Package python-impacket_0.9.12-1_all.deb
Source Package impacket

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-impacket deb package:
    # sudo apt-get install python-impacket

Files

Path
/usr/lib/python2.7/dist-packages/impacket-0.9.12.egg-info
/usr/lib/python2.7/dist-packages/impacket/Dot11Crypto.py
/usr/lib/python2.7/dist-packages/impacket/Dot11KeyManager.py
/usr/lib/python2.7/dist-packages/impacket/ICMP6.py
/usr/lib/python2.7/dist-packages/impacket/IP6.py
/usr/lib/python2.7/dist-packages/impacket/IP6_Address.py
/usr/lib/python2.7/dist-packages/impacket/IP6_Extension_Headers.py
/usr/lib/python2.7/dist-packages/impacket/ImpactDecoder.py
/usr/lib/python2.7/dist-packages/impacket/ImpactPacket.py
/usr/lib/python2.7/dist-packages/impacket/NDP.py
/usr/lib/python2.7/dist-packages/impacket/__init__.py
/usr/lib/python2.7/dist-packages/impacket/cdp.py
/usr/lib/python2.7/dist-packages/impacket/crypto.py
/usr/lib/python2.7/dist-packages/impacket/dhcp.py
/usr/lib/python2.7/dist-packages/impacket/dns.py
/usr/lib/python2.7/dist-packages/impacket/dot11.py
/usr/lib/python2.7/dist-packages/impacket/eap.py
/usr/lib/python2.7/dist-packages/impacket/ese.py
/usr/lib/python2.7/dist-packages/impacket/helper.py
/usr/lib/python2.7/dist-packages/impacket/hresult_errors.py
/usr/lib/python2.7/dist-packages/impacket/logger.py
/usr/lib/python2.7/dist-packages/impacket/nmb.py
/usr/lib/python2.7/dist-packages/impacket/nt_errors.py
/usr/lib/python2.7/dist-packages/impacket/ntlm.py
/usr/lib/python2.7/dist-packages/impacket/pcapfile.py
/usr/lib/python2.7/dist-packages/impacket/smb.py
/usr/lib/python2.7/dist-packages/impacket/smb3.py
/usr/lib/python2.7/dist-packages/impacket/smb3structs.py
/usr/lib/python2.7/dist-packages/impacket/smbconnection.py
/usr/lib/python2.7/dist-packages/impacket/smbserver.py
/usr/lib/python2.7/dist-packages/impacket/spnego.py
/usr/lib/python2.7/dist-packages/impacket/structure.py
/usr/lib/python2.7/dist-packages/impacket/system_errors.py
/usr/lib/python2.7/dist-packages/impacket/tds.py
/usr/lib/python2.7/dist-packages/impacket/uuid.py
/usr/lib/python2.7/dist-packages/impacket/version.py
/usr/lib/python2.7/dist-packages/impacket/winregistry.py
/usr/lib/python2.7/dist-packages/impacket/wps.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/__init__.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/atsvc.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/conv.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/dcerpc.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/dcerpc_v4.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/dcom.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/epm.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/lsarpc.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/mgmt.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/ndrutils.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/printer.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/samr.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/srvsvc.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/srvsvcserver.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/svcctl.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/transport.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/winreg.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/wkssvc.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/__init__.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/dcomrt.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/dtypes.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/enum.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/epm.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/lsad.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/lsat.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/ndr.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/nrpc.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/rpcrt.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/rrp.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/samr.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/scmr.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/srvs.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/transport.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/wkst.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/dcom/__init__.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/dcom/comev.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/dcom/oaut.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/dcom/scmp.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/dcom/vds.py
/usr/lib/python2.7/dist-packages/impacket/dcerpc/v5/dcom/wmi.py
/usr/lib/python2.7/dist-packages/impacket/examples/__init__.py
/usr/lib/python2.7/dist-packages/impacket/examples/remcomsvc.py
/usr/lib/python2.7/dist-packages/impacket/examples/serviceinstall.py
/usr/share/doc/python-impacket/README
/usr/share/doc/python-impacket/changelog.Debian.gz
/usr/share/doc/python-impacket/copyright
/usr/share/doc/python-impacket/examples/atexec.py
/usr/share/doc/python-impacket/examples/esentutl.py
/usr/share/doc/python-impacket/examples/ifmap.py
/usr/share/doc/python-impacket/examples/lookupsid.py
/usr/share/doc/python-impacket/examples/loopchain.py
/usr/share/doc/python-impacket/examples/mssqlclient.py
/usr/share/doc/python-impacket/examples/mssqlinstance.py
/usr/share/doc/python-impacket/examples/nmapAnswerMachine.py
/usr/share/doc/python-impacket/examples/ntfs-read.py
/usr/share/doc/python-impacket/examples/opdump.py
/usr/share/doc/python-impacket/examples/os_ident.py
/usr/share/doc/python-impacket/examples/ping.py
/usr/share/doc/python-impacket/examples/ping6.py
/usr/share/doc/python-impacket/examples/psexec.py
/usr/share/doc/python-impacket/examples/rdp_check.py
/usr/share/doc/python-impacket/examples/registry-read.py
/usr/share/doc/python-impacket/examples/rpcdump.py
/usr/share/doc/python-impacket/examples/samrdump.py
/usr/share/doc/python-impacket/examples/secretsdump.py
/usr/share/doc/python-impacket/examples/services.py
/usr/share/doc/python-impacket/examples/smbclient.py
/usr/share/doc/python-impacket/examples/smbexec.py
/usr/share/doc/python-impacket/examples/smbrelayx.py
/usr/share/doc/python-impacket/examples/smbserver.py
/usr/share/doc/python-impacket/examples/smbtorture.py
/usr/share/doc/python-impacket/examples/sniff.py
/usr/share/doc/python-impacket/examples/sniffer.py
/usr/share/doc/python-impacket/examples/split.py
/usr/share/doc/python-impacket/examples/tracer.py
/usr/share/doc/python-impacket/examples/uncrc32.py
/usr/share/doc/python-impacket/examples/wmiexec.py
/usr/share/doc/python-impacket/examples/wmiquery.py

Changelog

2014-10-16 - Arnaud Fontaine <arnau@debian.org>
impacket (0.9.12-1) unstable; urgency=medium
* New upstream release. Closes: #703784.
+ d/patches: refreshed.
* d/watch: upstream source location has changed.
* d/control: bump Standards-Version to 3.9.6. No changes needed.
2013-05-27 - Arnaud Fontaine <arnau@debian.org>
impacket (0.9.10-1) unstable; urgency=low
[ Arnaud Fontaine ]
* New upstream release. Closes: #703773.
+ Merge python-impacket-doc into python-impacket as doc is not included
in upstream source anymore.
+ Refresh debian/patches/*.
+ debian/control: add Depends against python-crypto.
* debian/control:
+ Bump Standards-Version to 3.9.4.
- Add debian/README.source.
* Use dh_python2 rather than deprecated pysupport:
+ debian/control:
- Bump cdbs version to 0.4.90~.
- Replace python-dev by python-all (all) and bump version to 2.6.6-3~.
- Drop Build-Depends against python-support.
+ debian/rules: remove DEB_PYTHON_SYSTEM line.
+ Remove debian/pyversions and debian/pycompat.
* Use 3.0 (quilt) format.
+ debian/rules: no need to use patchsys-quilt.mk anymore.
+ debian/control: remove Build-Depends on quilt.
* Update copyright years.
* New upstream URL.
+ Update URL in debian/watch and debian/copyright.
[ Sandro Tosi ]
* debian/control:
+ Uniforming Vcs-Browser field.
+ Switch Vcs-Browser field to viewsvn.
[ Jakub Wilk ]
* Use canonical URIs for Vcs-* fields.
2007-12-09 - Arnaud Fontaine <arnau@debian.org>
impacket (0.9.6.0-3) unstable; urgency=low
[ Arnaud Fontaine ]
* New email address.
* Remove useless debian/control.in.
* debian/control:
+ Update Standards-Version to 3.7.3. No changes needed.
* debian/copyright:
+ Add package license.
[ Piotr O┼╝arowski ]
* debian/control:
+ Added Vcs-Svn, Vcs-Browser and Homepage fields.
[ Jan Michael Alonzo ]
* Fix watch file and updated it to version=3. Closes: #450377.
2006-09-27 - Arnaud Fontaine <arnaud@andesi.org>
impacket (0.9.6.0-2) unstable; urgency=low
* debian/control.in:
+ Add missing Recommends for python-impacket-doc against python-pcapy.
Closes: #389657.
2006-06-20 - Arnaud Fontaine <arnaud@andesi.org>
impacket (0.9.6.0-1) unstable; urgency=low
* New upstream release.
+ Add debian/python-impacket-doc.docs for doc/.
* debian/control.in:
+ Update Standards-Version to 3.7.2. No changes needed.
* New Python policy changes. Closes: #373444.
+ debian/compat:
- Update debhelper compatibility to 5.
+ debian/rules:
- Add DEB_PYTHON_SYSTEM=pysupport.
+ debian/control.in
- Clean Build-Depends and Depends, cdbs handles that 
automatically now.
- XB-Python-Version and Provides for binary package.
+ debian/postinst && debian/prerm:
- Remove "hand made" python-support stuff, cdbs does this.
2006-04-18 - Arnaud Fontaine <arnaud@andesi.org>
impacket (0.9.5.2-2) unstable; urgency=low
* Use python-support and then remove python2.3-impacket and
python2.4-impacket packages.
* Move all Build-Depends to Build-Depends-Indep according 
to the debian policy.
* Update Standards-Version to 3.7.0 in debian/control*.
2006-04-11 - Arnaud Fontaine <arnaud@andesi.org>
impacket (0.9.5.2-1) unstable; urgency=low
* Initial release. Closes: #361966.

See Also

Package Description
python-imposm-parser_1.0.7+ds-2_amd64.deb Python module to parse OpenStreetMap data
python-imposm_2.6.0+ds-2_amd64.deb importer for OpenStreetMap data - Python module
python-indicate_12.10.1-0ubuntu5_amd64.deb Python bindings for libindicate
python-indigo_1.1.12-1.1_all.deb Organic Chemistry Toolkit (Python module)
python-inflect_0.2.5-1_all.deb Generate plurals, singular nouns, ordinals, indefinite articles
python-influxdb_2.12.0-1_all.deb Client for InfluxDB - Python 2.7
python-iniparse_0.4-2.2_all.deb access and modify configuration data in INI files (Python 2)
python-inotifyx_0.2.0-1_amd64.deb simple Python binding to the Linux inotify
python-input-pad_1.0.3-1_amd64.deb On-screen Input Pad to Send Characters with Mouse - python
python-instagram_1.3.2+git20160108~dfeebe9-4_all.deb Python 2 client for the Instagram REST and Search APIs
python-instant_1.6.0-1_all.deb simple inlining of C / C++ code in Python
python-interactive-markers_1.11.1-2_all.deb Robot OS interactive_markers python package
python-invocations_0.6.2-2_all.deb reusable invoke tasks - Python 2.x
python-invoke_0.11.1+dfsg1-1_all.deb Pythonic task execution - Python 2.x
python-ioprocess_0.15.1-2ubuntu1_all.deb Python bindings for ioprocess
Advertisement
Advertisement