python-ieee1284_0.2.11-12_amd64.deb


Advertisement

Description

python-ieee1284 - Python bindings to libieee1284

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-ieee1284
Package version: 0.2.11
Package release: 12
Package architecture: amd64
Package type: deb
Installed size: 83 B
Download size: 10.11 KB
Official Mirror: archive.ubuntu.com
This module offers bindings to libieee1284, a cross-platform library for parallel port access. The library runs on Linux, BSD, Windows, Solaris.

Alternatives

Provides

  • python2.7-ieee1284

    Download

    Source package: libieee1284

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-ieee1284 deb package:
      # sudo apt-get install python-ieee1284

    Files

    • /usr/lib/pyshared/python2.7/ieee1284module.so
    • /usr/lib/python2.7/dist-packages/ieee1284module.so
    • /usr/share/doc/python-ieee1284/changelog.Debian.gz
    • /usr/share/doc/python-ieee1284/copyright

    Changelog

    2013-09-01 - Laszlo Boszormenyi (GCS) <gcs@debian.org> libieee1284 (0.2.11-12) unstable; urgency=low * New maintainer (closes: #688539). * Update packaging. [ Daniel Schepler <schepler@debian.org> ] * Update libtool at build time using dh-autoreconf, in order to fix a build failure on x32 (closes: #702312).

    2013-04-03 - Emanuele Rocca <ema@debian.org> libieee1284 (0.2.11-11) unstable; urgency=low * QA upload. * Maintainer field set to QA Group. * Bump Standards-Version to 3.9.4. * Enable hardened build flags. * Add debian/watch. * Add build-{arch,indep} targets.

    2011-07-20 - Julien BLACHE <jblache@debian.org> libieee1284 (0.2.11-10) unstable; urgency=low * dh_python2 migration. * debian/control: + Remove python-support build-dep. + Bump python-all-dev build-dep to (>= 2.6.6-3~). + Add X-Python-Version: >= 2.2. * debian/pyversions: + Remove. * debian/rules: + Use dh_python2 instead of dh_pysupport.

    2011-06-13 - Julien BLACHE <jblache@debian.org> libieee1284 (0.2.11-9) unstable; urgency=low * debian/rules: + Establish temporary libieee1284.so symlink for Python modules installation to handle multiarch vs. non-multiarch paths for the main library and Python modules.

    2011-06-13 - Julien BLACHE <jblache@debian.org> libieee1284 (0.2.11-8) unstable; urgency=low * Multiarch conversion. * debian/control: + Bump debhelper build-dep to >= 8.1.3 for multiarch. + Add Pre-Depends: ${misc:Pre-Depends} to libieee1284-3. + Tag libieee1284-3 with Multi-Arch: same. * debian/rules: + Set multiarch path for the main library build. * debian/libieee1284-3.install, debian/libieee1284-3-dev.install: + Adapt for multiarch. * debian/*.dirs: + Removed; unneeded.

    2011-04-08 - Julien BLACHE <jblache@debian.org> libieee1284 (0.2.11-7) unstable; urgency=low * debian/control: + Bump Standards-Version to 3.9.2 (no changes). * debian/libieee1284-3-dev.install: + Don't install libtool .la file (closes: #621535).

    2010-05-06 - Julien BLACHE <jblache@debian.org> libieee1284 (0.2.11-6) unstable; urgency=low * Moved to source format 3.0 (quilt). * debian/control: + Bump Standards-Version to 3.8.4 (no changes). + Add ${misc:Depends}. + Remove dpatch build-dep. * debian/rules: + Remove dpatch code. * All patches refreshed, tagged with DEP-3 headers.

    2008-07-10 - Julien BLACHE <jblache@debian.org> libieee1284 (0.2.11-5) unstable; urgency=low * debian/control: + Bump Standards-Version to 3.8.0 (no changes). * debian/copyright: + Add missing copyright statements.

    2008-01-18 - Julien BLACHE <jblache@debian.org> libieee1284 (0.2.11-4) unstable; urgency=low * debian/patches/02_release_on_close.dpatch: + Added; release port on close, helps with the python module when an object gets deleted. Patch from Uwe Kleine-Koenig <Uwe.Kleine-Koenig@digi.com> (closes: #461068).

    2007-12-07 - Julien BLACHE <jblache@debian.org> libieee1284 (0.2.11-3) unstable; urgency=low * debian/rules: + Move patch/unpatch rules into debian/rules. + Rework python modules builds. + Fix parallel builds. * debian/control: + Bump Standards-Version to 3.7.3 (no changes).

    Advertisement
    Advertisement