python-hacking_0.10.2-4_all.deb


Advertisement

Description

python-hacking - Flake8 OpenStack Hacking Guidelines Enforcement plugins - Python 2.x

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-hacking
Package version: 0.10.2
Package release: 4
Package architecture: all
Package type: deb
Installed size: 88 B
Download size: 16.19 KB
Official Mirror: archive.ubuntu.com
Hacking is a set of flake8 plugins that test and enforce the OpenStack Style Commandments. It checks that your code matches the coding style which is mandatory for contributing to OpenStack. This package provides the Python 2.x module.

Alternatives

    Download

    Source package: python-hacking

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-hacking deb package:
      # sudo apt-get install python-hacking

    Files

    • /usr/lib/python2.7/dist-packages/hacking/__init__.py
    • /usr/lib/python2.7/dist-packages/hacking/config.py
    • /usr/lib/python2.7/dist-packages/hacking/core.py
    • /usr/lib/python2.7/dist-packages/hacking-0.10.2.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/hacking-0.10.2.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/hacking-0.10.2.egg-info/entry_points.txt
    • /usr/lib/python2.7/dist-packages/hacking-0.10.2.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/hacking-0.10.2.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/hacking-0.10.2.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/hacking/checks/__init__.py
    • /usr/lib/python2.7/dist-packages/hacking/checks/comments.py
    • /usr/lib/python2.7/dist-packages/hacking/checks/dictlist.py
    • /usr/lib/python2.7/dist-packages/hacking/checks/docstrings.py
    • /usr/lib/python2.7/dist-packages/hacking/checks/except_checks.py
    • /usr/lib/python2.7/dist-packages/hacking/checks/imports.py
    • /usr/lib/python2.7/dist-packages/hacking/checks/localization.py
    • /usr/lib/python2.7/dist-packages/hacking/checks/other.py
    • /usr/lib/python2.7/dist-packages/hacking/checks/python23.py
    • /usr/lib/python2.7/dist-packages/hacking/tests/__init__.py
    • /usr/lib/python2.7/dist-packages/hacking/tests/test_config.py
    • /usr/lib/python2.7/dist-packages/hacking/tests/test_doctest.py
    • /usr/lib/python2.7/dist-packages/hacking/tests/test_import_exceptions.py
    • /usr/lib/python2.7/dist-packages/hacking/tests/test_local.py
    • /usr/lib/python2.7/dist-packages/hacking/tests/checks/__init__.py
    • /usr/lib/python2.7/dist-packages/hacking/tests/checks/test_comments.py
    • /usr/share/doc/python-hacking/changelog.Debian.gz
    • /usr/share/doc/python-hacking/copyright

    Changelog

    2015-10-16 - Thomas Goirand <zigo@debian.org> python-hacking (0.10.2-4) unstable; urgency=medium * Uploading to unstable.

    2015-09-22 - Thomas Goirand <zigo@debian.org> python-hacking (0.10.2-3) experimental; urgency=medium * Fixed (build-)dependencies which where quite wrong. * Removed doc/source/static/nature.css from debian/copyright (it's gone from upstream source code).

    2015-06-02 - James Page <james.page@ubuntu.com> python-hacking (0.10.2-2) experimental; urgency=medium * Team upload. * d/control: Drop upper version boundary for pbr, no longer required.

    2015-06-01 - James Page <james.page@ubuntu.com> python-hacking (0.10.2-1) experimental; urgency=medium * Team upload. * New upstream release: - d/control: Align version requirements with upstream. - d/p/no-intersphinx.patch: Dropped no longer needed. - d/p/fix-requirements.txt.patch: Refresh, allow use of flake8 2.2.2.

    2015-05-30 - Clint Adams <clint@debian.org> python-hacking (0.9.2-1) unstable; urgency=medium * New upstream version.

    2015-05-30 - Clint Adams <clint@debian.org> python-hacking (0.9.0-1) unstable; urgency=medium * New upstream version. - Update fix-requirements.txt.patch.

    2014-05-03 - Thomas Goirand <zigo@debian.org> python-hacking (0.8.1-4) unstable; urgency=medium * Fixes requirements to allow pyflakes >= 0.8 (Closes: #745644).

    2014-03-25 - Thomas Goirand <zigo@debian.org> python-hacking (0.8.1-3) unstable; urgency=medium * Uploading to unstable. * Fixed missing BSD-2-clause license for nature.css in debian/copyright. * Calling testr / subunit without going through setup.py. * dh_clean also rm -rf .testrepository.

    2014-03-23 - Thomas Goirand <zigo@debian.org> python-hacking (0.8.1-2) experimental; urgency=medium * Added missing build-depends: python3-pbr.

    2014-03-21 - Thomas Goirand <zigo@debian.org> python-hacking (0.8.1-1) experimental; urgency=low * New upstream release. * Uploading to experimental. * Added support for Python 3. * fix requirements.txt for flake8 and pep8 versions (Closes: #742256).

    Advertisement
    Advertisement