python-gtk-vnc_0.5.3-1.3ubuntu2_amd64.deb


Advertisement

Description

python-gtk-vnc - VNC viewer widget for GTK+2 (Python binding)

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-gtk-vnc
Package version: 0.5.3
Package release: 1.3ubuntu2
Package architecture: amd64
Package type: deb
Installed size: 46 B
Download size: 8.63 KB
Official Mirror: archive.ubuntu.com
It is built using coroutines, allowing it to be completely asynchronous while remaining single threaded. It supports RFB protocols 3.3 through 3.8 and the VeNCrypt authentication extension providing SSL/TLS encryption with x509 certificate authentication. The core library is written in C and a binding for Python using PyGTK is available. The networking layer supports connections over both IPv4 and IPv6. This package contains the Python binding.

Alternatives

    Download

    Source package: gtk-vnc

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-gtk-vnc deb package:
      # sudo apt-get install python-gtk-vnc

    Files

    • /usr/lib/python2.7/dist-packages/gtkvnc.so
    • /usr/share/doc/python-gtk-vnc/changelog.Debian.gz
    • /usr/share/doc/python-gtk-vnc/copyright

    Changelog

    2016-02-17 - Matthias Klose <doko@ubuntu.com> gtk-vnc (0.5.3-1.3ubuntu2) xenial; urgency=medium * No-change rebuild for gnutls transition.

    2016-01-28 - Matthias Klose <doko@ubuntu.com> gtk-vnc (0.5.3-1.3ubuntu1) xenial; urgency=medium * Multiarchify the library packages.

    2014-10-09 - Matthias Klose <doko@debian.org> gtk-vnc (0.5.3-1.3) unstable; urgency=medium * Non-maintainer upload. * Build-depend on libtool-bin. Closes: #761755.

    2014-08-30 - Andreas Metzler <ametzler@debian.org> gtk-vnc (0.5.3-1.2) unstable; urgency=medium * Non-maintainer upload. * Upload to unstable. * Use dh-autoreconf (Patch by Breno Leitao). Closes: #746403

    2014-08-15 - Andreas Metzler <ametzler@debian.org> gtk-vnc (0.5.3-1.1) experimental; urgency=medium * Non-maintainer upload. * Change (build-)dependencies from libgnutls-dev to libgnutls28-dev and add a build-dependency on libgcrypt20-dev. Closes: #745946 * Upload to experimental to test buildability.

    2014-05-04 - Laurent Léonard <laurent@open-minds.org> gtk-vnc (0.5.3-1) unstable; urgency=medium * [66e3bf7] Imported Upstream version 0.5.3 * [c1d21eb] Redo patch * [f5c94bf] Update symbols

    2014-02-15 - Guido Günther <agx@sigxcpu.org> gtk-vnc (0.5.2-3) unstable; urgency=medium * [d2a1860] Depend on valac (>= 0.20) instead of valac-0.20 to ease vala upgrades (Closes: #739026, #738999) * [96583cf] Remove DM-Upload-Allowed. Not used anymore. * [56298bf] Remove xul-runner build-dep since we don't build the iceweasel plugin since ages * [fd993d0] Move introspection data to section introspection * [e113a9b] Bump standards version

    2013-05-22 - Guido Günther <agx@sigxcpu.org> gtk-vnc (0.5.2-2) unstable; urgency=low * [c792964] Switch to Vala 0.20 (Closes: #709166, #675645)

    2013-03-10 - Laurent Léonard <laurent@open-minds.org> gtk-vnc (0.5.2-1) unstable; urgency=low * [63d4584] Imported Upstream version 0.5.2 * [6fbea51] Drop patches - Fix-build-with-xulrunner-8.0.patch - fixed upstream - Use-C99-int-types-instead-of-NSPR-ones.patch - fixed upstream - fix-build-with-xulrunner-1.9.1.patch - fixed upstream * [32e7e95] Remove mozilla-gtk-vnc * [aeff29d] Update symbols

    2012-11-26 - Guido Günther <agx@sigxcpu.org> gtk-vnc (0.5.1-2) unstable; urgency=low * [40547ee] Add proper Breasks/Replaces to libgvnc-1.0-0-dbg. Thanks to Andreas Beckmann for the detailed report and fix (Closes: #694461)

    Advertisement
    Advertisement