python-gphoto2cffi_0.3~a1-1_amd64.deb


Advertisement

Description

python-gphoto2cffi - GPhoto2 bindings with simpler API

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-gphoto2cffi
Package version 0.3~a1
Package release 1
Package architecture amd64
Package type deb
Installed size 191 B
Download size 34.43 KB
Official Mirror archive.ubuntu.com
Python bindings for libgphoto2 with an interface that strives to be idiomatic.
In contrast to other bindings for Python, gphoto2-cffi hides most of the
lower-level abstractions and reduces the API surface while still offering
access to most of the library's features.

Alternatives

Package Version Architecture Repository
python-gphoto2cffi_0.3~a1-1_i386.deb 0.3~a1 i386 Ubuntu Universe
python-gphoto2cffi - - -

Requires

Name Value
libc6 >= 2.4
libgphoto2-6 >= 2.5.9
python >= 2.7~
python << 2.8
python-cffi-backend-api-9729 -
python-enum34 >= 1.0.3
python:any >= 2.7.5-5~

Provides

Name Value
python-gphoto2 -

Conflicts

Name Value
python-gphoto2 << 0.3~a1-1~

Replaces

Name Value
python-gphoto2 << 0.3~a1-1~

Download

Type URL
Binary Package python-gphoto2cffi_0.3~a1-1_amd64.deb
Source Package gphoto2-cffi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gphoto2cffi deb package:
    # sudo apt-get install python-gphoto2cffi

Files

Path
/usr/lib/python2.7/dist-packages/_backend.x86_64-linux-gnu.so
/usr/lib/python2.7/dist-packages/gphoto2_cffi-0.3a1.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/gphoto2_cffi-0.3a1.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/gphoto2_cffi-0.3a1.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/gphoto2_cffi-0.3a1.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/gphoto2_cffi-0.3a1.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/gphoto2cffi/__init__.py
/usr/lib/python2.7/dist-packages/gphoto2cffi/backend.py
/usr/lib/python2.7/dist-packages/gphoto2cffi/backend_build.py
/usr/lib/python2.7/dist-packages/gphoto2cffi/errors.py
/usr/lib/python2.7/dist-packages/gphoto2cffi/gphoto2.cdef
/usr/lib/python2.7/dist-packages/gphoto2cffi/gphoto2.py
/usr/lib/python2.7/dist-packages/gphoto2cffi/util.py
/usr/share/doc/python-gphoto2cffi/changelog.Debian.gz
/usr/share/doc/python-gphoto2cffi/copyright

Changelog

2016-04-04 - Aigars Mahinovs <aigarius@debian.org>
gphoto2-cffi (0.3~a1-1) unstable; urgency=low
* Updated upstream version merging changes
* Binary package renamed following upstream
* Remove unused code
* Thanks to Dmitry Shachnev <mitya57@debian.org> and Damon Lynch for help
2015-10-25 - Aigars Mahinovs <aigarius@debian.org>
gphoto2-cffi (0.2-3) unstable; urgency=low
* Python 3.5 support (Closes: #793328)
2015-06-28 - Aigars Mahinovs <aigarius@debian.org>
gphoto2-cffi (0.2-2) unstable; urgency=low
* Correct the copyright text to LGPL3 only
2015-06-25 - Aigars Mahinovs <aigarius@debian.org>
gphoto2-cffi (0.2-1) unstable; urgency=low
* Initial release

See Also

Package Description
python-gpiv_2.0.0-4.2_amd64.deb wrapper of libgpiv
python-gpod_0.8.3-6ubuntu2_amd64.deb Python bindings for libgpod
python-gps_3.15-2build1_amd64.deb Global Positioning System - Python libraries
python-gpyconf_0.2-1_all.deb Python configuration framework with support for multiple backends
python-grapefruit-doc_0.1~a3+dfsg-1_all.deb Python module to manipulate color information easily - documentation
python-grapefruit_0.1~a3+dfsg-1_all.deb Python module to manipulate color information easily
python-graphy_1.0+dfsg-3build1_all.deb chart generation library for Python
python-graypy_0.2.11-1build1_all.deb Python logging handler that sends messages in GELF (Python 2)
python-grib-doc_2.0.1-1_all.deb Documentation and examples for Python GRIB
python-grib_2.0.1-1_amd64.deb Python module for reading and writing GRIB files
python-gribapi_1.14.4-5_amd64.deb Python module for the ECMWF GRIB API library
python-gridfs_3.2-1build1_all.deb Python implementation of GridFS for MongoDB
python-grokcore.component_2.5-0ubuntu1_all.deb Grok-like configuration for basic components
python-gssapi_1.1.3-2ubuntu1_amd64.deb Python interface to GSSAPI
python-gst-1.0_1.6.2-1build1_amd64.deb GStreamer GObject Introspection overrides for Python
Advertisement
Advertisement