python-gmpy2_2.0.7-2build1_amd64.deb


Advertisement

Description

python-gmpy2 - interfaces GMP to Python 2 for fast, unbound-precision computations

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-gmpy2
Package version: 2.0.7
Package release: 2build1
Package architecture: amd64
Package type: deb
Installed size: 514 B
Download size: 125.73 KB
Official Mirror: archive.ubuntu.com
gmpy is a C-coded Python extension module that wraps the GMP library to provide to Python code fast multiprecision arithmetic (integer, rational, and float), random number generation, advanced number-theoretical functions, and more. This package installs Python 2 support for gmpy2.

Alternatives

Provides

  • python2.7-gmpy2

    Download

    Source package: python-gmpy2

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-gmpy2 deb package:
      # sudo apt-get install python-gmpy2

    Files

    • /usr/lib/python2.7/dist-packages/gmpy2-2.0.7.egg-info
    • /usr/lib/python2.7/dist-packages/gmpy2.x86_64-linux-gnu.so
    • /usr/share/doc/python-gmpy2/changelog.Debian.gz
    • /usr/share/doc/python-gmpy2/copyright

    Changelog

    2016-01-18 - Matthias Klose <doko@ubuntu.com> python-gmpy2 (2.0.7-2build1) xenial; urgency=medium * No-change rebuild to drop python3.4 support.

    2015-12-02 - Martin Kelly <martin@martingkelly.com> python-gmpy2 (2.0.7-2) unstable; urgency=medium * Overhauled debian/rules to use pybuild. Things look a lot better now! Since dpkg-buildpackage -A and dpkg-buildpackage -B now work correctly, this also Closes: #805958. * Update URL in changelog to PyPi.

    2015-08-23 - Martin Kelly <martin@martingkelly.com> python-gmpy2 (2.0.7-1) unstable; urgency=medium * New upstream release * Fixed duplicate long description lintian error

    2015-06-23 - Martin Kelly <martin@martingkelly.com> python-gmpy2 (2.0.5-1) unstable; urgency=medium * New upstream release * Fixed watch file to use PyPi redirector * Removed bogus test correction patches that are now present upstream * Made the Sphinx manpage use the most recent changelog entry for build date so we get reproducible builds

    2014-11-01 - Martin Kelly <martin@martingkelly.com> python-gmpy2 (2.0.4-2) unstable; urgency=medium * Adding in upstream patch for bogus test failures. We can drop the patch at next release. Closes: #767417. * Adding Multi-Arch: foreign so that just one copy of the -common package is required for multi-arch setups.

    2014-10-26 - Martin Kelly <martin@martingkelly.com> python-gmpy2 (2.0.4-1) unstable; urgency=medium * New upstream release * Updated Standards-Version to 3.9.6.0 (no changes needed) * Using machine-readable copyright file * Copyright is GPL 3 now, not GPL 2; fixed * Fixed build error by adding -a flag to dh_* scripts * Added dh-python to Build-Depends * Dropping manpage patch (it's now fixed upstream) * Unit tests now return error code, so the package build will fail if they fail

    2014-02-23 - Martin Kelly <martin@martingkelly.com> python-gmpy2 (2.0.3-1) unstable; urgency=medium * New upstream release * Updated Standards-Version to 3.9.5.0 (no changes needed) * Changed Python 3 dev build dependency to python3-all-dev * Added Python and Python 3 as build dependencies (needed to run setup.py)

    2013-10-13 - Martin Kelly <martin@martingkelly.com> python-gmpy2 (2.0.2-1) unstable; urgency=low * New upstream release * Updated Standards-Version to 3.9.4.0 (no changes needed) * Changed rules to use default compiler hardening flags * The manpage that comes with gmpy2 is now installed on the system * Renamed package to python-gmpy2. * Now providing a python3-gmpy2 package, which works with Python 3, as well as a common package for files in common between the two packages * No longer installing the tests * Now running tests at build time * Added patch to correct manpage library section from 1 to 3

    2012-03-13 - Martin Kelly <aomighty@gmail.com> python-gmpy (1.15-1) unstable; urgency=low * New upstream release * Updated Standards-Version to 3.9.3.0 (no changes needed) * Updated the watch file to make it actually work (not sure if it really did before) * Updated debhelper compatibility level to 9 * Changed the license symlink to be more specific * Cleaned up the rules file

    2011-03-25 - Martin Kelly <aomighty@gmail.com> python-gmpy (1.14-3) unstable; urgency=low * Removed version from libgmp3-dev dependency and changed it to libgmp-dev (Closes: #619585)

    Advertisement
    Advertisement