python-glpk_0.4.52-1.1_amd64.deb


Advertisement

Description

python-glpk - Python bindings to the GNU Linear Programming Kit

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-glpk
Package version: 0.4.52
Package release: 1.1
Package architecture: amd64
Package type: deb
Installed size: 470 B
Download size: 67.67 KB
Official Mirror: archive.ubuntu.com
GLPK (GNU Linear Programming Kit) is intended for solving large-scale linear programming (LP), mixed integer programming (MIP), and other related problems. It is a set of routines written in ANSI C and organized in the form of a callable library. GLPK supports the GNU MathProg language, which is a subset of the AMPL language. GLPK also supports the standard MPS and LP formats. This is the Python bindings to GLPK.

Alternatives

Provides

  • python2.7-glpk

    Download

    Source package: python-glpk

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-glpk deb package:
      # sudo apt-get install python-glpk

    Files

    • /usr/lib/pyshared/python2.7/glpk/_glpkpi.so
    • /usr/lib/python2.7/dist-packages/glpk-0.4.52.egg-info
    • /usr/lib/python2.7/dist-packages/glpk/__init__.py
    • /usr/lib/python2.7/dist-packages/glpk/_glpkpi.so
    • /usr/lib/python2.7/dist-packages/glpk/glpk_lex.py
    • /usr/lib/python2.7/dist-packages/glpk/glpk_parser.py
    • /usr/lib/python2.7/dist-packages/glpk/glpkpi.py
    • /usr/lib/python2.7/dist-packages/glpk/model_objects.py
    • /usr/lib/python2.7/dist-packages/glpk/parsetab.py
    • /usr/share/doc/python-glpk/changelog.Debian.gz
    • /usr/share/doc/python-glpk/copyright
    • /usr/share/doc/python-glpk/readme.txt
    • /usr/share/doc/python-glpk/examples/diet.py
    • /usr/share/doc/python-glpk/examples/example.mod
    • /usr/share/doc/python-glpk/examples/example.mps
    • /usr/share/doc/python-glpk/examples/example.py
    • /usr/share/doc/python-glpk/examples/example_refman.py
    • /usr/share/doc/python-glpk/examples/test.py
    • /usr/share/doc/python-glpk/examples/models/diet.mod
    • /usr/share/doc/python-glpk/examples/models/multi.dat
    • /usr/share/doc/python-glpk/examples/models/multi.mod
    • /usr/share/doc/python-glpk/examples/models/net3.dat
    • /usr/share/doc/python-glpk/examples/models/net3.mod
    • /usr/share/doc/python-glpk/examples/models/plan.lp
    • /usr/share/doc/python-glpk/examples/models/samp1.mps
    • /usr/share/doc/python-glpk/examples/models/steel.dat
    • /usr/share/doc/python-glpk/examples/models/steel.mod
    • /usr/share/pyshared/glpk-0.4.52.egg-info
    • /usr/share/pyshared/glpk/__init__.py
    • /usr/share/pyshared/glpk/glpk_lex.py
    • /usr/share/pyshared/glpk/glpk_parser.py
    • /usr/share/pyshared/glpk/glpkpi.py
    • /usr/share/pyshared/glpk/model_objects.py
    • /usr/share/pyshared/glpk/parsetab.py

    Changelog

    2013-12-06 - S├ębastien Villemot <sebastien@debian.org> python-glpk (0.4.52-1.1) unstable; urgency=medium * Non-maintainer upload. * Upload to unstable, for glpk transition. * debian/control: remove manually added versioned dependencies on libglpk0. The shared library is now libglpk36. Also, it is unnecessary to add such versioned dependencies, because SONAME versioning ensures that the package will work with newer versions of the library, and symbols/shlibs files ensure that the minimal required version is enforced.

    2013-09-02 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.4.52-1) experimental; urgency=low * updated interface to GLPK version 4.52 * Bug fix: "glpk.glp_printf() fails", thanks to Xypron (Closes: #597017) [printf cannot be implemented due to a limitation in swig; function glp_printf is no longer available from python]. * Bug fix: "FTBFS against glpk 4.51-1", thanks to Sebastien Villemot (Closes: #714211).

    2011-08-29 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.4.45-1) unstable; urgency=low * updated interface to GLPK version 4.45 (Closes: #638649).

    2010-05-18 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.4.43-2) unstable; urgency=low * Corrected debian/control file (Closes: #573696). * Corrected debian/control file (Closes: #578424).

    2010-05-12 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.4.43-1) unstable; urgency=low * Initial release: solved some issues related to debianization. * Cannot be reproduced with current version of glpk (Closes: #577405). * Dependencies fixed; now depends on glpk 4.43 (Closes: #578424). * Cannot be reproduced (Closes: #548267).

    2010-05-04 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.3.43-4) unstable; urgency=low * added dependency to python-ply

    2010-05-03 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.3.43-3) unstable; urgency=low * using a modified local copy of glpk.h for compiling in 64 bit machines

    2010-04-29 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.3.43-2) unstable; urgency=low * bug corrections on the python Gnu MathProg's parser

    2010-04-20 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.3.43-1) unstable; urgency=low * implemented support for modifying glpk model's data in python * updated interface to GLPK version 4.43 * cleaned up code for this version

    2009-08-01 - Joao Pedro Pedroso <jpp@fc.up.pt> python-glpk (0.1.38-1) unstable; urgency=low * Version compatible with glpk v4.38

    Advertisement
    Advertisement