python-gear_0.5.8-2_all.deb


Advertisement

Description

python-gear - Pure Python Async Gear Protocol Library - Python 2.x

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-gear
Package version 0.5.8
Package release 2
Package architecture all
Package type deb
Installed size 177 B
Download size 27.60 KB
Official Mirror archive.ubuntu.com
python-gear is a pure-Python asynchronous library to interface with Gearman.
It provides interfaces to build a client or worker, and access to the
administrative protocol. The design approach is to keep it simple, with a
relatively thin abstration of the Gearman protocol itself. It should be easy
to use to build a client or worker that operates either synchronously or
asynchronously.
The module also provides a simple Gearman server for use as a convenience in
unit tests. The server is not designed for production use under load.
Installing the suggested python-statsd package would add support for reporting
to statsd a frontend to Graphite a stats collection and graphing server.
This package contains the Python 2.x module.

Alternatives

Package Version Architecture Repository
python-gear_0.5.8-2_all.deb 0.5.8 all Ubuntu Universe
python-gear - - -

Requires

Name Value
python >= 2.7
python-argparse -
python-daemon >= 2.0.4
python-extras -
python-pbr -
python2.7 -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-gear_0.5.8-2_all.deb
Source Package python-gear

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-gear deb package:
    # sudo apt-get install python-gear

Files

Path
/usr/bin/python2-geard
/usr/lib/python2.7/dist-packages/gear/__init__.py
/usr/lib/python2.7/dist-packages/gear/acl.py
/usr/lib/python2.7/dist-packages/gear/constants.py
/usr/lib/python2.7/dist-packages/gear-0.5.8.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/gear-0.5.8.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/gear-0.5.8.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/gear-0.5.8.egg-info/not-zip-safe
/usr/lib/python2.7/dist-packages/gear-0.5.8.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/gear-0.5.8.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/gear/cmd/__init__.py
/usr/lib/python2.7/dist-packages/gear/cmd/geard.py
/usr/lib/python2.7/dist-packages/gear/tests/__init__.py
/usr/lib/python2.7/dist-packages/gear/tests/test_functional.py
/usr/lib/python2.7/dist-packages/gear/tests/test_gear.py
/usr/share/doc/python-gear/changelog.Debian.gz
/usr/share/doc/python-gear/copyright

Changelog

2015-09-08 - Thomas Goirand <zigo@debian.org>
python-gear (0.5.8-2) unstable; urgency=medium
* Added Python3 support.
2015-09-08 - Thomas Goirand <zigo@debian.org>
python-gear (0.5.8-1) unstable; urgency=medium
* New upstream release.
* Merged upstream code within the packaging branch, and switching to a more
OpenStack-ish branch name (ie: debian/unstable):
- Updated debian/gbp.conf
* Fixed (build-)depends for this release.
* Removed non-active uploaders.
* Moved test related build-depends into build-depends-indep.
* Ran wrap-and-sort -t -a
* Better call unit test suite (directly with testr).
* Added missing build-depends: dh-python.
* Added missing build-depends-indep: subunit, testrepository.
* Calling testr directly instead of using python setup.py testr.
* Fixed debian/gbp.conf
* Switched to dh 9.
* Fixed debian/copyright.
* Using --buildsystem=python_distutils in debian/rules.
2015-03-16 - Antoine Musso <hashar@free.fr>
python-gear (0.5.5-2) unstable; urgency=medium
* Update Vcs-Browser and set Vcs-Git
* Remove get-orig-source
* Clean debian/gbp.conf
* Fix most lintian errors
2014-08-04 - Antoine Musso <hashar@free.fr>
python-gear (0.5.5-1) unstable; urgency=low
* New upstream version
2014-05-15 - Antoine Musso <hashar@free.fr>
python-gear (0.5.4-1) unstable; urgency=low
* New upstream version
* python-statsd is now a build dependency (required to run tests) but is
only a suggestion since the package works fine without it.
* Tweak build dependencies
* [Alexandros Kosiaris] Package predepends on dpkg (>= 1.15.6~) to fix
lintian error data.tar.xz-member-without-dpkg-pre-depends
2013-09-12 - Antoine Musso <hashar@free.fr>
python-gear (0.4.0-1) unstable; urgency=low
* Initial Version
* Closes: #725081

See Also

Package Description
python-gearman_2.0.2-2build1_all.deb Python interface to the Gearman system
python-gencpp_0.5.3-4_all.deb C++ Robot OS message and service generators
python-genetic_0.1.1b-11build1_all.deb genetic algorithms in Python
python-genlisp_0.4.15-4_all.deb Common-Lisp Robot OS message and service generators
python-genmsg_0.5.6-4_all.deb Python library for generating Robot OS message and service data
python-genometools_1.5.8-2_all.deb Python bindings for genometools
python-genpy_0.5.7-6_all.deb Python Robot OS message and service generators
python-genshi_0.7-5_amd64.deb Python XML-based template engine - Python 2.x
python-genty_1.3.0-1_all.deb Allows you to run a test with multiple data sets (Python 2)
python-geoclue_0.1.0-4build1_all.deb Python module to access Geoclue data
python-geographiclib_1.45-2_amd64.deb Python implementation of GeographicLib
python-geohash_0.8.3-1.1_amd64.deb fast, accurate Python geohashing library
python-geoip_1.3.2-1build2_amd64.deb Python bindings for the GeoIP IP-to-country resolver library
python-geojson_1.3.1-1_all.deb Python 2 bindings and utilities for GeoJSON
python-geolinks_0.2.0-1_all.deb Python 2 Library for using geospatial links (catalogue interoperablity)
Advertisement
Advertisement