python-gasp_0.3.4-2_all.deb


Advertisement

Description

python-gasp - procedural Python graphics library for beginning programmers

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-gasp
Package version: 0.3.4
Package release: 2
Package architecture: all
Package type: deb
Installed size: 157 B
Download size: 36.44 KB
Official Mirror: archive.ubuntu.com
GASP is a wrapper around the Python Cairo Graphics library which makes writing graphical applications in Python easy for beginners, requiring little prior knowledge of object-oriented programming.

Alternatives

Provides

  • python2.7-gasp

    Download

    Source package: python-gasp

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-gasp deb package:
      # sudo apt-get install python-gasp

    Files

    • /usr/lib/python2.7/dist-packages/gasp/__init__.py
    • /usr/lib/python2.7/dist-packages/gasp/api.py
    • /usr/lib/python2.7/dist-packages/gasp/backend.py
    • /usr/lib/python2.7/dist-packages/gasp/color.py
    • /usr/lib/python2.7/dist-packages/gasp-0.3.4.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/gasp-0.3.4.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/gasp-0.3.4.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/gasp/images/gasp.png
    • /usr/share/doc/python-gasp/AUTHORS
    • /usr/share/doc/python-gasp/NEWS.gz
    • /usr/share/doc/python-gasp/README
    • /usr/share/doc/python-gasp/changelog.Debian.gz
    • /usr/share/doc/python-gasp/copyright
    • /usr/share/python-gasp/gasp.png

    Changelog

    2015-07-11 - Luke Faraone <lfaraone@debian.org> python-gasp (0.3.4-2) unstable; urgency=medium [ Jakub Wilk ] * Use canonical URIs for Vcs-* fields. * Fix watch file. [ Luke Faraone ] * Switch to dh_python2 (closes: #786127) * Update to Standards Version 3.9.6, no changes needed.

    2011-02-28 - Luke Faraone <lfaraone@debian.org> python-gasp (0.3.4-1) unstable; urgency=low * New upstream version. - Fix broken image support (LP: #698122) * Update to Standards Version 3.9.1, no changes needed. * Update maintainer field to use my @debian.org address

    2010-03-24 - Luke Faraone <luke@faraone.cc> python-gasp (0.3.3-1) unstable; urgency=low [ Luca Falavigna ] * Optionally depend on python (>= 2.6) with python-multiprocessing, multiprocessing module is part of Python 2.6. [ Jakub Wilk ] * Fix watch file. [ Luke Faraone ] * New upstream version. (LP: #419501) * Bump standards version to 3.8.4. * debian/rules: Change get-orig-source to reflect upstream * Switch to dpkg-source 3.0 (quilt) format

    2009-08-21 - Luke Faraone <luke@faraone.cc> python-gasp (0.3.2-1) unstable; urgency=low * New upstream version * Bump standards version to 3.8.3 * Drop debian/patches/setuptools.patch * debian/copyright: Update copyright to reflect upstream * debian/watch: Update for new upstream download location

    2009-07-27 - Luke Faraone <luke@faraone.cc> python-gasp (0.3.0-1) unstable; urgency=low * New upstream version * Update Maintainer email address * Fixed copyright file to use the © symbol * Switch to pysupport * Fix get-orig-source in debian/rules * Fixed setup.py so that images are installed in the proper location. * debian/control: Added dependency on python-gobject, python-gtk2, and python-multiprocessing.

    2008-12-07 - Luke Faraone <lfaraone@ubuntu.com> python-gasp (0.2.1~bzr65-1) unstable; urgency=low * Initial release. (Closes: #506501)

    Advertisement
    Advertisement