python-fuzzywuzzy_0.10.0-1_all.deb


Advertisement

Description

python-fuzzywuzzy - Fuzzy string matching in Python

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-fuzzywuzzy
Package version 0.10.0
Package release 1
Package architecture all
Package type deb
Installed size 56 B
Download size 10.34 KB
Official Mirror archive.ubuntu.com
Various methods for fuzzy matching of strings in Python, including:
- String similarity: Gives a measure of string similarity between 0 and 100.
- Partial string similarity: Inconsistent substrings are a common problem
when string matching. To get around it, use a "best partial" heuristic
when two strings are of noticeably different lengths.
- Token sort: This approach involves tokenizing the string in question,
sorting the tokens alphabetically, and then joining them back into a
string.
- Token sort: A slightly more flexible approach. Tokenize both strings, but
instead of immediately sorting and comparing, split the tokens into two
groups: intersection and remainder.

Alternatives

Package Version Architecture Repository
python-fuzzywuzzy_0.10.0-1_all.deb 0.10.0 all Ubuntu Universe
python-fuzzywuzzy - - -

Requires

Name Value
python-levenshtein >= 0.12
python:any << 2.8
python:any >= 2.7.5-5~

Provides

Name Value
python2.7-fuzzywuzzy -

Download

Type URL
Binary Package python-fuzzywuzzy_0.10.0-1_all.deb
Source Package fuzzywuzzy

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-fuzzywuzzy deb package:
    # sudo apt-get install python-fuzzywuzzy

Files

Path
/usr/lib/python2.7/dist-packages/fuzzywuzzy/StringMatcher.py
/usr/lib/python2.7/dist-packages/fuzzywuzzy/__init__.py
/usr/lib/python2.7/dist-packages/fuzzywuzzy/fuzz.py
/usr/lib/python2.7/dist-packages/fuzzywuzzy/process.py
/usr/lib/python2.7/dist-packages/fuzzywuzzy/string_processing.py
/usr/lib/python2.7/dist-packages/fuzzywuzzy/utils.py
/usr/lib/python2.7/dist-packages/fuzzywuzzy-0.10.0.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/fuzzywuzzy-0.10.0.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/fuzzywuzzy-0.10.0.egg-info/pbr.json
/usr/lib/python2.7/dist-packages/fuzzywuzzy-0.10.0.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/fuzzywuzzy-0.10.0.egg-info/zip-safe
/usr/share/doc/python-fuzzywuzzy/changelog.Debian.gz
/usr/share/doc/python-fuzzywuzzy/copyright

Changelog

2016-03-21 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.10.0-1) unstable; urgency=medium
* New upstream release.
2016-03-11 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.8.1-4) unstable; urgency=medium
* debian/tests/control: fix Depends, pep8 module is now in python-pep8
2016-03-10 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.8.1-3) unstable; urgency=low
* debian/control: update Build-Depends, pep8 module is now in python-pep8 
2016-02-23 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.8.1-2) unstable; urgency=low
* debian/rules: fix invalid Vcs-Git URL 
2016-02-21 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.8.1-1) unstable; urgency=low
* New upstream release.
* debian/control: remove unneeded versions on Build-Depends
* debian/control: update Standards-Version (no changes)
* debian/control: update Vcs-Git field to use https
2015-12-22 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.8.0-2) unstable; urgency=medium
* debian/tests/control: pep8 packages are required for DEP 8 tests
2015-12-02 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.8.0-1) unstable; urgency=medium
* New upstream release.
* Add autopkgtest testsuite.
2015-10-19 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.7.0-1) unstable; urgency=medium
* New upstream release.
* Update Vcs-* control headers.
2015-09-08 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.6.2-1) unstable; urgency=medium
* New upstream release
* debian/control: add a longer extended description
2015-08-17 - Edward Betts <edward@4angle.com>
fuzzywuzzy (0.6.1-1) unstable; urgency=low
* New upstream release.
* Move to unstable. This package depends on python-levenshtein >= 0.12.0,
which recently moved from experimental to unstable.

See Also

Package Description
python-fysom_2.1.2-1_all.deb pYthOn Finite State Machine
python-gabbi-doc_1.12.0-2_all.deb declarative HTTP testing library - doc
python-gabbi_1.12.0-2_all.deb declarative HTTP testing library - Python 2.x
python-gadfly_1.0.0-16_all.deb SQL database and parser generator for Python
python-galleryremote_0.6-1.1build1_all.deb Python library for accessing Gallery web installations
python-gamera-dev_3.4.2+svn1437-2_all.deb framework for document analysis applications (header files)
python-gamera.toolkits.greekocr_1.0.1-7_all.deb toolkit for building OCR systems for polytonal Greek
python-gamera.toolkits.ocr_1.2.2-2_all.deb toolkit for building OCR systems
python-gamera_3.4.2+svn1437-2_amd64.deb framework for building document analysis applications
python-gamin_0.1.10-5_amd64.deb Python binding for the gamin client library
python-gammu_2.5-1_amd64.deb Python module to communicate with mobile phones (Python 2)
python-ganeti-rapi_2.15.2-3_all.deb cluster virtualization manager - RAPI client library
python-gasp_0.3.4-2_all.deb procedural Python graphics library for beginning programmers
python-gastables_0.3-2.2_all.deb compressible flow gas table modules for Python
python-gccjit-doc_0.4-5_all.deb Python bindings for libgccjit (documentation)
Advertisement
Advertisement