python-flickrapi_2.1.2-4_all.deb


Advertisement

Description

python-flickrapi - Flickr API wrapper for Python 2

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-flickrapi
Package version: 2.1.2
Package release: 4
Package architecture: all
Package type: deb
Installed size: 109 B
Download size: 23.80 KB
Official Mirror: archive.ubuntu.com
Python-flickrapi is a complete and easy to use Python module for interfacing with the Flickr API (see https://www.flickr.com/services/api/ for details on the Flickr API). the main features are: - keeping track of authentication credentials (no need to pass them on every Flickr API call) - caching of API calls - support for uploading and replacing photos - support for different XML parsers This package installs the library for Python 2.

Alternatives

    Download

    Source package: python-flickrapi

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-flickrapi deb package:
      # sudo apt-get install python-flickrapi

    Files

    • /usr/lib/python2.7/dist-packages/README.txt
    • /usr/lib/python2.7/dist-packages/UPGRADING.txt
    • /usr/lib/python2.7/dist-packages/flickrapi/__init__.py
    • /usr/lib/python2.7/dist-packages/flickrapi/auth.py
    • /usr/lib/python2.7/dist-packages/flickrapi/cache.py
    • /usr/lib/python2.7/dist-packages/flickrapi/call_builder.py
    • /usr/lib/python2.7/dist-packages/flickrapi/contrib.py
    • /usr/lib/python2.7/dist-packages/flickrapi/core.py
    • /usr/lib/python2.7/dist-packages/flickrapi/exceptions.py
    • /usr/lib/python2.7/dist-packages/flickrapi/html.py
    • /usr/lib/python2.7/dist-packages/flickrapi/shorturl.py
    • /usr/lib/python2.7/dist-packages/flickrapi/sockutil.py
    • /usr/lib/python2.7/dist-packages/flickrapi/tokencache.py
    • /usr/lib/python2.7/dist-packages/flickrapi/xmlnode.py
    • /usr/lib/python2.7/dist-packages/flickrapi-2.1.2.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/flickrapi-2.1.2.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/flickrapi-2.1.2.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/flickrapi-2.1.2.egg-info/top_level.txt
    • /usr/lib/python2.7/dist-packages/flickrapi-2.1.2.egg-info/zip-safe
    • /usr/share/doc/python-flickrapi/changelog.Debian.gz
    • /usr/share/doc/python-flickrapi/copyright

    Changelog

    2016-01-13 - Thomas Schmidt <tschmidt@debian.org> python-flickrapi (2.1.2-4) unstable; urgency=low * Fixed typo in package description of python3-flickrapi (closes: #810801)

    2016-01-11 - Thomas Schmidt <tschmidt@debian.org> python-flickrapi (2.1.2-3) unstable; urgency=low * Added python3-flickrapi package (closes: #810648) + Additional build-depends: - python-requests-oauthlib/python3-requests-oauthlib - python-nose/python3-nose - python3-all - python3-setuptools - python3-requests-toolbelt + Updated python versions and build-depends to >= 2.7 and >= 3.2 * Small updates to the package description

    2016-01-10 - Thomas Schmidt <tschmidt@debian.org> python-flickrapi (2.1.2-2) unstable; urgency=low * Close the whishlist ticket for the 1.2-3.1 upload (closes: #769958) * Deprecated md5-module is not used in 2.1.2 anymore (closes: #603691) * Integrated changes from Petter Reinholdtsen: + Build-depend on python-all-dev instead of python-all + Switched source-format to 3.0 (quilt) + Use updated debian/watch * Converted change to setup.py to quilt patch do-not-install-LICENSE-txt.diff * Removed other local changes * Updated years in debian/copyright

    2016-01-06 - Thomas Schmidt <tschmidt@debian.org> python-flickrapi (2.1.2-1) unstable; urgency=medium * New upstream release (closes: #573719) * Acknowledge NMUs (closes: #769722, #786019) * Changed Standards-Version to 3.9.6 * Updated debian/watch, use pypi.debian.net redirector service * debian/rules: added missing target build-arch to fix Lintian warning * Avoid installation of extra LICENSE.txt referencing just the Python license to fix Lintian warning * Changed debhelper compat level to 9, build-depend on debhelper (>= 9) * Build-Depend on python-requests-toolbelt, required by new upstream version

    2012-04-21 - Olivier Berger <oberger@ouvaton.org> python-flickrapi (1.4.2-1) UNRELEASED; urgency=low * New upstream release

    2010-12-13 - Thomas Schmidt <tschmidt@debian.org> python-flickrapi (1.4.1-1) experimental; urgency=low * New upstream release (closes: #573719)

    2015-10-19 - Ross Gammon <rossgammon@mail.dk> python-flickrapi (1.2-3.2) unstable; urgency=medium * Non-maintainer upload. * Port from python-support to dh-python (Closes: #786019) * Replace XS-Python-Version with X-Python-Version

    2014-11-17 - Petter Reinholdtsen <pere@debian.org> python-flickrapi (1.2-3.1) unstable; urgency=low * Non-maintainer upload to get module working again. * Change API URLs from http to https to get them working with the current Flickr API where SSL is required (Closes: #769722). * Add missing ${misc:Depends} to dependency list. * Add --prefix=/usr to setup run in rules file to make sure the documentation end up in /usr/share/doc/, not /usr/local/share/doc/.

    2009-05-29 - Thomas Schmidt <tschmidt@debian.org> python-flickrapi (1.2-3) unstable; urgency=low * Improved package long description (closes: #531014)

    2009-05-14 - Thomas Schmidt <tschmidt@debian.org> python-flickrapi (1.2-2) unstable; urgency=low * First upload to debian (closes: #528612) * Updated debian/copyright * Bumped Standards-Version to 3.8.1 * Changed Upstream homepage in debian/control * Added Vcs-Git and Vcs-Browser fields to debian/control * Updated package short description * Fixed debian/watch

    Advertisement
    Advertisement