python-flake8_2.5.4-2_all.deb


Advertisement

Description

python-flake8 - code checker using pep8 and pyflakes - Python 2.x

Property Value
Distribution Ubuntu 16.04 LTS (Xenial Xerus)
Repository Ubuntu Universe amd64
Package name python-flake8
Package version 2.5.4
Package release 2
Package architecture all
Package type deb
Installed size 124 B
Download size 25.86 KB
Official Mirror archive.ubuntu.com
Flake8 is a wrapper around PyFlakes, pep8, and Ned's McCabe script. Flake8
runs all tools by launching the single 'flake8' script, but ignores pep8 and
PyFlakes extended options and just uses defaults. It displays the warnings in
a per-file, merged output.
This package provides Python 2 module bindings only.

Alternatives

Package Version Architecture Repository
python-flake8_2.5.4-2_all.deb 2.5.4 all Ubuntu Universe
python-flake8 - - -

Requires

Name Value
pep8 -
pyflakes -
python-mccabe >= 0.2.1
python-pep8 >= 1.5.7
python-pyflakes >= 0.8.1
python-setuptools -
python:any >= 2.7.5-5~
python:any << 2.8

Download

Type URL
Binary Package python-flake8_2.5.4-2_all.deb
Source Package python-flake8

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install python-flake8 deb package:
    # sudo apt-get install python-flake8

Files

Path
/usr/lib/python2.7/dist-packages/flake8/__init__.py
/usr/lib/python2.7/dist-packages/flake8/__main__.py
/usr/lib/python2.7/dist-packages/flake8/_pyflakes.py
/usr/lib/python2.7/dist-packages/flake8/callbacks.py
/usr/lib/python2.7/dist-packages/flake8/compat.py
/usr/lib/python2.7/dist-packages/flake8/engine.py
/usr/lib/python2.7/dist-packages/flake8/hooks.py
/usr/lib/python2.7/dist-packages/flake8/main.py
/usr/lib/python2.7/dist-packages/flake8/reporter.py
/usr/lib/python2.7/dist-packages/flake8/run.py
/usr/lib/python2.7/dist-packages/flake8/util.py
/usr/lib/python2.7/dist-packages/flake8-2.5.4.egg-info/PKG-INFO
/usr/lib/python2.7/dist-packages/flake8-2.5.4.egg-info/dependency_links.txt
/usr/lib/python2.7/dist-packages/flake8-2.5.4.egg-info/entry_points.txt
/usr/lib/python2.7/dist-packages/flake8-2.5.4.egg-info/requires.txt
/usr/lib/python2.7/dist-packages/flake8-2.5.4.egg-info/top_level.txt
/usr/lib/python2.7/dist-packages/flake8/tests/__init__.py
/usr/lib/python2.7/dist-packages/flake8/tests/_test_warnings.py
/usr/lib/python2.7/dist-packages/flake8/tests/test_engine.py
/usr/lib/python2.7/dist-packages/flake8/tests/test_hooks.py
/usr/lib/python2.7/dist-packages/flake8/tests/test_integration.py
/usr/lib/python2.7/dist-packages/flake8/tests/test_main.py
/usr/lib/python2.7/dist-packages/flake8/tests/test_pyflakes.py
/usr/lib/python2.7/dist-packages/flake8/tests/test_reporter.py
/usr/lib/python2.7/dist-packages/flake8/tests/test_util.py
/usr/share/doc/python-flake8/changelog.Debian.gz
/usr/share/doc/python-flake8/copyright

Changelog

2016-03-14 - Barry Warsaw <barry@debian.org>
python-flake8 (2.5.4-2) unstable; urgency=medium
* Team upload.
* debian/patches/update-pyflakes-version.patch: Allow for pyflakes 1.1.
* debian/watch: Use the pypi.debian.net redirector.
2016-03-01 - Sylvestre Ledru <sylvestre@debian.org>
python-flake8 (2.5.4-1) unstable; urgency=medium
[ Sylvestre Ledru ]
* Team upload
* New upstream release
* Update of the standard version
* Update of the homepage
* Depends on python-pyflakes/python3-pyflakes instead of pyflakes
(Closes: #804741)
* Run the test suite when building the package
* Cherry-pick Ubuntu changes
[ Jackson Doak ]
* debian/tests/tools: Call flake8 on some actual files (setup.py as a
known-good one, and a synthetic one for a known-bad one) instead of
without arguments on an empty directory. Closes: #742482
[ Ondřej Nový ]
* Standards-Version is 3.9.7 now (no change).
* Vcs-Git changed to https.
* Added python-pyflakes and dh-python to Build-Depend.
* Removed useless XS-Testsuite.
* Added myself to d/copyright.
* Added myself as uploader.
* d/copyright: Cleanup.
* Removed python-mock from Debian tests dependency - it's not needed.
* Moved /usr/bin/flake8 to solo package.
* Changed architecture of python3-flake8 to all.
2015-10-23 - Matthias Klose <doko@ubuntu.com>
python-flake8 (2.2.2-1ubuntu4) xenial; urgency=medium
* Add explicit dependency on setuptools. LP: #1509396.
* python-flake8: (Build)-Depend on python-pep8 instead of pep8.
2015-10-15 - Barry Warsaw <barry@ubuntu.com>
python-flake8 (2.2.2-1ubuntu2) wily; urgency=medium
* d/patches/py35-compat.patch: Added for Python 3.5 compatibility.
2015-01-23 - Liam Young <liam.young@canonical.com>
python-flake8 (2.2.2-1ubuntu1) vivid; urgency=medium
* Merge from Debian testing. Remaining changes:
- debian/rules: Run tests during package build.
- debian/tests/tools: Call flake8 on some actual files (setup.py as a
known-good one, and a synthetic one for a known-bad one) instead of
without arguments on an empty directory.
2014-07-16 - Zygmunt Krynicki <zygmunt.krynicki@canonical.com>
python-flake8 (2.2.2-1) unstable; urgency=medium
* Team upload.
* New upstream release
* debian/control: update Standards-Version to 3.9.5.0 (no change)
* debian/rules: remove unused PY2_PACAKGE_NAME and PY3_PACKAGE_NAME
* debian/control: change architecture to 'arch: all' since there are
no binary or otherwise arch-specific executables in this package
* debian/control: correct dependencies for python3-flake8 (python3-pep8
instead of pep8, remove python3-flake8)
* debian/copyright: add current upstream maintainer copyright
* debian/control: add Suggest: python-mock to python-flake8, this is
required to run the tests
* debian/tests/control: install python-mock to let tests run, note that
tests are currently relying on the executable which is currently
python2-only so no similar changes are made to the python3 side of the
package
* debian/control: bump dependencies as required by flake8
2014-04-13 - Thomas Goirand <zigo@debian.org>
python-flake8 (2.1.0-2) unstable; urgency=medium
* Added debian/py{3,}dist-overrides for pyflakes.
* Ran wrap-and-sort.
2014-07-25 - Chuck Short <zulcss@ubuntu.com>
python-flake8 (2.1.0-1ubuntu2) utopic; urgency=medium
* debian/rules: Run tests during package build.
2014-03-24 - Martin Pitt <martin.pitt@ubuntu.com>
python-flake8 (2.1.0-1ubuntu1) trusty; urgency=medium
* debian/tests/tools: Call flake8 on some actual files (setup.py as a
known-good one, and a synthetic one for a known-bad one) instead of
without arguments on an empty directory.
2013-11-05 - Jackson Doak <noskcaj@ubuntu.com>
python-flake8 (2.1.0-1) unstable; urgency=low
* Team upload.
* New upstream release
* Add manpage. Closes: #722704
* debian/control:
- Update versioned depends
* Make basic autopkgtest

See Also

Package Description
python-flaky_3.1.0-1_all.deb Plugin for nose or py.test that automatically reruns flaky tests (Python 2)
python-flask-api-common_0.6.4+dfsg-1_all.deb Browsable web APIs for the Flask micro web framework - static resources
python-flask-api_0.6.4+dfsg-1_all.deb Browsable web APIs for the Flask micro web framework - Python 2.X
python-flask-autoindex-doc_0.6-1_all.deb automatically generated index pages for Flask applications (documentation)
python-flask-autoindex_0.6-1_all.deb automatically generated index pages for Flask applications (Python 2)
python-flask-babel-doc_0.9-2.1_all.deb internationalization and localization support for Flask (documentation)
python-flask-babel_0.9-2.1_all.deb internationalization and localization support for Flask
python-flask-flatpages-doc_0.6-1_all.deb Provides flat static pages to a Flask application (doc)
python-flask-flatpages_0.6-1_all.deb Provides flat static pages to a Python 2 Flask application
python-flask-httpauth_2.2.1-1_all.deb Basic and Digest HTTP authentication for Flask routes
python-flask-login_0.2.6-1_all.deb user session management for Flask
python-flask-migrate_1.7.0-1_all.deb SQLAlchemy database migrations for Flask applications using Alembic
python-flask-openid-doc_1.2.5+dfsg-2_all.deb OpenID support for Flask applications (documentation)
python-flask-openid_1.2.5+dfsg-2_all.deb OpenID support for Flask applications (Python 2)
python-flask-principal_0.4.0-1build1_all.deb identity management for Flask
Advertisement
Advertisement