python-fdsend_0.2.1-2_amd64.deb


Advertisement

Description

python-fdsend - Provides an abstraction for file descriptor passing via sockets

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-fdsend
Package version: 0.2.1
Package release: 2
Package architecture: amd64
Package type: deb
Installed size: 87 B
Download size: 10.83 KB
Official Mirror: archive.ubuntu.com
fdsend is yet another file descriptor passing abstraction, specifically for Python. This package offers a few conveniences not commonly found together in other abstractions: sending multiple files at once, sending arbitrary data, and working with both files and file descriptors.

Alternatives

Provides

  • python2.7-fdsend

    Download

    Source package: fdsend

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-fdsend deb package:
      # sudo apt-get install python-fdsend

    Files

    • /usr/lib/pyshared/python2.7/_fdsend.so
    • /usr/lib/python2.7/dist-packages/_fdsend.so
    • /usr/lib/python2.7/dist-packages/fdsend/__init__.py
    • /usr/lib/python2.7/dist-packages/fdsend/tests.py
    • /usr/lib/python2.7/dist-packages/fdsend-0.2.1.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/fdsend-0.2.1.egg-info/SOURCES.txt
    • /usr/lib/python2.7/dist-packages/fdsend-0.2.1.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/fdsend-0.2.1.egg-info/top_level.txt
    • /usr/share/doc/python-fdsend/changelog.Debian.gz
    • /usr/share/doc/python-fdsend/copyright
    • /usr/share/pyshared/fdsend/__init__.py
    • /usr/share/pyshared/fdsend/tests.py
    • /usr/share/pyshared/fdsend-0.2.1.egg-info/PKG-INFO
    • /usr/share/pyshared/fdsend-0.2.1.egg-info/SOURCES.txt
    • /usr/share/pyshared/fdsend-0.2.1.egg-info/dependency_links.txt
    • /usr/share/pyshared/fdsend-0.2.1.egg-info/top_level.txt

    Changelog

    2011-08-23 - Fabian Knittel <fabian.knittel@avona.com> fdsend (0.2.1-2) unstable; urgency=low * Convert to dh_python2.

    2011-08-23 - Fabian Knittel <fabian.knittel@avona.com> fdsend (0.2.1-1) unstable; urgency=low * New upstream release: + Fixes integer size mismatches on 64 bit architectures.

    2011-08-16 - Philipp Kern <pkern@debian.org> fdsend (0.2.0-1) unstable; urgency=low * Initial upload. (Closes: #634173) * debian/control: set priority to optional * Set source version to 3.0 (quilt) and exclude .gbp.conf from being considered as a change to the upstream source.

    2010-05-18 - Fabian Knittel <fabian.knittel@avona.com> fdsend (0.1-5) fsmi-lenny; urgency=low * Change build dependency from python-dev to python-all-dev, so that it correctly builds against all available Python versions.

    2010-05-10 - Fabian Knittel <fabian.knittel@avona.com> fdsend (0.1-4) fsmi-lenny; urgency=low * Use lenny's debhelper instead of a debhelper backport. * Change to source version 1.0 (from 3.0 quilt).

    2010-05-05 - Philipp Kern <pkern@debian.org> fdsend (0.1-3) local; urgency=low * Build-depend on debhelper >= 7.4 as --buildsystem is not supported by the debhelper in Lenny. * Build-depend on python-dev to get the appropriate header files.

    2010-05-04 - Fabian Knittel <fabian.knittel@avona.com> fdsend (0.1-2) local; urgency=low * Clarified license and origin of the code.

    2010-05-02 - Fabian Knittel <fabian.knittel@avona.com> fdsend (0.1-1) local; urgency=low * Initial release.

    Advertisement
    Advertisement