python-docker_1.8.0-0ubuntu1_all.deb


Advertisement

Description

python-docker - Python wrapper to access docker.io's control socket

Distribution: Ubuntu 16.04 LTS (Xenial Xerus)
Repository: Ubuntu Universe amd64
Package name: python-docker
Package version: 1.8.0
Package release: 0ubuntu1
Package architecture: all
Package type: deb
Installed size: 159 B
Download size: 28.41 KB
Official Mirror: archive.ubuntu.com
This package contains oodles of routines that aid in controling docker.io over it's socket control, the same way the docker.io client controls the daemon. This package provides Python 2 module bindings only.

    Download

    Source package: python-docker

    Install Howto

    1. Update the package index:
      # sudo apt-get update
    2. Install python-docker deb package:
      # sudo apt-get install python-docker

    Files

    • /usr/lib/python2.7/dist-packages/docker/__init__.py
    • /usr/lib/python2.7/dist-packages/docker/client.py
    • /usr/lib/python2.7/dist-packages/docker/constants.py
    • /usr/lib/python2.7/dist-packages/docker/errors.py
    • /usr/lib/python2.7/dist-packages/docker/tls.py
    • /usr/lib/python2.7/dist-packages/docker/version.py
    • /usr/lib/python2.7/dist-packages/docker/api/__init__.py
    • /usr/lib/python2.7/dist-packages/docker/api/build.py
    • /usr/lib/python2.7/dist-packages/docker/api/container.py
    • /usr/lib/python2.7/dist-packages/docker/api/daemon.py
    • /usr/lib/python2.7/dist-packages/docker/api/exec_api.py
    • /usr/lib/python2.7/dist-packages/docker/api/image.py
    • /usr/lib/python2.7/dist-packages/docker/api/network.py
    • /usr/lib/python2.7/dist-packages/docker/api/volume.py
    • /usr/lib/python2.7/dist-packages/docker/auth/__init__.py
    • /usr/lib/python2.7/dist-packages/docker/auth/auth.py
    • /usr/lib/python2.7/dist-packages/docker/ssladapter/__init__.py
    • /usr/lib/python2.7/dist-packages/docker/ssladapter/ssl_match_hostname.py
    • /usr/lib/python2.7/dist-packages/docker/ssladapter/ssladapter.py
    • /usr/lib/python2.7/dist-packages/docker/unixconn/__init__.py
    • /usr/lib/python2.7/dist-packages/docker/unixconn/unixconn.py
    • /usr/lib/python2.7/dist-packages/docker/utils/__init__.py
    • /usr/lib/python2.7/dist-packages/docker/utils/decorators.py
    • /usr/lib/python2.7/dist-packages/docker/utils/types.py
    • /usr/lib/python2.7/dist-packages/docker/utils/utils.py
    • /usr/lib/python2.7/dist-packages/docker/utils/ports/__init__.py
    • /usr/lib/python2.7/dist-packages/docker/utils/ports/ports.py
    • /usr/lib/python2.7/dist-packages/docker_py-1.8.0.egg-info/PKG-INFO
    • /usr/lib/python2.7/dist-packages/docker_py-1.8.0.egg-info/dependency_links.txt
    • /usr/lib/python2.7/dist-packages/docker_py-1.8.0.egg-info/not-zip-safe
    • /usr/lib/python2.7/dist-packages/docker_py-1.8.0.egg-info/requires.txt
    • /usr/lib/python2.7/dist-packages/docker_py-1.8.0.egg-info/top_level.txt
    • /usr/share/doc/python-docker/changelog.Debian.gz
    • /usr/share/doc/python-docker/copyright

    Changelog

    2016-04-11 - Pierre-André MOREY <pierre-andre.morey@canonical.com> python-docker (1.8.0-0ubuntu1) xenial; urgency=medium * Update to 1.8.0 upstream release. - Dropped d/p/0002-Fix-Unix-adapter-bug-with-newer-versions-of-requests.patch Applied upstream.

    2015-11-08 - Tianon Gravi <tianon@debian.org> python-docker (1.5.0-1) unstable; urgency=medium * Update to 1.5.0 upstream release.

    2015-07-28 - Tianon Gravi <admwiggin@gmail.com> python-docker (1.3.1-1) unstable; urgency=medium * Update to 1.3.1 upstream release.

    2015-07-20 - Tianon Gravi <admwiggin@gmail.com> python-docker (1.3.0-2) unstable; urgency=medium * Update 01_requirements.patch to reflect that the requirements are actually stored in no less than three separate files (Closes: #793024). * Add a DEP8 test that runs upstream's integration tests to verify basic functionality. * Patch the default API version down one notch to match src:docker.io (to be removed when Docker 1.7+ gets into the archive).

    2015-07-16 - Tianon Gravi <admwiggin@gmail.com> python-docker (1.3.0-1) unstable; urgency=medium * Update to 1.3.0 upstream release.

    2015-07-02 - Tianon Gravi <admwiggin@gmail.com> python-docker (1.2.3-1) unstable; urgency=medium * Update to 1.2.3 upstream release (Closes: #790817).

    2015-03-29 - Tianon Gravi <admwiggin@gmail.com> python-docker (1.2.2-2) unstable; urgency=medium * Relax requests dependency slightly to account for the accidental misupload to unstable.

    2015-03-29 - Tianon Gravi <admwiggin@gmail.com> python-docker (1.2.2-1) unstable; urgency=medium * Update to 1.2.2 upstream release (Closes: #781355) * Update debian/watch to use the pypi.debian.net redirector * Update Build-Depends, 01_requirements.patch, and comment in debian/rules regarding tests

    2014-11-13 - Tianon Gravi <admwiggin@gmail.com> python-docker (0.5.3-2) unstable; urgency=medium * Remove 02_use-system-urllib3.patch thanks to the fix in requests

    2014-11-01 - Jakub Warmuz <jakub@warmuz.org> python-docker (0.5.3-1.1) unstable; urgency=medium * Non-maintainer upload. * Added debian/patches/02_use-system-urllib3.patch (Closes: #767445). * Renamed debian/patches/requirements.patch to debian/patches/01_requirements.patch following convention from other Python packages.

    Advertisement
    Advertisement